Xfce Forum

Sub domains
 

You are not logged in.

#1 2008-01-22 14:44:00

lmo
Member
Registered: 2008-01-22
Posts: 7

Thunar does not generate thumbnails. [Solved]

Is it is possible for Thunar to generate thumbnails without having gnome installed?
Please help me find out how to do this.

I installed my system without any gnome components.
I understand, therefore, that Thunar would not be making use of any GNOME thumbnailers.
I installed Thunar-0.8.0-installer.run
I tried to follow the instructions for Customizing Thunar
However, I have not been able to get Thunar to generate any thumbnails.
I would like to see thumbnails for image files such as png, jpg, gif, etc.

Offline

#2 2008-01-25 16:28:37

Mark7
Member
Registered: 2007-10-05
Posts: 37

Re: Thunar does not generate thumbnails. [Solved]

If you have a package manager there's a thumbnails plugin for Thunar in there

Offline

#3 2008-01-25 17:22:59

lmo
Member
Registered: 2008-01-22
Posts: 7

Re: Thunar does not generate thumbnails. [Solved]

The response is appreciated.
However, if you mean the thunar thumbnail plugin at xfce goodies I have tried that, but still get no thumbnails for gif, png, jpg, etc image files.

Offline

#4 2008-01-29 22:43:29

siafok
Member
Registered: 2007-01-11
Posts: 5

Re: Thunar does not generate thumbnails. [Solved]

maybe you have "Show thumbnails" in Thunar "Preferences" switched off?

Offline

#5 2008-01-31 18:12:05

lmo
Member
Registered: 2008-01-22
Posts: 7

Re: Thunar does not generate thumbnails. [Solved]

siafok wrote:

maybe you have "Show thumbnails" in Thunar "Preferences" switched off?

No, I have "Show thumbnails" in Thunar "Preferences" switched on.

Offline

#6 2008-02-01 15:47:29

Wapush
Member
Registered: 2006-12-14
Posts: 140

Re: Thunar does not generate thumbnails. [Solved]

You need to install some development libraries like libjpeg62-dev and libexif-dev(Debian, X/Ubuntu) before building Thunar.

Offline

#7 2008-02-02 01:16:16

lmo
Member
Registered: 2008-01-22
Posts: 7

Re: Thunar does not generate thumbnails. [Solved]

Wapush wrote:

You need to install some development libraries like libjpeg62-dev and libexif-dev(Debian, X/Ubuntu) before building Thunar.

./configure for thunar shows

checking for jpeg_start_decompress in -ljpeg... yes
checking jpeglib.h usability... yes
checking jpeglib.h presence... yes
checking for jpeglib.h... yes
...
checking for libexif >= 0.6.0... 0.6.13
checking EXIF_CFLAGS...
checking EXIF_LIBS... -lexif -lm
checking whether to build the thunar-sbr plugin... yes

and I see

root@lfs:/# whereis libjpeg
libjpeg: /usr/lib/libjpeg.a /usr/lib/libjpeg.so /usr/lib/libjpeg.la
root@lfs:/# whereis libexif
libexif: /usr/lib/libexif.la /usr/lib/libexif.a /usr/lib/libexif.so /usr/include/libexif
root@lfs:/# ls -l /usr/lib/libjpeg*
-rw-r--r-- 1 root root 166420 2007-07-11 12:26 /usr/lib/libjpeg.a
-rwxr-xr-x 1 root root    469 2007-07-11 12:26 /usr/lib/libjpeg.la
lrwxrwxrwx 1 root root     17 2007-12-08 17:19 /usr/lib/libjpeg.so -> libjpeg.so.62.0.0
lrwxrwxrwx 1 root root     17 2007-12-08 17:19 /usr/lib/libjpeg.so.62 -> libjpeg.so.62.0.0
-rwxr-xr-x 1 root root 142806 2007-07-11 12:26 /usr/lib/libjpeg.so.62.0.0

What else should I check that is needed for thunar to generate thumbnails?

By the way, if gimp creates a thumbnail for an image, Thunar does show the thumbnail for that image.

Offline

#8 2008-02-02 15:55:35

lmo
Member
Registered: 2008-01-22
Posts: 7

Re: Thunar does not generate thumbnails. [Solved]

Solved!

I installed shared-mime-info
I ran update-mime-database /usr/share/mime
I ran thunar -q

Afterwards, Thunar generated thumbnails  roll

Offline

Board footer

Powered by FluxBB