Xfce Forum

Sub domains
 

You are not logged in.

#1 2008-09-06 14:46:52

boldoran
Member
Registered: 2008-09-06
Posts: 4

[Solved] Xfce Terminal Transparency

Hello

I am trying to enable true transparency in the xfce Terminal. The compositor in Window Manager Tweaks is enabled and it works well on non active windows etc. I can also change the transparency of a window by pressing ALT and moving the mouswheel while hoovering over a Window Border.

What i have not been able to make work however is the built-in transparency of the Terminal. I enabled the Transparent Background option in the Appearance menu of the Terminal preferences. However this has no effect at all on my Terminal.

here are some debuging informations

muse markus # terminal -v
Terminal 0.2.8 (Xfce 4.4.2)

Copyright (c) 2003-2007
        os-cillation e.K. All rights reserved.

Written by Benedikt Meurer <benny@xfce.org>.

Built with Gtk+-2.12.10, running with Gtk+-2.12.10.

Please report bugs to <http://bugzilla.xfce.org/>.

From the terminal config (gentoo ebuild):

...
checking whether VTE supports real transparency... yes
...

The X Server gives me a VTE related warning:
VTE-warning **: No handler for control sequence 'device-control-string' definde

I can move the shade transparent slider around as much as i like but there is no response.
What am I doing wrong?

Offline

#2 2008-09-06 16:31:25

edward
Member
From: Boston
Registered: 2008-03-23
Posts: 11

Re: [Solved] Xfce Terminal Transparency

Launch the terminal.

Select Edit/Preferences/Appearance.

Change the item in the Background pull-down list to Transparent Background and click Close.  You should immediately have a transparent background.


[img]http://img.userbars.pl/135/26800.png[/img]
Xubuntu 9.10

Offline

#3 2008-09-06 18:07:09

boldoran
Member
Registered: 2008-09-06
Posts: 4

Re: [Solved] Xfce Terminal Transparency

@Edward

boldoran wrote:

I enabled the Transparent Background option in the Appearance menu of the Terminal preferences. However this has no effect at all on my Terminal.

I am afraid that is not working for me. This setting seems to have absolutly no effect. I still get the black default background.

Offline

#4 2008-09-07 11:13:41

mmassonnet
Moderator
From: the milky way galaxy
Registered: 2006-07-30
Posts: 99
Website

Re: [Solved] Xfce Terminal Transparency

Do you have the compositor running?  Go to Settings > Window Manager Tweaks, and go to the last tab Compositor.  There you can enable and disable the compositor.

If you don't have the Compositor tab you need to rebuild xfwm4 (hint: xfwm4 --help).


Mike

Offline

#5 2008-09-09 13:16:51

boldoran
Member
Registered: 2008-09-06
Posts: 4

Re: [Solved] Xfce Terminal Transparency

Yes the compositor is up an running as described in my first post. No Terminal transparency though.

Offline

#6 2008-09-22 17:47:53

boldoran
Member
Registered: 2008-09-06
Posts: 4

Re: [Solved] Xfce Terminal Transparency

Ok I reinstalled my whole Gentoo System (Never try to allocate free disk space into a new partition using Windows Vista btw  :-x )

Anyway the true transparency works now. It might have something to do with the fact that I installed newer nvidia drivers this time (173.14.12) or there might be another library that did not get updated correctly before.

Whatever it was the transparency works now. Although I still need to set nvidia-settings -a InitialPixmapPlacement=2 for the Terminal application to open in acceptable timespans.

Offline

Board footer

Powered by FluxBB