Xfce Forum

Sub domains
 

You are not logged in.

#1 2009-03-10 06:03:58

haiyy
Member
Registered: 2009-03-10
Posts: 2

I have to login twice everytime

I'm using Xfce 4.6 on ubuntu 8.04.
There is only a arrow on the desktop every time when I login by gdm. It seems that nothing starts but the xfce-session, but when I login again, everything is OK!
If I logout or reboot, such strange events repeat. I have tried to delete the directory .cache before gdm runs the xfce-session. It doesn't work.
How to fix it? Thanks for concerning.

Offline

#2 2009-03-10 11:40:45

xfcelav
Member
From: /var/www/xfcelav
Registered: 2008-04-10
Posts: 94
Website

Re: I have to login twice everytime

It's easy. In your home creates a file named. / Session as follows:

nano /home/your_user/.xsession

and inside it put this:

#!/bin/bash
exec /bin/sh /usr/local/etc/xdg/xfce4/xinitrc

And close the sesion..


url: blog.desdelinux.net
twt: @elavdeveloper

Offline

#3 2009-03-10 12:48:20

haiyy
Member
Registered: 2009-03-10
Posts: 2

Re: I have to login twice everytime

Thank you, but it doesn't work either.
I set "Display chooser on login" in "Session Manager settings" and set up a new session, then if I choose the new session, I can log in successfully.
Now,I have to choose a session every time, how to remove the default session?

Offline

#4 2009-03-10 13:06:34

xfcelav
Member
From: /var/www/xfcelav
Registered: 2008-04-10
Posts: 94
Website

Re: I have to login twice everytime

If you use Xfce, do not use GDM in the end you install many packages that will not use Gnome. Slim and used as you see it works. If you do not work so hixiste only deletes the file. Xsession point and ...


url: blog.desdelinux.net
twt: @elavdeveloper

Offline

Board footer

Powered by FluxBB