Xfce Forum

Sub domains
 

You are not logged in.

#1 2009-09-16 22:13:58

KitchM
Member
Registered: 2009-08-15
Posts: 90

Mouse has no wheel action (Resolved)

My fresh install of Arch/Xfce4.6.1 shows a mouse and it is working, except for the wheel.  I am not sure if this is an Xfce issue or an X issue.  As Xfce has no hardware configurator, and the mouse applet only lists Mouse0, and /etc/X11/xorg.conf shows:
InputDriver    "Mouse 0"    "CorePointer"

as well as,

Driver    "mouse"
Option   "Device"   "/dev/input/mice/"
Option   "Protocol"   "PS/2"
Option   "ZAxismapping"   "4 5 6 7"

, and there is no place to change details of the mouse hardware, I cannot decide the correct way to proceed and get the wheel working.  So I thought it best to ask here.

Does anyone have any ideas?

Thanks very much.

Offline

#2 2009-09-21 06:17:29

KitchM
Member
Registered: 2009-08-15
Posts: 90

Re: Mouse has no wheel action (Resolved)

Okay, this was interesting.  I think I found the solution (because it's working perfectly as far as I can tell  :-| ).

I have a PS/2-type mouse with a center wheel/button.  I'd think it was pretty common.  The problem seemed to be the X configuration.  So, here's what seemed to work.

Note the lines commented-out and/or added in the following section of xorg.conf:
Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option        "Device" "/dev/input/mice"
#    Option        "Protocol" "PS/2"
    Option      "Protocol" "auto"
    Option      "Buttons" "5"
    Option        "ZAxisMapping" "4 5 6 7"
#    Option      "SendCoreEvents" "true"
EndSection

Evidently, the automatic process did not get the identification of the mouse correct, nor did it know how many buttons to use.  It doesn't seem to make a difference what one does during the install of the X environment.  Worse yet, it appears that the only source of information is either the programmer's documentation or some obscure, but helpful explanation from someone with some smarts who got it figured out and was kind enough to write it down in simple language.  I used the latter.

Obviously, once you get it set right, you'll want to make darn sure this is not changed again.  So, I recommend adding the following section:
Section "ServerFlags"
    Option    "AutoAddDevices" "False"
EndSection

That should do it.

Offline

Board footer

Powered by FluxBB