Xfce Forum

Sub domains

You are not logged in.

#1 2009-12-27 17:22:55

Registered: 2009-12-27
Posts: 4

Why Xfce4.6.1 takes so long to startup?

Why Xfce 4.6.1 takes about 5-10 sec to load? LXDE loads in a sec.
I have disabled support for KDE/Gnome and I only load guake on startup.
Is there any way to run a kind of profiler to tell me which process consumes the most time?
Is startup disk write intensive? (I am on a Disk On Module SSD, writes really slow when relatively filled, despite being SLC)


#2 2009-12-27 21:48:26

From: Idaho
Registered: 2005-12-25
Posts: 291

Re: Why Xfce4.6.1 takes so long to startup?

Thats because Xfce has evolved from what the LXde folks forked from hah
Whats all running after Xfce starts?  Could be a number of things, it starts in a flash here on older hw.  I'm guessing xfce4-settings-helper, sometimes it takes its time starting (can be started from Autostarted Apps so you don't "see it")


#3 2009-12-28 10:07:29

From: Germany
Registered: 2006-05-18
Posts: 143

Re: Why Xfce4.6.1 takes so long to startup?

I had a similar startup speed issue after upgrading from 4.4 to 4.6 on xubuntu.

removing ~/.config/xfce4* and ~/.cache/xfce4/ while no xfce was running did the trick.




#4 2009-12-28 15:55:43

Registered: 2009-08-15
Posts: 92

Re: Why Xfce4.6.1 takes so long to startup?

The complexity of the boot process at all levels is one of the biggest problems in computing.  As I continue to study the experts documentation for each stage, I find that they don't all agree.  That just makes it more confusing.

At the particular level where you load X, you have not loaded Xfce, but the two often load together; one right after the other from the same command.  The best you can do with X is look at its config file, where you have all your video and keyboard and mouse settings, etc..

With Xfce, we do need a step-by-step, detailed listing of what happens upon startup.  The only ones who know authoritatively are those who coded it.  That sort of documentation is the single most important part of any project.  Without it, it remains difficult to diagnose.

My suggestion is to go to the Settings Manager, Session and Startup, Application Autostart tab and uncheck everything.  This is what sOulslack's suggestion was all about, and is a very good one.  Also, don't save the session on shutdown, so that you can start fresh each time.  (Same applet, under General, Logout Settings, etc..)   That may help some.  Good luck.


Board footer

Powered by FluxBB