Xfce Forum

Sub domains
 

You are not logged in.

#1 2009-01-24 03:11:46

One Salient Oversight
Member
Registered: 2009-01-24
Posts: 9

"Allow xfce to manage your desktop" problem

The more I check this out on the net, the more common this problems seems to be. Hopefully someone here can point me into the right direction.

I run Xubuntu 8.10. I used to run Kubuntu but 4.x gave me nightmares and slowed everything down.

Now I use xfce. I like it. It is simple. It makes everything else faster. It may not look great but it works.

But not always.

I have this problem that whenever I log in under my username, the desktop is being run by gnome. I have to go to Settings Manager --> Desktop and manually check "Allow xfce to manage your desktop" every single time I log in.

I've seen some solutions around the net, but nothing that has worked yet.

Can someone please give me a list of things to try that will solve this problem so that every time I log in, xfce is the default.

Before anyone asks, Settings Manager --> Settings and Startup --> General --> Logout settings --> Automatically save session on logout is checked.

Update: This is not a joke. This is a serious request. Does anyone try to help at these forums or should I go somewhere else?

Offline

#2 2009-01-27 10:47:11

s0ulslack
Moderator
From: Idaho
Registered: 2005-12-25
Posts: 291

Re: "Allow xfce to manage your desktop" problem

Dang, your attitude is probably whats keeping the help.  You wanna threatin to leave and go else where for help, go.... don't threaten, learn manners.

Secondly, you started nautilus with out --no-desktop which caused it to kill xfdesktop.  You appreantly saved the session like this too, so killall -9 nautilus and relaunch xfdesktop or go back into Settings-> Desktop-> Tick Allow Xfce to manage Desktop

Offline

#3 2009-01-28 12:40:27

One Salient Oversight
Member
Registered: 2009-01-24
Posts: 9

Re: "Allow xfce to manage your desktop" problem

I said please, no one replied. I've had better experiences in other Linux forums.

Having said that I checked ksysguard and killed nautilus. The problem is fixed. I appreciate your help substantially.

Offline

#4 2009-09-28 17:00:40

infinitelink
Member
Registered: 2009-06-21
Posts: 7

Re: "Allow xfce to manage your desktop" problem

We're talking about mixing components of DEs here, so a prolem arises. One can keep killing Nautilus, and also not let it start with the session, but when anybody runs Gnome apps that rely on Nautilus, Nautilus is going to start, and the problem will keep recurring. I've posted a solution that, if you find it useful, please refer others to it (that is, the link to my blog),

http://cmpstuff.blogspot.com/2009/09/se … sktop.html

I've tried posting it into the forums (Ubuntu's), but unfortunately I always encounter the 'you don't have permission to post [bla bla bla]' problem there, despite being a LONG time registered user: there's a REAL bug (this problem is not) for you. : ( [with teardrop]

Anyways, enjoy to all who need the solution. : )

Offline

#5 2010-02-15 22:01:10

Skara Brae
Member
Registered: 2010-02-14
Posts: 2

Re: "Allow xfce to manage your desktop" problem

s0ulslack wrote:

Secondly, you started nautilus with out --no-desktop which caused it to kill xfdesktop.  You appreantly saved the session like this too, so killall -9 nautilus and relaunch xfdesktop or go back into Settings-> Desktop-> Tick Allow Xfce to manage Desktop

Since a few weeks, I had the same thing happening - Nautilus taking over my Xubuntu 8.04 desktop (I thought Nautilus was only a file manager).

@s0oulslack: Thank you for your "killall"-command tip.

@infinitelink: I saved your blog (page) in my Bookmarks (and the text, too), in case I ever need it again. Thank you very much for the link.


Registered Linux User #495429
----------
HP Vectra VL420 (modded): Pentium4 (1.6 GHz) // 1024 MB SDRAM // Geforce 6600GT // Xubuntu 8.04 (Xfce/Fluxbox)

Offline

#6 2010-02-28 20:27:44

KitchM
Member
Registered: 2009-08-15
Posts: 90

Re: "Allow xfce to manage your desktop" problem

One Salient Oversight, I too have noticed the sorts of problems you've experienced.  I also hope you do not put too much weight on what soulslaker wrote.  I think he means well.  I find that three days without a comment by anyone is quite a long time, and the frustration we experience over these more obvious problems is certainly legitimate.  While not a direct part of the development team, I support you and apologise for the lack of empathy.

Infinitelink has shown some wonderful capability to explain the problems with the DE.  I certainly applaud his efforts and his insight.  We need more of this.

I invite you all to take part in my little discussion of the problems of the environment at this link:
http://wiki.xfce.org/dev/system-wide-settings

Offline

Board footer

Powered by FluxBB