Xfce Forum

Sub domains
 

You are not logged in.

#1 2007-07-25 00:24:35

lagbot
Member
Registered: 2007-07-25
Posts: 1

Mouse Themes in Xfce4 - Debian Etch

I'm having a strange problem with my mouse theme.  I downloaded the Red Hat 9 theme and installed it to /usr/share/cursors/x11-xorg/redhat9cursors.  It shows up in the Mouse options and for some applications, such as Thunar, it works, but for most programs, like Iceweasel, it reverts to the standard xorg cursor.  As the title says, I'm running the latest apt-get of Xfce4 under Debian Etch.  This likely isn't an Xfce problem, but any help would be appreciated.

Offline

#2 2007-07-30 08:54:41

MtheF
Member
Registered: 2004-03-21
Posts: 26

Re: Mouse Themes in Xfce4 - Debian Etch

I have the same problem. Also Debian Etch.
For example resizing windows on the xfce-border doesn't work,
and it's always the standard cursor on the background.

It is the same with all mouse themes.

Offline

#3 2007-07-31 15:29:07

MtheF
Member
Registered: 2004-03-21
Posts: 26

Re: Mouse Themes in Xfce4 - Debian Etch

HI again!

I solved it! Not a nice solution, but it works... partly atleast.
And this is for DEBIAN!

There are many different places to set the cursor. Here orderd, the first is the one
I think is most important...
1: debian alternatives
2: Xdefaults
3: xfce-settings
4: gtkrc
5: just fill in...

1 Update alternatives
root>> uptade-alternatives --config x-cursor-theme
If your mouse theme isn't there you have to add it. Try
looking in "man update-alternatives", "/var/lib/dpkg/alternatives/x-cursor-theme" and
"/etc/alternatives/"

2 Xdefaults
in "~/.Xdefault" add (if it doesn't exist create it)
Xcursor.theme: cursortheme
Xcursor.size: 32
(The size is optional)

3 Xfce-settings
Just go to settings and select your theme

4 gtkrc
in "~/.gtkrc-2.0" add
gtk-cursor-theme-name="themename"
gtk-cursor-theme-size=32

I don't know what steps you need to make, but try from the top.

Good luck  smile
/Martin

I can also recomend the theme tuxcursor:
http://xfce-look.org/content/show.php?c … 8d070dbf30

Offline

#4 2007-07-31 15:56:18

mzilikazi
Member
Registered: 2004-07-17
Posts: 3

Re: Mouse Themes in Xfce4 - Debian Etch

There is a simpler way.  Simply drop your mouse theme in ~/.icons  No need to edit anything or change /etc/alternatives.

Offline

#5 2007-07-31 16:39:29

MtheF
Member
Registered: 2004-03-21
Posts: 26

Re: Mouse Themes in Xfce4 - Debian Etch

I hoped that would work but it didn't for me sad
xfce and some other apps didn't use the theme.

Offline

#6 2007-12-14 11:00:17

Jouke74
Member
Registered: 2007-12-14
Posts: 3

Re: Mouse Themes in Xfce4 - Debian Etch

Make sure you install the cursors theme on the right location.

/usr/X11R6/lib/X11/icons/ "Theme here" also make sure there is an index file.
(Most theme installers will do that automagically).

To use the theme in X-server, GDM and XFCE4 use the following command in the terminal (Ubuntu) other's may need to login using root.

"sudo update-alternatives --config x-cursor-theme"

And select the theme you want.

Somehow XFCE4 does not have root access to the X-server mouse theme when runned as user desktop :-)

Offline

#7 2007-12-15 12:44:59

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,144
Website

Offline

#8 2010-03-14 12:34:09

theHand
Member
Registered: 2010-03-13
Posts: 1

Re: Mouse Themes in Xfce4 - Debian Etch

Offline

Board footer

Powered by FluxBB