Xfce Forum

Sub domains
 

You are not logged in.

#1 2010-03-25 22:05:36

woodsman
Member
Registered: 2007-08-17
Posts: 3
Website

Not Loading Thunar and D-Bus During Startup

How can I prevent Thunar and d-bus from loading during Xfce startup?

I have been fiddling with a kiosk project (web browser appliance) using Xfce and an old PII system. With this project I don't need these apps running in the background.

I can run a script in the Xfce autostart section to kill Thunar, which frees valuable memory on this old box, but preventing Thunar from loading would shave some overhead during the boot process.

I do not have d-bus running in the boot scripts. I commented out the associated d-bus lines in the xfce xinitrc script, but d-bus loads nonetheless.

Thanks much.

Offline

#2 2010-03-26 20:53:45

herd
Member
From: Germany
Registered: 2006-05-18
Posts: 143
Website

Re: Not Loading Thunar and D-Bus During Startup

Beginning with xfce 4.6, many things are using DBus.
Giving ubuntu karmic as exemplary:

~$ apt-cache rdepends libdbus-glib-1-2|grep xf|sort
  libxfcegui4-4
  libxfconf-0-2
  xfce4-cddrive-plugin
  xfce4-clipman-plugin
  xfce4-governor-plugin
  xfce4-messenger-plugin
  xfce4-notes-plugin
  xfce4-notifyd
  xfce4-power-manager
  xfce4-power-manager-plugins
  xfce4-session
  xfce4-settings
  xfce4-smartpm-plugin
  xfce4-terminal
  xfce4-utils
  xfce4-verve-plugin
  xfce4-volstatus-icon
  xfconf
  xfdesktop4
  xfmedia
  xfmedia-remote-plugin
  xfwm4
~$ 

e.g. xfconf does not work without d-bus, so you'll get no settings.
Better revert to 4.4.

hth,

herd

Offline

Board footer

Powered by FluxBB