Xfce Forum

Sub domains
 

You are not logged in.

#1 2010-11-11 13:41:15

videodrome
Member
Registered: 2010-11-11
Posts: 7

Please help a beginner install 4.8pre over existing 4.6.2 Xubuntu

Hello, can you please help me with the following questions?

Please answer in beginner terminology, even though I have installed Xfce in the past.

1) Can I install the 4.8 components over top of the 4.6.2 components on an Xubuntu 10.10 installation?

2) If so, do you just unzip the files and do a configure/make/make install for each one?

3) Is there a list of dependencies I need first, and are they all in the Ubuntu repository?

4) What order do you install the files in?

5) Is there anything else that I need to know?

Thank you!

Offline

#2 2010-11-11 19:10:20

jeromeg
Moderator
From: France
Registered: 2010-11-11
Posts: 131
Website

Re: Please help a beginner install 4.8pre over existing 4.6.2 Xubuntu

If you are a beginner, it is not advised to:
- install stuff which is not packaged by your distribution.
- run versions which are not labelled as stable.

If you really want to test 4.8pre1, I advise you to wait until it is available in the Xubuntu Team Dev PPA: https://launchpad.net/~xubuntu-dev/+archive/ppa That way you won't mess with your system.

Offline

#3 2011-02-24 15:33:25

gregg128
Member
Registered: 2011-02-24
Posts: 3

Re: Please help a beginner install 4.8pre over existing 4.6.2 Xubuntu

are there any playns to update this PPA soon ?
tnx.

Offline

#4 2011-02-25 16:35:43

xfcelav
Member
From: /var/www/xfcelav
Registered: 2008-04-10
Posts: 94
Website

Re: Please help a beginner install 4.8pre over existing 4.6.2 Xubuntu

Install on Debian Squeeze

#sudo aptitude install build-essential intltool libglib2.0-dev libdbus-glib-1-dev xserver-xorg-dev libgtk2.0-dev libstartup-notification0-dev libgladeui-1-dev libglade2-dev python-gtk2-dev libwnck-dev libexif-dev libfreetype6-dev libjpeg62-dev libpng12-dev libgudev-1.0-dev libnotify-dev libxklavier-dev libcanberra-dev libgconf2-dev libgnome-keyring1.0-cil-dev libgnome-keyring-dev libgamin-dev libhal-storage-dev

#!/bin/bash
# Script - installazione automatizzata XFCE4.8.0 per ubuntu
# Script - Automatic Installation XFCE4.8.0 for ubuntu

#Testato su Ubuntu 10.04.1 (32bit) e Ubuntu 10.10 (64bit)
#Tested su Ubuntu 10.04.1 (32bit) and Ubuntu 10.10 (64bit)

#Utilizzo: copiare questo script nel punto dove si vogliono scaricare/compilare i sorgenti ed eseguirlo
#Usage: copy this script to the point where you want to download / compile source and run it

sudo apt-get install build-essential intltool libglib2.0-dev libdbus-glib-1-dev xserver-xorg-dev libgtk2.0-dev libstartup-notification0-dev libgladeui-1-dev libglade2-dev python-gtk2-dev libwnck-dev libexif-dev libfreetype6-dev libjpeg62-dev libpng12-dev libgudev-1.0-dev libnotify-dev libxklavier-dev libcanberra-dev libgconf2-dev libgnome-keyring1.0-cil-dev libgnome-keyring-dev libgamin-dev libhal-storage-dev

wget -c http://archive.xfce.org/xfce/4.8/fat_tarballs/xfce-4.8.tar.bz2
tar xfvj xfce-4.8.tar.bz2
cd src

tar xfvj libxfce4util-4.8.1.tar.bz2
cd libxfce4util-4.8.1/
./configure --prefix=/usr
make
sudo make install
cd ..

tar xfvj xfconf-4.8.0.tar.bz2
cd xfconf-4.8.0/
./configure --prefix=/usr
make
sudo make install
cd ..

tar xfvj libxfce4ui-4.8.0.tar.bz2
cd libxfce4ui-4.8.0/
./configure --prefix=/usr
make
sudo make install
cd ..

tar xfvj libxfcegui4-4.8.0.tar.bz2
cd libxfcegui4-4.8.0/
./configure --prefix=/usr
make
sudo make install
cd ..

tar xfvj exo-0.6.0.tar.bz2
cd exo-0.6.0/
./configure --prefix=/usr
make
sudo make install
cd ..

#Scarico garcon
wget -c http://archive.xfce.org/src/libs/garcon/0.1/garcon-0.1.5.tar.bz2
tar xfvj garcon-0.1.5.tar.bz2
cd garcon-0.1.5/
./configure --prefix=/usr
make
sudo make install
sudo cp data/xfce/xfce-applications.menu /etc/xdg/menus/
cd ..

tar xfvj xfce4-panel-4.8.0.tar.bz2
cd xfce4-panel-4.8.0/
./configure --prefix=/usr
make
sudo make install
cd ..

tar xfvj Thunar-1.2.0.tar.bz2
cd Thunar-1.2.0/
./configure --prefix=/usr
make
sudo make install
cd ..

tar xfvj xfce4-settings-4.8.0.tar.bz2
cd xfce4-settings-4.8.0/
./configure --enable-sound-settings --enable-pluggable-dialogs --prefix=/usr
make
sudo make install
cd ..

tar xfvj xfce4-session-4.8.0.tar.bz2
cd xfce4-session-4.8.0/
./configure --prefix=/usr --enable-libgnome-keyring
make
sudo make install
cd ..

tar xfvj xfdesktop-4.8.0.tar.bz2
cd xfdesktop-4.8.0/
./configure --prefix=/usr
make
sudo make install
cd ..

tar xfvj xfwm4-4.8.0.tar.bz2
cd xfwm4-4.8.0/
./configure --prefix=/usr
make
sudo make install
cd ..

tar xfvj xfce-utils-4.8.0.tar.bz2
cd xfce-utils-4.8.0/
./configure --prefix=/usr
make
sudo make install
cd ..

tar xfvj xfce4-appfinder-4.8.0.tar.bz2
cd xfce4-appfinder-4.8.0/
./configure --prefix=/usr
make
sudo make install
cd ..

tar xfvj gtk-xfce-engine-2.8.0.tar.bz2
cd gtk-xfce-engine-2.8.0/
./configure --prefix=/usr
make
sudo make install
cd ..

tar xfvj thunar-vfs-1.2.0.tar.bz2
cd thunar-vfs-1.2.0/
./configure --prefix=/usr
make
sudo make install
cd ..

http://archive.be2.xfce.org/src/xfce/libxfce4menu/4.6/libxfce4menu-4.6.2.tar.bz2
tar xfvj libxfce4menu-4.6.2.tar.bz2
cd libxfce4menu-4.6.2/
./configure --prefix=/usr
make
sudo make install

Last edited by xfcelav (2011-02-25 16:37:10)


url: blog.desdelinux.net
twt: @elavdeveloper

Offline

Board footer

Powered by FluxBB