Xfce Forum

Sub domains
 

You are not logged in.

#1 2010-12-20 23:35:33

hcmeyer
Member
From: Shelbyville, KY USA
Registered: 2010-12-20
Posts: 3

building sample plugin

I am trying to build the sample panel plugin on narwhal. autogen does not complete, three questions:

1) what is the appropriate "autoconf macro directory" to copy codeset.m4 etc. to ? I have tried /usr/share/autoconf/autoconf/

2) where is the file isc-posix.m4 from ? I don't have it on my system, and google does not produce good clues.

3) configure:4014 produces error: possibly undefined macro: m4_ifval. The  macro is defined in /usr/share/autoconf/m4sugar/m4sugar.m4.

Offline

#2 2010-12-25 08:38:59

mmassonnet
Moderator
From: the milky way galaxy
Registered: 2006-07-30
Posts: 99
Website

Re: building sample plugin

When building something from git, install xfce4-dev-tools.

http://git.xfce.org/xfce/xfce4-dev-tools/
http://archive.xfce.org/src/xfce/xfce4-dev-tools/


Mike

Offline

#3 2010-12-25 13:33:27

hcmeyer
Member
From: Shelbyville, KY USA
Registered: 2010-12-20
Posts: 3

Re: building sample plugin

Installed them, and a lot of other pgming stuff suggested by apt-get.
To answer my own questions the macros ended up in /usr/share/xfce4/dev-tools/m4macros/
I found some text to put in isc-posix, it is ? no longer needed ?
I have a ./configure, but it fails with:

checking for a sed that does not truncate output... /bin/sed
./configure: line 4012: syntax error near unexpected token `lt_decl_varnames,'
./configure: line 4012: `lt_if_append_uniq(lt_decl_varnames, SED, , ,'

Similar errors google up from building Apache, they are blamed on version incompatibilities between autoconf and libtool. Currntly, autoconf is version 2.67 and libtool is 2.2.6b, automake is 1.11.1

I am researching. Merry Christmas.

Offline

#4 2011-01-07 18:05:30

hcmeyer
Member
From: Shelbyville, KY USA
Registered: 2010-12-20
Posts: 3

Re: building sample plugin

I am now able to build recent plugins from git, like the xfce4-sensors plugin, but the sample plugin is about 18 months old, and will not build. Since most of the autogen work is done by xdt-autogen in the dev package, it should work. Of course "should" means nothing. Back to research.

Offline

Board footer

Powered by FluxBB