Xfce Forum

Sub domains
 

You are not logged in.

#1 2011-01-07 19:57:32

lphilpot
Member
From: Louisiana, USA
Registered: 2011-01-07
Posts: 11
Website

[Solved] Building 4.6.2 on RHEL6 - libwnck-1.0 dependency ?

I'm trying to build 4.6.2 on a new RHEL 6 install. I downloaded the tarball and have 10 of the 15 packages built. The remainder have a dependency on libwnck-1.0. For example, from xfce4-panel-4.6.4:

checking for libwnck-1.0 >= 2.20... not found
checking for libwnck-1.0 >= 2.12... not found
*** The required package libwnck-1.0 was not found on your system.
*** Please install libwnck-1.0 (atleast version 2.12) or adjust
*** the PKG_CONFIG_PATH environment variable if you
*** installed the package in a nonstandard prefix so that
*** pkg-config is able to find it.

Looking at the system, I see this:

# echo $PKG_CONFIG_PATH
/usr/lib:/usr/lib/pkgconfig:/usr/local/lib/pkgconfig

# rpm -qa | grep wnck
gnome-python2-libwnck-2.28.0-4.el6.i686
libwnck-2.28.0-2.el6.i686

# yum list installed | grep -i wnck
gnome-python2-libwnck.i686              2.28.0-4.el6                          @anaconda-RedHatEnterpriseLinux-201009221732.i386/6.0
libwnck.i686                            2.28.0-2.el6                          @anaconda-RedHatEnterpriseLinux-201009221732.i386/6.0

So, is there a difference between libwnck and libwnck-1.0? Googling so far hasn't differentiated the two for me, but I might be just missing it. I searched the forums and although 'libwnck' turned up a few interesting posts, nothing seems to apply to my situation. Some refereneced having libXres* installed, which I have:

# rpm -qa | grep -i xres
libXres-1.0.4-1.el6.i686

I've googled and tried various packages, but I always just descend into dependency hell, which shouldn't be the case with a current, new (virtually "everything") install.  :-\  There are apparently no other libwnck* packages in the default yum repository RHEL6 is looking at (and to tell the truth, I'm just inexperienced enough with yum to be unsure of how to tell it to look elsewhere, even if I knew where).

What obvious thing am I overlooking here? Or even better, is there a fully-satisfied binary xfce RPM available somewhere? I gotta get off Gnome / KDE4... :-)

Thanks!

Last edited by lphilpot (2011-01-07 22:52:57)

Offline

#2 2011-01-08 15:02:52

mmassonnet
Moderator
From: the milky way galaxy
Registered: 2006-07-30
Posts: 99
Website

Re: [Solved] Building 4.6.2 on RHEL6 - libwnck-1.0 dependency ?

Hello,

Looks like you are missing the libwnck-devel package for libwnck.

I don't know much about enabling repositories in Yum, or in particular RHEL6, but this package is the one you need. It contains the header files for compilation and the pkgconfig file.

Kind Regards


Mike

Offline

#3 2011-01-08 17:00:46

lphilpot
Member
From: Louisiana, USA
Registered: 2011-01-07
Posts: 11
Website

Re: [Solved] Building 4.6.2 on RHEL6 - libwnck-1.0 dependency ?

Kinda what I thought, too, based on some of the things I found. So far, I've had no luck locating a version-matching libwnck-devel package that will install without further (missing) dependencies. This is interesting, since when I installed RHEL6,  I included all the development libraries...

Guess I'll keep looking.

Thanks!

Offline

#4 2011-01-18 20:12:42

lphilpot
Member
From: Louisiana, USA
Registered: 2011-01-07
Posts: 11
Website

Re: [Solved] Building 4.6.2 on RHEL6 - libwnck-1.0 dependency ?

It was indeed libwnck-devel that was needed, but I had to add libXres and libXres-devel first. That took care of it.

Thanks for the help, although my timing was as impeccable as usual since 4.8 was imminent and I'll now have to uninstall 4.6 to get there.  :-)

Offline

Board footer

Powered by FluxBB