Xfce Forum

Sub domains
 

You are not logged in.

#1 2011-01-08 19:35:09

tezer
Member
Registered: 2011-01-08
Posts: 4

[Solved] "Staritng nautilus" problem

Hi all,

I am using Xfce  4.6.1 (Xubuntu 10.04) and some time ago occasionally installed Nautilus. I wouldn't mind having it on my disk, but struggle between Nautilus and Thunar for desktop management was annoying and I decided to remove Nautilus (sudo apt-get remove --purge nautilus*)
Now Nautilus is gone, but every time I start my computer the start up screen (with a running mouse) says "Starting nautilus" and does (tries to do?) something for about 10 seconds. After that it proceeds with autostart.
The problem isn't big and I don't mind waiting for a little more every time Xfce starts, but I guess it should be quite easy to just remove a line somewhere in a config file.

So the question is, what I should edit to make my Xfce forget about Nautilus?

In ~/.cache/sessions I found file xfce4-session-compname:0 with four lines containing "nautilus":
Code:
Client0_CloneCommand=nautilus
Client0_DiscardCommand=/bin/rm,-rf,/home/username/.config/session-state/nautilus-1292007222.desktop
Client0_Program=nautilus
Client0_RestartCommand=nautilus,--sm-client-id,2b7bf197d-6c39-47cd-a3cc-f9c83d7a7c1a
I tried to comment them out with # but nothing changed: after re-logging in the file was the same("Starting nautilus" also appeared at start up), I also re-installed xubuntu-desktop and got a right session file without any mention of Nautilus in it. The first boot was ok (without "Starting nautilus"), but by the next boot the session file was overwritten to the version that contains Nautilus.

What can write to ~/.cache/sessions/xfce4-session-compname:0?

If it may help, the output of sudo find / -type f -name *nautilus* is:

Code:
/usr/share/locale-langpack/en_GB/LC_MESSAGES/nautilus-share.mo
/usr/share/locale-langpack/en_GB/LC_MESSAGES/nautilus-sendto.mo
/usr/share/locale-langpack/en_GB/LC_MESSAGES/nautilus.mo
/usr/share/locale-langpack/en_AU/LC_MESSAGES/nautilus-sendto.mo
/usr/share/locale-langpack/en_AU/LC_MESSAGES/nautilus.mo
/usr/share/locale-langpack/en@shaw/LC_MESSAGES/nautilus-sendto.mo
/usr/share/locale-langpack/en@shaw/LC_MESSAGES/nautilus.mo
/usr/share/locale-langpack/en_CA/LC_MESSAGES/nautilus-share.mo
/usr/share/locale-langpack/en_CA/LC_MESSAGES/nautilus-sendto.mo
/usr/share/locale-langpack/en_CA/LC_MESSAGES/nautilus.mo
/usr/share/app-install/icons/nautilus-cd-burner.png
/usr/share/app-install/icons/nautilus-scripts-manager.svg
/usr/share/app-install/icons/nautilus-pastebin.png
/usr/share/app-install/icons/nautilus-actions.png
/usr/share/app-install/desktop/nautilus-cd-burner.desktop
/usr/share/app-install/desktop/nautilus-pastebin-configurator.desktop
/usr/share/app-install/desktop/nautilus-scripts-manager.desktop
/usr/share/gnome/help/user-guide/C/figures/nautilus_restore_saved_search.png
/usr/share/gnome/help/user-guide/C/gosnautilus.xml
/usr/share/gnome/help-langpack/user-guide/en_AU/gosnautilus.xml
/usr/share/gnome/help-langpack/user-guide/en_CA/gosnautilus.xml
/usr/share/mime/application/x-nautilus-link.xml
/usr/lib/python2.6/dist-packages/ubuntutweak/modules/nautilus.py
/usr/lib/python2.6/dist-packages/ubuntutweak/modules/nautilus.pyc
/home/username/.config/session-state/nautilus-1292007222.desktop
/home/username/.local/share/Trash/info/.nautilus.trashinfo
/home/username/.gnome2/accels/nautilus
/home/username/Downloads/Apps/Utilities/Dropbox/nautilus-dropbox-0.6.2.tar.bz2
/var/lib/dpkg/info/nautilus-data.postrm
/var/lib/dpkg/info/nautilus-data.list
/var/lib/dpkg/info/libnautilus-extension1.postrm
/var/lib/dpkg/info/nautilus.postrm
/var/lib/dpkg/info/libnautilus-extension1.list
/var/lib/dpkg/info/nautilus.list

Offline

#2 2011-01-13 17:33:10

mmassonnet
Moderator
From: the milky way galaxy
Registered: 2006-07-30
Posts: 99
Website

Re: [Solved] "Staritng nautilus" problem

Nautilus has a hidden setting to never run in desktop mode:
gconftool-2 /apps/nautilus/preferences/show_desktop -t bool -s false


Mike

Offline

#3 2011-01-13 19:35:53

tezer
Member
Registered: 2011-01-08
Posts: 4

Re: [Solved] "Staritng nautilus" problem

mmassonnet wrote:

Nautilus has a hidden setting to never run in desktop mode:
gconftool-2 /apps/nautilus/preferences/show_desktop -t bool -s false

Thanks, but that just hides the desktop but nautilus still starts.

Offline

#4 2011-01-15 09:32:09

mmassonnet
Moderator
From: the milky way galaxy
Registered: 2006-07-30
Posts: 99
Website

Re: [Solved] "Staritng nautilus" problem

tezer wrote:
mmassonnet wrote:

Nautilus has a hidden setting to never run in desktop mode:
gconftool-2 /apps/nautilus/preferences/show_desktop -t bool -s false

Thanks, but that just hides the desktop but nautilus still starts.

In that case the following will help:

Copied from Gigolo

you may need to add the following lines to your ~/.local/share/applications/defaults.list so that Thunar is used to open folders by gvfs-open:

x-directory/gnome-default-handler=Thunar.desktop
inode/directory=Thunar.desktop
x-directory/normal=Thunar.desktop

Let us know if that worked for you.


Mike

Offline

#5 2011-01-15 11:07:32

tezer
Member
Registered: 2011-01-08
Posts: 4

Re: [Solved] "Staritng nautilus" problem

mmassonnet wrote:
tezer wrote:
mmassonnet wrote:

Nautilus has a hidden setting to never run in desktop mode:
gconftool-2 /apps/nautilus/preferences/show_desktop -t bool -s false

Thanks, but that just hides the desktop but nautilus still starts.

In that case the following will help:

Copied from Gigolo

you may need to add the following lines to your ~/.local/share/applications/defaults.list so that Thunar is used to open folders by gvfs-open:

x-directory/gnome-default-handler=Thunar.desktop
inode/directory=Thunar.desktop
x-directory/normal=Thunar.desktop

Let us know if that worked for you.

Thanks, but it didn't work either.
I also tried reinstalling nautilus and running it with
nautilus --sm-disable
It solved the problem of automatic modification of file .cache/sessions/xfce4-session-compname:0  but nautilus still starts every time I log in. And it is not possible to stop it even with nautilus -q it keeps restarting itself every time.
It looks like I need to get rid of gnome-session-bin altogether, but I am afraid it may damage my Xfce desktop as it will remove gdm and xubuntu-desktop.
Nautilus behaves just like a virus... I don't really want to re-install my system, but Nautilus starting every time I load my Xfce is annoying.

Offline

#6 2011-01-15 13:48:44

mmassonnet
Moderator
From: the milky way galaxy
Registered: 2006-07-30
Posts: 99
Website

Re: [Solved] "Staritng nautilus" problem

To make sure Nautilus is not in the session, log out, erase (or rename) the ~/.cache/sessions directory. Now log in again. If Nautilus is running it is executed by a script or a startup file (it will eventually save itself again in the session).


Mike

Offline

#7 2011-01-15 15:16:47

tezer
Member
Registered: 2011-01-08
Posts: 4

Re: [Solved] "Staritng nautilus" problem

mmassonnet wrote:

To make sure Nautilus is not in the session, log out, erase (or rename) the ~/.cache/sessions directory. Now log in again. If Nautilus is running it is executed by a script or a startup file (it will eventually save itself again in the session).

Looks like deleting the whole ~/.cache helped (I overdid it a little). Although new ~/.cache/sessions (with Nautilus mentioned in several strings) was created on log out and I failed to delete being logged out (didn't have permissions to do so), after the next log in there was no "Starting nautilus" scum. I checked the session file, it still mentioned Nautilus. After another log-out log-in routine the file changed again and did not have any string with Nautilus.
To be honest, I don't know what happened and what was changing the file, but I am glad I've got rid of the annoyance.
Thank you.

Offline

Board footer

Powered by FluxBB