Xfce Forum

Sub domains
 

You are not logged in.

#1 2011-01-17 18:54:18

xfcelav
Member
From: /var/www/xfcelav
Registered: 2008-04-10
Posts: 94
Website

How Install Xfce 4.8 on Debian

Greetings:
I have installed LMDE (Linux Mint Debian Edition) which uses the Debian Testing repositories. I downloaded the. run Xfce 4.8 and when I try to install I get this error in terminal:

Checking for GLib (GModule) >= 2.6.0... not found, see /home/elav/.xfce4.installer-log for details

I searched the logs:

## Checking for GLib (GModule) >= 2.6.0
pkg-config --atleast-version=2.6.0 glib-2.0 gmodule-2.0
!! Please install GLib 2.6.0 or above and the GLib development files. It is
!! important that you install GModule, which is part of GLib as well. GLib
!! can be downloaded from http://www.gtk.org/.

and the packages I have installed need not, however, I have installed this package whose description reads:

i gir1.0-glib-2.0 - Introspection data for GLib, GObject, Gio and GModule 

url: blog.desdelinux.net
twt: @elavdeveloper

Offline

#2 2011-01-18 08:57:06

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,144
Website

Re: How Install Xfce 4.8 on Debian

Do you have the -devel packages installed?

Offline

#3 2011-01-18 10:47:22

nekron29
Member
Registered: 2011-01-17
Posts: 6

Re: How Install Xfce 4.8 on Debian

@xfcelav

Hi there...

I managed to compile xfce 4.8 on ubuntu 10.10; the first thing is to install development libraries (as nick told you) and dependencies.

For ubuntu (you need to test it in debian) i have installed the following in a terminal :

sudo apt-get install build-essential intltool libavahi-gobject-dev libdbus-glib-1-dev xserver-xorg-dev libgtk2.0-dev libstartup-notification0-dev libwnck-dev libgudev-1.0-dev libnotify-dev libxklavier-dev

there will be also other packages that will need to be installed, choose yes and everything will be installed.

After that compile sau recompile everything in the following order :

1. libxfce4util
2.xfconf
3. libxfce4ui
4. garcon
5. exo
6. xfce4-panel
7. thunar
8. thunar-vfs
9. xfce4-settings
10. xfce4-session
11. xfdesktop
12. xfwm4
13. xfce-utils
14. xfce4-appfinder
15. gtk-xfce-engine

This is what i have done on my laptop and it worked fine; see my other post about Ubuntu for details regarding the menu issue..

cheers..

Last edited by nekron29 (2011-01-18 10:47:53)

Offline

#4 2011-01-18 13:24:59

xfcelav
Member
From: /var/www/xfcelav
Registered: 2008-04-10
Posts: 94
Website

Re: How Install Xfce 4.8 on Debian

nekron29 wrote:

@xfcelav

Hi there...

I managed to compile xfce 4.8 on ubuntu 10.10; the first thing is to install development libraries (as nick told you) and dependencies.

For ubuntu (you need to test it in debian) i have installed the following in a terminal :

sudo apt-get install build-essential intltool libavahi-gobject-dev libdbus-glib-1-dev xserver-xorg-dev libgtk2.0-dev libstartup-notification0-dev libwnck-dev libgudev-1.0-dev libnotify-dev libxklavier-dev

there will be also other packages that will need to be installed, choose yes and everything will be installed.

After that compile sau recompile everything in the following order :

1. libxfce4util
2.xfconf
3. libxfce4ui
4. garcon
5. exo
6. xfce4-panel
7. thunar
8. thunar-vfs
9. xfce4-settings
10. xfce4-session
11. xfdesktop
12. xfwm4
13. xfce-utils
14. xfce4-appfinder
15. gtk-xfce-engine

This is what i have done on my laptop and it worked fine; see my other post about Ubuntu for details regarding the menu issue..

cheers..

Thanks.. I try now...


url: blog.desdelinux.net
twt: @elavdeveloper

Offline

Board footer

Powered by FluxBB