Xfce Forum

Sub domains
 

You are not logged in.

#1 2011-01-17 08:32:56

nekron29
Member
Registered: 2011-01-17
Posts: 6

[Solved] xfce 4.8 compiled in ubuntu maverick

hello ! me again..

So i managed to compile xfce 4.8 - ubuntu 10.10 (maverick)

I have 2 main issues :

1. thunar is taking ages to launch - whenever i am trying to access a folder
2. i don't have a menu - "File "menus/xfce-applications.menu" not found" , although i did compile an 4.6.2 version of the libxfce4menu; in the archive for the 4.8 i couldn't find it and according to the compiling instructions, this was supposed to be deprecated. - SOLVED - use custom menu from /usr/etc/xdg/menus - xfce-applications.menu / i used the package libxfce4menu-4.6.2.

*I have an additional problem with the notification area - whenever it passes a certain number of icon or size of icons it starts blinking as crazy and take my CPU load at maximum; quiting several notification icons resolves the issue.

*compositor doesn't work - nvidia 7150 integrated - compiz on gnome works fine..

Can you help me ? Did you manage to install it ?

cheers..

Last edited by nekron29 (2011-01-17 09:28:41)

Offline

#2 2011-01-17 12:40:46

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: [Solved] xfce 4.8 compiled in ubuntu maverick

For proper menu support you need xfce-utils 4.8.0 and the garcon library (replacement of libxfce4menu).

Check if the compositor is properly compiled in xfwm4: xfwm4 -V

For the panel/systray bug you should open a new bug and attach the output of "PANEL_DEBUG=systray xfce4-panel > ~/somefile".

Offline

#3 2011-01-17 14:31:09

nekron29
Member
Registered: 2011-01-17
Posts: 6

Re: [Solved] xfce 4.8 compiled in ubuntu maverick

Hello Nick,

Thank you for the reply.

So :

Check if the compositor is properly compiled in xfwm4: xfwm4 -V
---
    This is xfwm4 version 4.8.0 (revision e316a45) for Xfce 4.8.0
    Released under the terms of the GNU General Public License.
    Compiled against GTK+-2.22.0, using GTK+-2.22.0.

    Build configuration and supported features:
    - Startup notification support:                 Yes
    - XSync support:                                Yes
    - Render support:                               Yes
    - Xrandr support:                               Yes
    - Embedded compositor:                          Yes
    - KDE systray proxy (deprecated):               No
---
So i presume everything compiled ok; after removing several old libraries of xfce 4.6 i recompiled several 4.8 components and the compositor is working fine now.
---

For proper menu support you need xfce-utils 4.8.0 and the garcon library (replacement of libxfce4menu).
---
I compiled those 2 and yet i had the same issue, until i selected a custom menu with the "Use custom menu file" option in the Applications Menu window. Regarding garcon, do you know why it is not included in the main source archive for XFCE 4.8 ? This is what i used : http://archive.se.xfce.org/src/libs/garcon/0.1/
---
For the notification area i will open a bug report as per your advice; as a side note - after i remove it from the top panel and place it in the bottom panel, everything worked; it looked like because of the number of apps, the notification area is "trying more room" without success and thus the flickering and the cpu load.

thanks again...

Offline

#4 2011-01-18 06:48:00

nekron29
Member
Registered: 2011-01-17
Posts: 6

Re: [Solved] xfce 4.8 compiled in ubuntu maverick

Hello Everyone,

UPDATE on the Ubuntu Maverick 10.10 front...

So i compiled XFCE 4.8 on my old laptop - the same Ubuntu 10.10 as for my desktop (actually is Mint 10 wink I followed the compiling instructions from here - http://www.xfce.org/download/building - see the Dependencies section; i took out libxfcegui4  and   libxfce4menu because they are deprecated.

MAKE SURE YOU REMOVE ANY OLD XFCE 4.6 PACKAGE FIRST !

So in short this is the order that i used for the compilation :

1. libxfce4util
2. xfconf
3. libxfce4ui
4. garcon
5. exo
6. xfce4-panel
7, thunar
8. thunar-vfs
9. xfce4-settings
10. xfce4-session
11. xfdesktop
12. xfwm4
13. xfce-utils
14. xfce4-appfinder
15. gtk-xfce-engine

Everything went ok; i don't have the issue with the notification area - so i suspect there are some issues with it on my desktop and thunar starts in a second wink The menu still doesn't want to load so i had to compile libxfce4menu from the 4.6.2 series from the internet (http://archive.be2.xfce.org/src/xfce/li … .2.tar.bz2) and use a custom menu (right click on the menu, properties - use custom menu file option - the path should be - /usr/etc/xdg/menus/xfce-applications.menu).

I tested the menu by installing a new app and it works ok.

I will keep testing - so far everything is very quick and snappy wink and there are lots of new things to explore. If you want panel transparency you need to activate the compositor in the Window Manager Tweaks section in the Settings Manager.

Cheers..

Last edited by nekron29 (2011-01-18 06:54:03)

Offline

#5 2011-01-23 21:33:01

Skcrog86
Member
Registered: 2011-01-23
Posts: 3

Re: [Solved] xfce 4.8 compiled in ubuntu maverick

Hello

I followed the instructions on the page you mentionned, all went fine.
I had the same issue with the menu and tweaked a bit to get one, but it will not update.
There is another, newer thread for this issue : http://forum.xfce.org/viewtopic.php?id=5675

Concerning the compositor I have an issue. I can enable it, check boxes, change opacity settings but nothing happens, even after reboot.

My xfwm4 seems to be ok :
wfwm4 -V
    - Startup notification support:                 Yes
    - XSync support:                                Yes
    - Render support:                               Yes
    - Xrandr support:                               Yes
    - Embedded compositor:                          Yes
    - KDE systray proxy (deprecated):               No

I still have the folders where the compilation of each module was compiled, so I can provide any file needed for help.

Thanks in advance !

Offline

#6 2011-01-23 22:05:07

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: [Solved] xfce 4.8 compiled in ubuntu maverick

Any warnings printed by xfwm4 during statup (in console if you start with startxfce4, or in the .xsession-errors file).

Offline

#7 2011-01-23 22:24:55

Skcrog86
Member
Registered: 2011-01-23
Posts: 3

Re: [Solved] xfce 4.8 compiled in ubuntu maverick

Oh, indeed, might be interesting :

"(xfwm4:2721): xfwm4-WARNING **: The display does not support the XComposite extension.

(xfwm4:2721): xfwm4-WARNING **: Compositing manager disabled."

In the first lines of .xsession-errors.

What could cause that ? I made my best during compilation to have all the features included.

I tried to install Compiz, and I also had a composite-something error.

Video driver involved ?
I use the fglrx (proprietary ATI driver) modified by sgfxi in order to work on my 2.6.36 kernel.

EDIT : After some googling, I found out that there is an option for the composite extension in /etc/X11/xorg.conf
I simply commented the line :
Option      "Composite" "disable"
under the :
Section "Extensions"

At the end of the file.

Last edited by Skcrog86 (2011-01-24 00:48:10)

Offline

#8 2011-01-24 07:23:51

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: [Solved] xfce 4.8 compiled in ubuntu maverick

And does it work now?

Offline

#9 2011-01-24 14:01:42

Skydancer
Member
From: Slovenia
Registered: 2011-01-24
Posts: 5

Re: [Solved] xfce 4.8 compiled in ubuntu maverick

I think I'll try to install Xfce 4.8 on my Xubuntu 10.10 as well, but first I need to get a few answers.

nekron29 wrote:

MAKE SURE YOU REMOVE ANY OLD XFCE 4.6 PACKAGE FIRST!

So if I understand you correctly I need to remove first all DEB Xfce packages for the individual components that are listed in "xfce-4.8.tar.bz2"?

When I get to the installation of  dependencies like libxfce4util, where do I get them? Via apt-get from the current Maverick repositories?

Offline

#10 2011-01-24 20:38:11

Skcrog86
Member
Registered: 2011-01-23
Posts: 3

Re: [Solved] xfce 4.8 compiled in ubuntu maverick

Nick wrote:

And does it work now?

Yes it works fine now smile
Thank you !

XFCE is great on my dual screen display !

Offline

#11 2011-01-25 17:55:01

Skydancer
Member
From: Slovenia
Registered: 2011-01-24
Posts: 5

Re: [Solved] xfce 4.8 compiled in ubuntu maverick

Yay, I too successfully installed Xfce 4.8 on Xubuntu 10.10!

Offline

#12 2011-01-26 15:50:52

wkr
Member
Registered: 2011-01-01
Posts: 88

Re: [Solved] xfce 4.8 compiled in ubuntu maverick

Yay, I too successfully installed Xfce 4.8 on Xubuntu 10.10

Do all panel plugins work (mailwatch, notes etc.) ? I have successfully installed xfce4.8 in
Lucid but 4.6 plugins don't work (and there is very few 4.8 plugins)

Offline

#13 2011-01-26 21:27:15

Skydancer
Member
From: Slovenia
Registered: 2011-01-24
Posts: 5

Re: [Solved] xfce 4.8 compiled in ubuntu maverick

Yes, I noticed too the scarcity of plugins compared to Xfce 4.6. I didn't compile any additional panel plugins, but from what I gathered many of them haven't been updated yet.

One positive side of Xfce is compiled from source is that it's noticeably faster than the one installed from DEBs.

Last edited by Skydancer (2011-01-26 21:29:34)

Offline

#14 2011-01-26 22:16:03

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: [Solved] xfce 4.8 compiled in ubuntu maverick

Most 4.6 plugins work with 4.8 too after they have been recompiled against the new library. Only 1 plugin breaks; which is the weather plugin because it can't cope with rgba windows.

Offline

#15 2011-01-27 09:17:23

Skydancer
Member
From: Slovenia
Registered: 2011-01-24
Posts: 5

Re: [Solved] xfce 4.8 compiled in ubuntu maverick

Nick wrote:

Most 4.6 plugins work with 4.8 too after they have been recompiled against the new library.

How do I do that? (Sorry for the newbie question.)

Offline

#16 2011-01-27 13:40:00

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: [Solved] xfce 4.8 compiled in ubuntu maverick

You can the compile the plugins again and install them on your system (extract tarballs, ./configure --prefix=/usr && make && make install).

Offline

#17 2011-01-27 14:05:56

Skydancer
Member
From: Slovenia
Registered: 2011-01-24
Posts: 5

Re: [Solved] xfce 4.8 compiled in ubuntu maverick

Oh, right; I thought there are some extra steps. I managed to install xfce4-mixer with checkinstall to build a DEB package, but it failed so I tried it with make install and it seems everything is fine.

Offline

#18 2013-07-29 20:18:28

GaryAitken
Member
Registered: 2012-05-29
Posts: 9

Re: [Solved] xfce 4.8 compiled in ubuntu maverick

newbie question -- what is "Startup Notification Support" and what are the pros and cons of enabling it in a build / install?

Can someone explain to me what enabling this option does,
what happens if some components have it enabled and others don't,
and what behavior is present / missing if it is disabled all over?

Thanks!

Offline

#19 2013-07-29 20:20:22

GaryAitken
Member
Registered: 2012-05-29
Posts: 9

Re: [Solved] xfce 4.8 compiled in ubuntu maverick

oops, sorry, didn't mean that to be in an existing post; will repost as new

Offline

Board footer

Powered by FluxBB