Xfce Forum

Sub domains
 

You are not logged in.

#1 2011-01-21 09:27:45

karlitos
Member
Registered: 2011-01-21
Posts: 3

[Solved] kiosk mode for xfce panel 4.8.

Hello

Is there a way to activate kiosk mode for xfce4-panel in version 4.8 ? Or ANY other possibility to prevent a reaction after right-clicing the panel? I created the /etc/xdg/xfce4/kiosk/kioskrc file with

[xfce4-panel]
CustomizePanel=%root,root

but after reboot the panel is still displaying menu(s) after i click on it with the right mouse button.

Thnks in advance for reply - K

Offline

#2 2011-01-21 09:34:43

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: [Solved] kiosk mode for xfce panel 4.8.

The old kiosk mode was dropped, it handles kiosk permissions through xfconf. See http://git.xfce.org/xfce/xfconf/tree/do … el-xml.txt. Note that in this only works if the panel config is in the readonly xdg directory.

Offline

#3 2011-01-21 09:37:34

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: [Solved] kiosk mode for xfce panel 4.8.

You can put a lock on the main property (/) or per-panel (/panels/panel-0).

Offline

#4 2011-01-21 10:03:43

karlitos
Member
Registered: 2011-01-21
Posts: 3

Re: [Solved] kiosk mode for xfce panel 4.8.

Hi Nick

Thanks very much for your fast reply. I have to admit I did not understand the instructions well sad .
I am using Lubuntu 10.10 and aded the xfce 4.8 panel from a repository. As far as I understand it, the settings are stored in HOME_DIR/.config/xfce4/xfconf/xfce-perchannel-xml. There is also a /etc/xdg/xfce4/xfconf/xfce-perchannel-xml directory with some shortcut bindings.
Here is my xfce-perchannel-xml configuration file :

<?xml version="1.0" encoding="UTF-8"?>

<channel name="xfce4-panel" version="1.0">
  <property name="panels" type="uint" value="1">
    <property name="panel-0" type="empty">
      <property name="position" type="string" value="p=6;x=0;y=0"/>
      <property name="length" type="uint" value="100"/>
      <property name="position-locked" type="bool" value="true"/>
      <property name="plugin-ids" type="array">
        <value type="int" value="1"/>
        <value type="int" value="2"/>
        <value type="int" value="3"/>
        <value type="int" value="5"/>
        <value type="int" value="4"/>
      </property>
      <property name="background-style" type="uint" value="2"/>
      <property name="background-image" type="string" value="/home/babicka/panel_bg.jpg"/>
      <property name="size" type="uint" value="35"/>
    </property>
  </property>
  <property name="plugins" type="empty">
    <property name="plugin-1" type="string" value="applicationsmenu"/>
    <property name="plugin-5" type="string" value="clock">
      <property name="digital-format" type="string" value="%A %d %B %Y - %R"/>
    </property>
    <property name="plugin-2" type="string" value="showdesktop"/>
    <property name="plugin-3" type="string" value="separator">
      <property name="expand" type="bool" value="true"/>
      <property name="style" type="uint" value="0"/>
    </property>
    <property name="plugin-4" type="string" value="separator">
      <property name="expand" type="bool" value="true"/>
      <property name="style" type="uint" value="0"/>
    </property>
  </property>
</channel>

Could you be so nice and explain what should I change in order to prevent the panel from reacting after being clicked ?
Thank you very much K

Last edited by karlitos (2011-01-21 10:04:40)

Offline

#5 2011-01-21 11:02:48

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: [Solved] kiosk mode for xfce panel 4.8.

Create a panel config and copy it over to the /etc/xdg location (readonly for users) and then change:

<channel name="xfce4-panel" version="1.0">

to

<channel name="xfce4-panel" version="1.0" locked="*" unlocked="root;@wheel">

Offline

#6 2011-01-21 11:30:59

karlitos
Member
Registered: 2011-01-21
Posts: 3

Re: [Solved] kiosk mode for xfce panel 4.8.

cat /etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-panel.xml


<?xml version="1.0" encoding="UTF-8"?>

<channel name="xfce4-panel" version="1.0" locked="*" unlocked="root;@wheel">
  <property name="panels" type="uint" value="1">
    <property name="panel-0" type="empty">
      <property name="position" type="string" value="p=6;x=0;y=0"/>
      <property name="length" type="uint" value="100"/>
      <property name="position-locked" type="bool" value="true"/>
      <property name="plugin-ids" type="array">
        <value type="int" value="1"/>
        <value type="int" value="2"/>
        <value type="int" value="3"/>
        <value type="int" value="5"/>
        <value type="int" value="4"/>
      </property>
      <property name="background-style" type="uint" value="2"/>
      <property name="background-image" type="string" value="/home/babicka/panel_bg.jpg"/>
      <property name="size" type="uint" value="35"/>
    </property>
  </property>
  <property name="plugins" type="empty">
    <property name="plugin-1" type="string" value="applicationsmenu"/>
    <property name="plugin-5" type="string" value="clock">
      <property name="digital-format" type="string" value="%A %d %B %Y - %R"/>
    </property>
    <property name="plugin-2" type="string" value="showdesktop"/>
    <property name="plugin-3" type="string" value="separator">
      <property name="expand" type="bool" value="true"/>
      <property name="style" type="uint" value="0"/>
    </property>
    <property name="plugin-4" type="string" value="separator">
      <property name="expand" type="bool" value="true"/>
      <property name="style" type="uint" value="0"/>
    </property>
  </property>
</channel>

This configuration results in a blank panel without applets. The panel menu is unaccessible, but all the panel enries are gone . Anyway, is there a possibility to disable showing the help, about and logout entries ?

Offline

#7 2011-04-12 11:50:24

wtsch
Member
Registered: 2010-06-09
Posts: 26

Re: [Solved] kiosk mode for xfce panel 4.8.

Nick wrote:

Create a panel config and copy it over to the /etc/xdg location (readonly for users) and then change:

<channel name="xfce4-panel" version="1.0">

to

<channel name="xfce4-panel" version="1.0" locked="*" unlocked="root;@wheel">

Really? Is it works? Sure? Did you test it? Really? Damn! You didn't test this!
This configuration results in a blank panel without applets.
cat .xsession-errors:

...
xfce4-panel-Message: Plugin "applicationsmenu-1" was not found und has been removed from the configuration
etc
...

Last edited by wtsch (2011-04-12 11:54:46)

Offline

#8 2011-04-16 16:50:23

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: [Solved] kiosk mode for xfce panel 4.8.

True, was not tested in a while. Kiosk mode is fixed in master and the 4.8 branch.

Offline

#9 2011-04-18 09:19:58

wtsch
Member
Registered: 2010-06-09
Posts: 26

Re: [Solved] kiosk mode for xfce panel 4.8.

Nick wrote:

True, was not tested in a while. Kiosk mode is fixed in master and the 4.8 branch.

Thank you. I'll test this smile

Great!!! It works. We need this feature for ~4.000 users in our firm wink Thank you once more.

Last edited by wtsch (2011-04-18 14:06:11)

Offline

#10 2011-04-19 08:56:29

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: [Solved] kiosk mode for xfce panel 4.8.

Nice. If you experience more problems, please open a bug at bugzilla.xfce.org.

Offline

Board footer

Powered by FluxBB