Xfce Forum

Sub domains
 

You are not logged in.

#1 2011-09-03 12:27:18

Unia
Member
Registered: 2011-08-22
Posts: 10

[Solved] xfce4-indicator-plugin

Hello,

I'm trying to compile xfce4-indicator-plugin on Arch Linux. I have all the dependencies installed, but still I receive the following error:

*** The required package indicator was not found on your system.
*** Please install indicator (atleast version 0.3.0) or adjust
*** the PKG_CONFIG_PATH environment variable if you
*** installed the package in a nonstandard prefix so that
*** pkg-config is able to find it.

I have libindicator 0.3.93-1 installed.

Offline

#2 2011-09-04 11:55:20

mmassonnet
Moderator
From: the milky way galaxy
Registered: 2006-07-30
Posts: 99
Website

Re: [Solved] xfce4-indicator-plugin

What does "pkg-config --list-all | grep indicator" return?

Does "pkg-config --list-all > /dev/null" print an error message?


Mike

Offline

#3 2011-09-04 12:10:46

Unia
Member
Registered: 2011-08-22
Posts: 10

Re: [Solved] xfce4-indicator-plugin

Hey, thanks for your reply!

pkg-config --list-all | grep indicator:

┌─[jente@lappy ~][14:08:56] 
└─■ pkg-config --list-all | grep indicator
indicator3-0.4                      libindicator3 - libindicator3.

pkg-config --list-all > /dev/null does not print an error message, it returns nothing:

┌─[jente@lappy ~][14:09:08] 
└─■ pkg-config --list-all > /dev/null
┌─[jente@lappy ~][14:09:20] 
└─■ 

Offline

#4 2011-09-05 14:09:00

Unia
Member
Registered: 2011-08-22
Posts: 10

Re: [Solved] xfce4-indicator-plugin

On the AUR page of the plugin, someone told me this:

libindicator 0.3.90+ is part of the new 0.4 branch, xfce4-indicator-plugin-0.3 requires the 0.3 branch of libindicator, the latest of which is 0.3.22.
make sure you build the plugin against the right version of libindicator.

Would there be any fix for this, or could you update the plugin to work with the new 0.4 branch?

Here's the AUR page:
https://aur.archlinux.org/packages.php?ID=46810

Last edited by Unia (2011-09-05 14:09:16)

Offline

#5 2011-09-05 18:20:00

mmassonnet
Moderator
From: the milky way galaxy
Registered: 2006-07-30
Posts: 99
Website

Re: [Solved] xfce4-indicator-plugin

Ok, your installation looks ok, if the plugin doesn't build against libindicator 0.4 I recommend contacting the author of the plugin.


Mike

Offline

#6 2011-09-05 20:18:09

Unia
Member
Registered: 2011-08-22
Posts: 10

Re: [Solved] xfce4-indicator-plugin

This might sound stupid but I can't find any way to contact him.. I found numerous blogs, a launchpad profile and Google+, but neither of those has an email or something. Can you find something I can use?

Offline

#7 2011-09-05 22:00:04

jeromeg
Moderator
From: France
Registered: 2010-11-11
Posts: 131
Website

Re: [Solved] xfce4-indicator-plugin

The AUTHORS file in the distributed tarball is always helpful in such a case: http://git.xfce.org/panel-plugins/xfce4 … ee/AUTHORS for a live preview of the latest version.

Offline

#8 2011-09-06 20:01:21

Unia
Member
Registered: 2011-08-22
Posts: 10

Re: [Solved] xfce4-indicator-plugin

^ Thanks! I will email him there and see if I get a response!

Offline

#9 2011-09-07 20:48:55

mdarda
Member
Registered: 2011-09-07
Posts: 2

Re: [Solved] xfce4-indicator-plugin

Please write here if you find a solution. I really need that indicator in my Archlinux with Xfce DE. wink

Offline

#10 2011-09-08 08:26:27

Unia
Member
Registered: 2011-08-22
Posts: 10

Re: [Solved] xfce4-indicator-plugin

I will report back, but haven't heart anything so far...

Offline

#11 2011-09-08 10:01:30

mdarda
Member
Registered: 2011-09-07
Posts: 2

Re: [Solved] xfce4-indicator-plugin

Hey, I think I have found a solution to install 'indicator' so:

yaourt -S libindicator

and then you edit PKGBUILD with your text editor like gedit or something to make it look like this:

# Maintainer: mathieui <mathieui(AT)mathieui(DOT)net>
# Contributor: mathieui <mathieui(AT)mathieui(DOT)net>

pkgname=libindicator
pkgver=0.3.22
_pkgbranch=0.3
pkgrel=1
pkgdesc="A set of symbols and convience functions that all indicators would like to use. (Canonical Ayatana Project)"
arch=('i686' 'x86_64')
url="http://launchpad.net/libindicator/"
license=('GPL')
makedepends=('make' 'autoconf')
depends=('gnome-common')
source=(http://launchpad.net/$pkgname/$_pkgbranch/$pkgver/+download/$pkgname-$pkgver.tar.gz)
md5sums=('9cbd9724375718dd06b86ac3d668e548')

build() {
  cd "$srcdir"/$pkgname-$pkgver
  ./configure --prefix=/usr --disable-static
  make
}

package() {
  cd "$srcdir"/$pkgname-$pkgver
  make DESTDIR="$pkgdir" install
}

but I've got another problem when I'm tryin to install indicator-applet:

No package 'libpanelapplet-3.0' found

Whats is this? Which package provides it?

Offline

#12 2011-09-08 14:32:29

Unia
Member
Registered: 2011-08-22
Posts: 10

Re: [Solved] xfce4-indicator-plugin

^ You installed an older version of libindicator. For xfce4-indicator-plugin this will work, but the newer versions of indicator-applet require the newer version of libindicator, which you haven't installed. The developer has just send me an email and he'll go check on it. We'll see!

Offline

#13 2011-09-13 18:34:56

Unia
Member
Registered: 2011-08-22
Posts: 10

Re: [Solved] xfce4-indicator-plugin

Thanks to the developer and the awesome Arch forums, I got it working!

Firstly, install this libindicator package:
https://github.com/City-busz/Arch-Linux … r/PKGBUILD

Then use my PKGBUILD with the patch!
PKGBUILD: http://pastebin.com/VNAVP8R4
Patch: http://pastebin.com/rZCcRNAm

Offline

Board footer

Powered by FluxBB