Xfce Forum

Sub domains
 

You are not logged in.

#1 2011-05-13 19:41:46

oco
Member
Registered: 2011-05-13
Posts: 18

xfce4-kbdleds-plugin

Hello!

I have no keyboard LEDs (Caps,Scroll,NumLock) on my netbook so I had to write a small panel plugin to show LEDs' state.
Does anybody need it?
You can download it from here: http://compas.com.ua/oco/file/xfce4-kbd … in.tar.bz2
I have Xfce 4.6 but I suppose it's not hard to port it to 4.8.

Last edited by oco (2011-05-13 19:45:54)

Offline

#2 2011-05-26 14:15:03

joukim
Member
Registered: 2011-05-26
Posts: 1

Re: xfce4-kbdleds-plugin

I've made few changes to work with libxfceui4 instead of libxfcegui4... Worked here, but no icon in panel plugin list. But worked, and I need this (no led in keyboard too).

My changes are here: http://www.4shared.com/file/uhPS1rvu/xf … intar.html

Can you put this as a project in xfce-goodies?
http://goodies.xfce.org/

Offline

#3 2011-05-26 19:26:55

oco
Member
Registered: 2011-05-13
Posts: 18

Re: xfce4-kbdleds-plugin

joukim wrote:

I've made few changes to work with libxfceui4 instead of libxfcegui4... Worked here, but no icon in panel plugin list. But worked, and I need this (no led in keyboard too).

My changes are here: http://www.4shared.com/file/uhPS1rvu/xf … intar.html

I have installed Xubuntu 11.04 today and done same job as you.
Here http://compas.com.ua/oco/file/xfce4-kbd … .2.tar.bz2 is the result. The icon is in my panel plugins list. Try

./configure --prefix=/usr
joukim wrote:

Can you put this as a project in xfce-goodies?
http://goodies.xfce.org/

I want to but I don't know how to do it by now.

Offline

#4 2011-06-01 09:01:02

oco
Member
Registered: 2011-05-13
Posts: 18

Re: xfce4-kbdleds-plugin

Strange, but I have no plugin icon too...
Posted a bug: https://bugzilla.xfce.org/show_bug.cgi?id=7678

Last edited by oco (2011-06-01 09:01:33)

Offline

#5 2011-06-02 21:12:33

oco
Member
Registered: 2011-05-13
Posts: 18

Re: xfce4-kbdleds-plugin

Solved problem with missing plugin icon. You can get new version here: http://compas.com.ua/oco/file/xfce4-kbd … .4.tar.bz2
Note: you MUST use ./configure --prefix=/usr

It is strange, when I call this icon "xfce4-kbdleds-plugin.png" it disappears. Called it "kbdleds-plugin.png" and it is OK!

I hope I will put this to xfce-goodies. Somebody help to do it, please!

Offline

#6 2011-09-24 09:53:47

gour
Member
Registered: 2011-09-24
Posts: 1

Re: xfce4-kbdleds-plugin

oco wrote:

Solved problem with missing plugin icon. You can get new version here: http://compas.com.ua/oco/file/xfce4-kbd … .4.tar.bz2
Note: you MUST use ./configure --prefix=/usr

Thank you very much for your useful plugin.

It's just what we need for our new netbook. :-)

I hope I will put this to xfce-goodies. Somebody help to do it, please!

I'll post to the mailing list asking to be put into xfce-goodies.

In the meantime, I've prepared package for Archlinux. wink


Sincerely,
Gour

Offline

#7 2011-10-03 07:55:02

oco
Member
Registered: 2011-05-13
Posts: 18

Re: xfce4-kbdleds-plugin

gour wrote:

I'll post to the mailing list asking to be put into xfce-goodies.

Thank you!
Let's see, what will be the result.

Offline

#8 2011-10-04 16:51:18

StephenH
Member
From: Wake Forest, North Carolina
Registered: 2011-09-10
Posts: 16
Website

Re: xfce4-kbdleds-plugin

Thanks. This will also solve a problem I have with my netbook. I need this as I like XFCE over LXDE which does have an indicator but which is somewhat limited in other areas.

Later edit:

I tried compiling this, but after installing many development tools and searching for missing parts, it compiled only to not show up anywhere. I'm not sure what I did wrong so I backed out. I think I will wait until it shows up in xfce-goodies.

Last edited by StephenH (2011-10-05 01:42:36)


StephenH

"We must understand the reality that just because our culture claims certain things are true it does not mean they are!" --M. Liederbach
http://pilgrim-wanderings.blogspot.com

Offline

#9 2011-10-06 19:33:46

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: xfce4-kbdleds-plugin

oco, you should've received a notification about your new account on goodies.xfce.org.

If you login and visit http://goodies.xfce.org/projects/panel- … eds-plugin you can create a new page.

Offline

#10 2011-10-07 05:55:16

oco
Member
Registered: 2011-05-13
Posts: 18

Re: xfce4-kbdleds-plugin

Nick wrote:

oco, you should've received a notification about your new account on goodies.xfce.org.

If you login and visit http://goodies.xfce.org/projects/panel- … eds-plugin you can create a new page.

Thanks!

Offline

#11 2011-10-09 22:40:01

StephenH
Member
From: Wake Forest, North Carolina
Registered: 2011-09-10
Posts: 16
Website

Re: xfce4-kbdleds-plugin

I thought I'd try compiling it again. I get this message:

checking for libxfce4ui-1 >= 4.6.0... not found
*** The required package libxfce4ui-1 was not found on your system.
*** Please install libxfce4ui-1 (atleast version 4.6.0) or adjust
*** the PKG_CONFIG_PATH environment variable if you
*** installed the package in a nonstandard prefix so that
*** pkg-config is able to find it.

so I installed libxfce4ui-devel as libxfce4ui was already installed. It pulled in a number of dependencies. I also ended up installing just about everything X86_64 for libxfce4 available on the Fedora repositories. When I try again, I get this:

checking for libxfce4ui-1 >= 4.6.0... 4.8.0
checking LIBXFCE4UI_CFLAGS... -pthread -I/usr/include/xfce4/libxfce4ui-1 -I/usr/include/gtk-2.0 -I/usr/include/xfce4 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 
checking LIBXFCE4UI_LIBS... -pthread -lxfce4ui-1 -lgtk-x11-2.0 -lxfce4util -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lpng12 -lm -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0 
checking for libxfce4util-1.0 >= 4.6.0... 4.8.2
checking LIBXFCE4UTIL_CFLAGS... -I/usr/include/xfce4 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include 
checking LIBXFCE4UTIL_LIBS... -lxfce4util -lglib-2.0 
checking for libxfce4panel-1.0 >= 4.6.0... not found
*** The required package libxfce4panel-1.0 was not found on your system.
*** Please install libxfce4panel-1.0 (atleast version 4.6.0) or adjust
*** the PKG_CONFIG_PATH environment variable if you
*** installed the package in a nonstandard prefix so that
*** pkg-config is able to find it.

??? There is no package "libxfce4panel" available. After more searching, I installed xfce4-panel-devel, and the configure command completed. However, now the make command fails with this:

# make
make  all-recursive
make[1]: Entering directory `/home/xxxxxxxx/Downloads/xfce4-kbdleds-plugin-0.0.4'
Making all in icons
make[2]: Entering directory `/home/xxxxxxxx/Downloads/xfce4-kbdleds-plugin-0.0.4/icons'
Making all in 48x48
make[3]: Entering directory `/home/xxxxxxxx/Downloads/xfce4-kbdleds-plugin-0.0.4/icons/48x48'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/home/xxxxxxxx/Downloads/xfce4-kbdleds-plugin-0.0.4/icons/48x48'
Making all in scalable
make[3]: Entering directory `/home/xxxxxxxx/Downloads/xfce4-kbdleds-plugin-0.0.4/icons/scalable'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/home/xxxxxxxx/Downloads/xfce4-kbdleds-plugin-0.0.4/icons/scalable'
make[3]: Entering directory `/home/xxxxxxxx/Downloads/xfce4-kbdleds-plugin-0.0.4/icons'
make[3]: Nothing to be done for `all-am'.
make[3]: Leaving directory `/home/xxxxxxxx/Downloads/xfce4-kbdleds-plugin-0.0.4/icons'
make[2]: Leaving directory `/home/xxxxxxxx/Downloads/xfce4-kbdleds-plugin-0.0.4/icons'
Making all in panel-plugin
make[2]: Entering directory `/home/xxxxxxxx/Downloads/xfce4-kbdleds-plugin-0.0.4/panel-plugin'
  CC     xfce4_kbdleds_plugin-kbdleds.o
  CC     xfce4_kbdleds_plugin-xkbleds.o
  CC     xfce4_kbdleds_plugin-kbdleds-dialogs.o
  CCLD   xfce4-kbdleds-plugin
/usr/bin/ld: xfce4_kbdleds_plugin-xkbleds.o: undefined reference to symbol 'XkbGetNamedIndicator'
/usr/bin/ld: note: 'XkbGetNamedIndicator' is defined in DSO /usr/lib64/libX11.so.6 so try adding it to the linker command line
/usr/lib64/libX11.so.6: could not read symbols: Invalid operation
collect2: ld returned 1 exit status
make[2]: *** [xfce4-kbdleds-plugin] Error 1
make[2]: Leaving directory `/home/xxxxxxxx/Downloads/xfce4-kbdleds-plugin-0.0.4/panel-plugin'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/xxxxxxxx/Downloads/xfce4-kbdleds-plugin-0.0.4'
make: *** [all] Error 2

Is this indicative of a basic incompatibility of this plugin with Fedora 15 x86_64? This is the same problem I was having trying to compile it on my netbook. This time it was on my desktop system.


StephenH

"We must understand the reality that just because our culture claims certain things are true it does not mean they are!" --M. Liederbach
http://pilgrim-wanderings.blogspot.com

Offline

#12 2011-10-09 23:38:30

oco
Member
Registered: 2011-05-13
Posts: 18

Re: xfce4-kbdleds-plugin

StephenH wrote:

/usr/bin/ld: xfce4_kbdleds_plugin-xkbleds.o: undefined reference to symbol 'XkbGetNamedIndicator'
/usr/bin/ld: note: 'XkbGetNamedIndicator' is defined in DSO /usr/lib64/libX11.so.6 so try adding it to the linker command line
/usr/lib64/libX11.so.6: could not read symbols: Invalid operation
...
Is this indicative of a basic incompatibility of this plugin with Fedora 15 x86_64? This is the same problem I was having trying to compile it on my netbook. This time it was on my desktop system.

Do you have /usr/lib64/libX11.so.6?
Try to create symbolic link to this file in /usr/lib
(I have 32-bit Linux, so I can not check this now, maybe later...)
UPD:
try

export LDFLAGS=-lX11

and

make

Last edited by oco (2011-10-10 00:07:08)

Offline

#13 2011-10-10 01:58:58

StephenH
Member
From: Wake Forest, North Carolina
Registered: 2011-09-10
Posts: 16
Website

Re: xfce4-kbdleds-plugin

oco wrote:
StephenH wrote:

/usr/bin/ld: xfce4_kbdleds_plugin-xkbleds.o: undefined reference to symbol 'XkbGetNamedIndicator'
/usr/bin/ld: note: 'XkbGetNamedIndicator' is defined in DSO /usr/lib64/libX11.so.6 so try adding it to the linker command line
/usr/lib64/libX11.so.6: could not read symbols: Invalid operation
...
Is this indicative of a basic incompatibility of this plugin with Fedora 15 x86_64? This is the same problem I was having trying to compile it on my netbook. This time it was on my desktop system.

Do you have /usr/lib64/libX11.so.6?
Try to create symbolic link to this file in /usr/lib
(I have 32-bit Linux, so I can not check this now, maybe later...)
UPD:
try

export LDFLAGS=-lX11

and

make

I have /usr/lib64/libX11.so.6, which is a symbolic link to /usr/lib64/libX11.so.6.3.0
There is also a /usr/lib/libX11.so.6 which links to /usr/lib/libX11.so.6.3.0

I hesitate to change the link in /usr/lib64 to link to the 32 bit version lest it break other things in the process.

I tried the export command as listed and then make. It also failed. The relevant parts are here:

/usr/bin/ld: xfce4_kbdleds_plugin-xkbleds.o: undefined reference to symbol 'XkbGetNamedIndicator'
/usr/bin/ld: note: 'XkbGetNamedIndicator' is defined in DSO /usr/lib64/libX11.so.6 so try adding it to the linker command line
/usr/lib64/libX11.so.6: could not read symbols: Invalid operation
collect2: ld returned 1 exit status
make[2]: *** [xfce4-kbdleds-plugin] Error 1
make[2]: Leaving directory `/home/xxxxxxxx/Downloads/xfce4-kbdleds-plugin-0.0.4/panel-plugin'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/xxxxxxxx/Downloads/xfce4-kbdleds-plugin-0.0.4'
make: *** [all] Error 2

Thank you for at least giving me something to try.  At least I have found a workaround. It is in using GKrellM and the gkleds plugin, which I was able to compile. I would rather have the panel plugin rather than a separate program installed, but for now, I can see the caps lock status. That is the important thing.


StephenH

"We must understand the reality that just because our culture claims certain things are true it does not mean they are!" --M. Liederbach
http://pilgrim-wanderings.blogspot.com

Offline

#14 2011-10-10 06:06:02

oco
Member
Registered: 2011-05-13
Posts: 18

Re: xfce4-kbdleds-plugin

StephenH wrote:

Thank you for at least giving me something to try.  At least I have found a workaround. It is in using GKrellM and the gkleds plugin, which I was able to compile. I would rather have the panel plugin rather than a separate program installed, but for now, I can see the caps lock status. That is the important thing.

Googled and found this: http://fedoraproject.org/wiki/Understan … LinkChange
Try the following:
in panel-plugin/makefile find

xfce4_kbdleds_plugin_LDADD = \
        $(LIBXFCE4UTIL_LIBS) \
        $(LIBXFCE4UI_LIBS) \
        $(LIBXFCE4PANEL_LIBS)

and make it look like this:

xfce4_kbdleds_plugin_LDADD = \
        $(LIBXFCE4UTIL_LIBS) \
        $(LIBXFCE4UI_LIBS) \
        $(LIBX11_LIBS) \
        $(LIBXFCE4PANEL_LIBS)

then run "make"

Last edited by oco (2011-10-10 06:07:20)

Offline

#15 2011-10-10 17:15:35

StephenH
Member
From: Wake Forest, North Carolina
Registered: 2011-09-10
Posts: 16
Website

Re: xfce4-kbdleds-plugin

Thanks oco. That did it. I never would have known to look there as I don't have the background knowledge necessary to recognize the problem. I appreciate it. My netbook now has your panel plugin showing up and operating fine. big_smile

Last edited by StephenH (2011-10-10 17:16:46)


StephenH

"We must understand the reality that just because our culture claims certain things are true it does not mean they are!" --M. Liederbach
http://pilgrim-wanderings.blogspot.com

Offline

#16 2011-10-11 19:40:37

oco
Member
Registered: 2011-05-13
Posts: 18

Re: xfce4-kbdleds-plugin

StephenH wrote:

Thanks oco. That did it. I never would have known to look there as I don't have the background knowledge necessary to recognize the problem. I appreciate it. My netbook now has your panel plugin showing up and operating fine. big_smile

You're welcome!
Made a new version without this bug:
http://compas.com.ua/oco/file/xfce4-kbd … .5.tar.bz2
Goodies Project page
http://goodies.xfce.org/projects/panel- … eds-plugin
Git
http://git.xfce.org/panel-plugins/xfce4-kbdleds-plugin/

Offline

#17 2011-10-11 19:53:48

StephenH
Member
From: Wake Forest, North Carolina
Registered: 2011-09-10
Posts: 16
Website

Re: xfce4-kbdleds-plugin

Are there any other changes that would make it advisable to download or is it okay to just stick with the version that is currently installed?


StephenH

"We must understand the reality that just because our culture claims certain things are true it does not mean they are!" --M. Liederbach
http://pilgrim-wanderings.blogspot.com

Offline

#18 2011-10-12 05:46:14

oco
Member
Registered: 2011-05-13
Posts: 18

Re: xfce4-kbdleds-plugin

StephenH wrote:

Are there any other changes that would make it advisable to download or is it okay to just stick with the version that is currently installed?

No, I just fixed that bug, you can use v.0.0.4

Offline

#19 2011-10-12 12:32:16

StephenH
Member
From: Wake Forest, North Carolina
Registered: 2011-09-10
Posts: 16
Website

Re: xfce4-kbdleds-plugin

Thank you. I have a suggestion for a future version:

Instead of just small letters that change, have the background of the letters change as in the GKrellM version. It is easier to spot the state when the background changes instead of or in addition to the letter shape change. I was going to attach a screenshot, but did not see an option to do so. In that, the letters are all individually blocked and are caps. The background changes from neutral to a brighter green and back as the state changes. Even if the current layout of all letters in one block is kept, it still would be handy to have the background of the letters change in addition to the shape as it would still make the state easier to spot at a glance.

Respectfully,

Stephen


StephenH

"We must understand the reality that just because our culture claims certain things are true it does not mean they are!" --M. Liederbach
http://pilgrim-wanderings.blogspot.com

Offline

#20 2011-10-13 05:43:27

oco
Member
Registered: 2011-05-13
Posts: 18

Re: xfce4-kbdleds-plugin

Stephen, I'll think about it.

Offline

#21 2011-10-13 15:11:09

Matias
Member
Registered: 2011-04-17
Posts: 12

Re: xfce4-kbdleds-plugin

Congratulations..
But please.. Eliminate all unnecessary files on git!. (Dist files, tarballs, po and gmo files, anjuta db, etc!-)

Keep in git only as needed for building with autogen.sh

Regards.
Matias

Offline

#22 2011-10-13 19:31:37

oco
Member
Registered: 2011-05-13
Posts: 18

Re: xfce4-kbdleds-plugin

Matias wrote:

Congratulations..
But please.. Eliminate all unnecessary files on git!. (Dist files, tarballs, po and gmo files, anjuta db, etc!-)

Keep in git only as needed for building with autogen.sh

Regards.
Matias

Thank you!
I'll clean up the project. But there are translations in *.po files, how can I remove them?

To Stephen:
Made some changes, now it looks as this:
xfce4-kbdleds-plugin
Download:
http://compas.com.ua/oco/file/xfce4-kbd … .6.tar.bz2

Offline

#23 2011-10-13 20:06:41

oco
Member
Registered: 2011-05-13
Posts: 18

Re: xfce4-kbdleds-plugin

To Matias:
Cleaning is done!

Offline

#24 2011-10-13 20:15:25

Matias
Member
Registered: 2011-04-17
Posts: 12

Re: xfce4-kbdleds-plugin

Thanks oco!. smile

D'Oh!. The po files not be deleted. haha.

Regards.

Offline

#25 2011-11-03 01:59:34

StephenH
Member
From: Wake Forest, North Carolina
Registered: 2011-09-10
Posts: 16
Website

Re: xfce4-kbdleds-plugin

Thank you very much. The little splash of color makes a big difference in seeing it. I needed to get it and install it again as I had a bad experience with trying to install the AMD Catalyst driver which led to a total re-installation of the whole system. sad

The plus side is that it caused me to get this new version. smile


StephenH

"We must understand the reality that just because our culture claims certain things are true it does not mean they are!" --M. Liederbach
http://pilgrim-wanderings.blogspot.com

Offline

Board footer

Powered by FluxBB