Xfce Forum

Sub domains
 

You are not logged in.

#1 2011-11-04 14:53:21

kiran.majer
Member
Registered: 2011-11-04
Posts: 11

Dual monitor: panel is always on the left one

When I add a second monitor via "xrandr  --output VGA1 --auto --left-of LVDS1", the panel and opened windows move to the added monitor. How do I expand my desktop to the left without moving the hole stuff (like it works, when I expand it to the right)?

Offline

#2 2011-11-04 15:04:20

kiran.majer
Member
Registered: 2011-11-04
Posts: 11

Re: Dual monitor: panel is always on the left one

Btw, using the --primary or --noprimary option, did not seem to make any difference.

Offline

#3 2011-11-05 18:32:59

the98
Member
Registered: 2009-11-10
Posts: 60

Re: Dual monitor: panel is always on the left one

What happens if you try:

xrandr  --output LVDS1 --auto --left-of VGA1

And you can try Arandr, which is a GUI of xrandr.

Good luck.

Offline

#4 2011-11-06 08:59:02

kiran.majer
Member
Registered: 2011-11-04
Posts: 11

Re: Dual monitor: panel is always on the left one

the98 wrote:

What happens if you try:

xrandr  --output LVDS1 --auto --left-of VGA1

And you can try Arandr, which is a GUI of xrandr.

Good luck.

Well, that's similar to

xrandr  --output VGA1 --auto --right-of LVDS1

and my notebook monitor (LVDS1) is the left one, so the panel and previously opened windows stay there. I also tried

xrandr  --output LVDS1 --auto --right-of VGA1

and

xrandr --output VGA1 --pos -1600x0 --auto (1680 is the resolution of VGA1)

all with the same result: the display, which is more to the left gets the panel.

Offline

#5 2011-11-06 11:57:21

warpig
Member
Registered: 2011-11-05
Posts: 2

Re: Dual monitor: panel is always on the left one

Have you tried:

Applications Menu -> Settings -> Setting Manager, then opening "Panel"
Within the settings applet, make sure that each panel (Panel 1 and Panel 2 by default) are set to have their default Output set to LVDS1.  This should ensure that the panel are always on your laptop/netbook screen, regardless of whether an external monitor is attached...

Offline

#6 2011-11-06 14:43:02

kiran.majer
Member
Registered: 2011-11-04
Posts: 11

Re: Dual monitor: panel is always on the left one

warpig wrote:

Have you tried:

Applications Menu -> Settings -> Setting Manager, then opening "Panel"
Within the settings applet, make sure that each panel (Panel 1 and Panel 2 by default) are set to have their default Output set to LVDS1.  This should ensure that the panel are always on your laptop/netbook screen, regardless of whether an external monitor is attached...

This sure does work for the panel, but isn't quite what I want. I want my primary display (that means the panel, opened windows, notification and so on) to be LVDS1, regardless to which side (left or right) I extend my desktop by an external monitor.

By now I think xfwm sets the primary display always to the display which defines the 0xX border of the virtual screen in a dual monitor setup. So I'm going to fill in a bug report/ enhancement request.

Offline

#7 2011-11-07 00:30:50

the98
Member
Registered: 2009-11-10
Posts: 60

Re: Dual monitor: panel is always on the left one

kiran.majer wrote:
the98 wrote:

What happens if you try:

xrandr  --output LVDS1 --auto --left-of VGA1

And you can try Arandr, which is a GUI of xrandr.

Good luck.

Well, that's similar to

xrandr  --output VGA1 --auto --right-of LVDS1

It's not similar. I've tested it on my laptop. Try as I say, if it doesn't work, install Arandr to avoid headaches.

Offline

#8 2011-11-07 07:45:45

kiran.majer
Member
Registered: 2011-11-04
Posts: 11

Re: Dual monitor: panel is always on the left one

the98 wrote:
kiran.majer wrote:
the98 wrote:

What happens if you try:

xrandr  --output LVDS1 --auto --left-of VGA1

And you can try Arandr, which is a GUI of xrandr.

Good luck.

Well, that's similar to

xrandr  --output VGA1 --auto --right-of LVDS1

It's not similar. I've tested it on my laptop. Try as I say, if it doesn't work, install Arandr to avoid headaches.

Can you specify in which way it is not similar? For me, both commands extend my desktop to the right, while LVDS1 stays primary monitor. This worked all the times and is how I want it to be.
(With primary monitor i mean the display, which has the panel and icons, gets the notifications, shows all previously opened windows, is called 'monitor 1' in the desktop settings dialog, in short, which doesn't change if you plugin in a second display. In this context the secondary monitor is the empty desktop space, which is called 'monitor 2' in desktop settings.)
However, if in a physical setup LVDS1 is in front of me and an external monitor or beamer is located left of my notebook, I would like to extend my desktop to the left (i.e. add an empty desktop to the left) and keep my primary monitor on LVDS1.

I've tested arandr, but it's is only a gui to xrandr, so you can't do more then xrandr can do.

Offline

#9 2011-11-08 14:13:42

the98
Member
Registered: 2009-11-10
Posts: 60

Re: Dual monitor: panel is always on the left one

You're right. It's the same command. I didn't read it right.

Ok, so try removing the --auto switch to see what happens. If you say you've tested Arandr and couldn't make it work either, then I don't know what's the problem.

I tried just the other day adding a second monitor to my laptop. I used the command "xrandr  --output LVDS1 --left-of VGA1", if I remember correctly and the same thing happened to me as it's happening to you; the added monitor (VGA1) got all the Panels and Icons. So I simply switched the command like this: "xrandr  --output VGA --left-of 1 LVDS1" and I got what I wanted.

About Arandr, you have the two monitors and you can drag and drop one of them to the right or left of the other, then click Aply. So you could do this:

----------- ----------
| LVDS1| | VGA1 |
----------- ----------

Or this:

----------- -----------
|  VGA1 | | LVDS1 |
----------- -----------


Good luck!

Offline

#10 2012-01-10 15:30:17

jvdurme
Member
Registered: 2012-01-10
Posts: 6

Re: Dual monitor: panel is always on the left one

This is still a nasty bug of XFCE. I'm experiencing the same here with an external monitor. Using Linux Mint Debian Edition 201109.
XFCE panel is always on the left monitor (as specified by xrandr).
So basically the --primary option of xrandr does not work in XFCE (4.8). This is the real issue.

I want to have the panel on the external monitor and that one is physically on the right of my laptop. I cannot reorganize my desk. ;-)

Where can I file a bug report for this?


Xubuntu 12.04 Alpha 2

Offline

#11 2013-01-18 11:17:51

inspirit1986
Member
Registered: 2013-01-18
Posts: 2

Re: Dual monitor: panel is always on the left one

Hi, I have a similar problem. I have connected the second monitor, and I want to move the main panel of XFCE 4.8 and notification and so on to this monitor..  (By default this panel is on the left monitor, but I want to move this panel to the right monitor)

Does anyone to know how to get workaround this problem ?

P/s I use TwinView by Nvidia.

Last edited by inspirit1986 (2013-01-18 11:47:20)

Offline

#12 2013-01-21 07:27:10

inspirit1986
Member
Registered: 2013-01-18
Posts: 2

Re: Dual monitor: panel is always on the left one

pls help. Any workaround for this issue?

How I can move xfce interface from left monitor(by default) to right?

Last edited by inspirit1986 (2013-01-21 07:27:34)

Offline

#13 2013-02-05 07:09:23

Netti+Peti
Member
From: Dresden
Registered: 2013-02-05
Posts: 1

Re: Dual monitor: panel is always on the left one

Hello folks,

I also have the same problem in a similar setup having my notebook (mostly) on the left within the docking station and the monitor at the right. Alternatively, I often use the notebook inside meetings with other external flat-screen or beamer at the one hand or when beein in train or so using it without any external monitor at the other. Depending on given setup, the "primary monitor" (if you call it so) should either be right (external monitor at my desktop) or left (the notebook itself, in case of the meeting or the notebook-only use). Of course I want to have panels and so on the primary one. Additionally, I often plug or unplug the notebook from the docking station and I do not want to reconfigure the panels by hand everytime (as I've to do right now).

Up to now, I've only spent a few minutes on searching for a proper solution, but I think it is possible to setup something with just a little scripting. Unfortunately, I do not have enough time to do it by myself right now, but maybe some of you will try :-)

First, there is the command "xfconf-query", which allows manipulation of XFCE settings from terminal/script. Getting the current position of panel looks like:
  xfconf-query -c xfce4-panel -p /panels/panel-1/output-name
which currently gives "HDMI2". Setting it to the notebook-monitor is done by:
  xfconf-query -c xfce4-panel -p /panels/panel-1/output-name -s LVDS1

The second command is "xrandr" which will give you all available connections and the information about connected monitors. When looking at
  http://unix.stackexchange.com/questions … splay-is-p
the guy is proposing a polling approach to check for connected devices.

I think, that combining both things is an easy way to work around that ugly issue. Also using udev in order to get an event on plug/unplug is possible but
may need a bit more knowledge about the current setup.

I hope I've given a few ideas to that discussion and maybe someone finds time to write down the solution ;-)

Best regards,
Peter

Offline

#14 2013-03-03 00:21:29

jb0nez
Member
Registered: 2013-03-03
Posts: 1

Re: Dual monitor: panel is always on the left one

I registered simply to add to this. The exact same thing is happening to me. This is driving me nuts. I had been using kubuntu and configuring multi desktop using the proprietary AMD drivers was easy and worked. I am trying Xubuntu 12.10 now and this is a game-ender for me. I'm going back to Kubuntu.

No matter what combinations of xrandr/amdccle I do, it ALWAYS wants to put my desktop icons and open displays etc on the left-most display, which is not my main display. Even when display 2 is supposed to just be an extension of the desktop on 1, it still puts the whole desktop on 2. Sure I've managed to move my panel back to display 1, but I'm not going to sit here doing my work facing to my left all the time.

Offline

#15 2013-04-04 17:53:20

Selth
Member
Registered: 2013-04-04
Posts: 1

Re: Dual monitor: panel is always on the left one

I also registered to put a note in here smile changing the location of the bars is a first step ; the icons can be also moved to the new screen and applications usually start on the screen where the mouse is.

However, using alt+f2 no longer brings up the launcher and the icons jump to the other screen temporarily when I get into the panel settings menu mentioned earlier.

still, that works...

(personally my final workaround is to remove the desktop icons. I don't like them anyway!)

Last edited by Selth (2013-04-04 17:54:38)

Offline

#16 2013-09-27 13:47:24

seasoned_geek
Member
Registered: 2013-09-27
Posts: 1

Re: Dual monitor: panel is always on the left one

I also registered simply to post this.

Where does one file bug reports?

I tried the latest and greated OS/4 because I liked the previous version I have running BOINC on a few machines.  When I installed this new release on my primary workstation I encounted the dual monitor bug.  I only moved to OS/4 because Evolution is busted in Mint and Ubuntu.  Evolution actually works with the new release of OS/4.

A bug this basic is totally bogus.

Offline

#17 2013-10-01 22:53:29

MountainDewManiac
Member
From: USA police-state welfare-state
Registered: 2013-03-24
Posts: 387

Re: Dual monitor: panel is always on the left one

seasoned_geek wrote:

I also registered simply to post this.

Where does one file bug reports?

For XFCE?

https://bugzilla.xfce.org/

If for BOINC, OS/4, Evolution, and Ubuntu? IDK.

If for Mint?

https://bugs.launchpad.net/linuxmint

Regards,
MDM


Mountain Dew Maniac

How to Ask for Help <=== Click on this link

Offline

#18 2014-05-22 06:49:37

ponsfrilus
Member
Registered: 2014-05-22
Posts: 1

Re: Dual monitor: panel is always on the left one

Hey guys,
    this is how I did it:

1 - save the script with ARandr
2 - edit the script to add the xconf-query for panels

I get something like this:

#!/bin/sh
xrandr --output HDMI1 --mode 1680x1050 --pos 0x0 --rotate normal --output LVDS1 
--mode 1600x900 --pos 1680x150 --rotate normal --output VIRTUAL1 --off --output 
DP1 --off --output VGA1 --off

# For panel on LDVS1
xfconf-query -c xfce4-panel -p /panels/panel-0/output-name -s LVDS1
xfconf-query -c xfce4-panel -p /panels/panel-1/output-name -s LVDS1

It's not perfect (if someone know how to keep windows and desktop icons on LVDS1 it would be great) but it may save some time.

Cheers,
ponsfrilus

Offline

#19 2014-05-31 02:29:18

ubuntuaddicted
Member
Registered: 2014-05-31
Posts: 4

Re: Dual monitor: panel is always on the left one

i registered to also comment that this bug is affecting me. I am running Xubuntu 14.04 and my main monitor which is directly in front of me is a 1920x1080 panel and I want it as my primary monitor where games launch and where the environment gets it info BUT when I launch games like The Witcher 2 and Painkiller Hell & Damnation they think the max resolution they can be is 1680x1050 which is the resolution of my monitor on the left, which is at 0,0.

In order to get them positioned correctly so that I can drag windows left and right between them, I have to run a xrandr command because when I tried using nvidia-settings it would always make it so that the 1680x1050 panel was to the right of my main panel so in order to get to it I would have to drag my mouse to the right just to get to the panel on the left.

#!/bin/sh
xrandr --output DVI-D-0 --primary --mode 1920x1080 --pos 1680x0 --rotate normal --output HDMI-0 --off --output DVI-I-1 --off --output DVI-I-0 --mode 1680x1050 --pos 0x0 --rotate normal --output DP-1 --off --output DP-0 --off

Using the --primary doesn't seem to make my 1920x1080 panel the primary one.


I enjoy gaming and Linux. Check out my Tech Blog
I livestream Linux gaming at Twitch OR Hitbox
I also make various kinds of videos on YouTube

Offline

#20 2014-06-11 16:26:21

lulzicon
Member
From: The other end of the rainbow
Registered: 2014-06-10
Posts: 10

Re: Dual monitor: panel is always on the left one

I'm curious as to how many people who have this problem are using the nvidia driver verse the nouveau driver. I use the nouveau driver and have ran some pretty funky dual monitor setups in the past and always have just used XFCE Settings with no problems. At one time I had three computers (two of which where dual head) and three monitors. My main (center monitor) ran into a KVM switch to all three computers. The other two monitors went directly to the graphics card. And as I said, a couple of adjustment in XFCE Settings and I was good to go. Main (center monitor) apps opened. Left/right, depending on the computer active, was panels and so on according to my settings in XFCE

Even right now XFCE remembers which monitor the app was last loaded on and opens it there. Example: When I start Seamonkey (both mail and browser at the same time)  mozmail opens on the left monitor and browser on main monitor. Automaticially! With other apps as well. XFCE "just" remembers where the window was last time it was opened and reopens there. No crazy commands involved. So I'm having a hard time understanding the problem because I can't recreate it on my own computer which leads me to believe this is not XFCE but something else, either I'm not fully understanding the problem everyone is having or ...

Offline

#21 2014-07-06 00:00:45

Alexmint
Member
Registered: 2014-07-05
Posts: 1

Re: Dual monitor: panel is always on the left one

I have this bag too :-( the main monitor only at the left hand, 0x0 position.

Offline

#22 2014-07-06 19:24:33

gxagar
Member
Registered: 2012-03-14
Posts: 86

Re: Dual monitor: panel is always on the left one

I dual-boot Debian Stable and Testing.  Stable has the Nvidia proprietary driver, and testing has the Nouveau driver.  I use aRandR to config.  All works equally well on both OSs.  Applications on both OSs tend to open on the screen that my mouse is hovering on.  If I click to open on one screen, then move the cursor to the other screen while the app is opening, it opens on the other screen.  I have learned to keep my mouse still and wait, but it was hard.


Linuxers Live by a CODE!

Offline

Board footer

Powered by FluxBB