Xfce Forum

Sub domains
 

You are not logged in.

#1 2012-01-02 14:33:03

chengshiding
Member
Registered: 2011-12-14
Posts: 21

[Solved] please come in if you konw the debian testing + xfce4.8

my OS : debian testing + xfce4.8
There are some problem when i as a no root acount.
1. When I  plug a removable disk in my computer,  it is come out a ERROR DIALOG with the Not Authorized.
2. i is not  authorized to shutdown and reboot the computer.  i have fill the NOPASSWD filed to the /etc/sudoers.
Do anyone help me?
Thanks.

Offline

#2 2012-01-02 22:29:09

demosthenese
Member
From: Liverpool, UK
Registered: 2009-05-04
Posts: 62

Re: [Solved] please come in if you konw the debian testing + xfce4.8

How are you starting xfce - with startx or a display manager? I had similar problems when using slim, but not with gdm3 or lightdm. gdm3 has more dependencies so I currently use lightdm.

Offline

#3 2012-01-03 04:52:51

chengshiding
Member
Registered: 2011-12-14
Posts: 21

Re: [Solved] please come in if you konw the debian testing + xfce4.8

demosthenese wrote:

How are you starting xfce - with startx or a display manager? I had similar problems when using slim, but not with gdm3 or lightdm. gdm3 has more dependencies so I currently use lightdm.

i use the slim. and i have not used the other display managers. so, i will try the lightdm.

Offline

#4 2012-01-04 17:31:29

xfcelav
Member
From: /var/www/xfcelav
Registered: 2008-04-10
Posts: 96
Website

Re: [Solved] please come in if you konw the debian testing + xfce4.8

1- As root create the file /etc/polkit-1/localauthority/50-local.d/55-myconf.pkla

2- Add inside

[Storage Permissions]
Identity=unix-group:storage
Action=org.freedesktop.udisks.filesystem-mount;org.freedesktop.udisks.drive-eject;org.freedesktop.udisks.drive-detach;org.freedesktop.udisks.luks-unlock;org.freedesktop.udisks.inhibit-polling;org.freedesktop.udisks.drive-set-spindown
ResultAny=yes
ResultActive=yes
ResultInactive=no

3- Add your user in STORAGE group. If Storage does not exist, you must create it.

# addgroup storage
# usermod -a -G storage USERNAME

url: blog.desdelinux.net
twt: @elavdeveloper

Offline

#5 2012-01-05 08:49:57

chengshiding
Member
Registered: 2011-12-14
Posts: 21

Re: [Solved] please come in if you konw the debian testing + xfce4.8

xfcelav wrote:

1- As root create the file /etc/polkit-1/localauthority/50-local.d/55-myconf.pkla

2- Add inside

[Storage Permissions]
Identity=unix-group:storage
Action=org.freedesktop.udisks.filesystem-mount;org.freedesktop.udisks.drive-eject;org.freedesktop.udisks.drive-detach;org.freedesktop.udisks.luks-unlock;org.freedesktop.udisks.inhibit-polling;org.freedesktop.udisks.drive-set-spindown
ResultAny=yes
ResultActive=yes
ResultInactive=no

3- Add your user in STORAGE group. If Storage does not exist, you must create it.

# addgroup storage
# usermod -a -G storage USERNAME

Thanks, i modify the /usr/share/polkit-1/actions/org.freedesktop.udisks.policy.
modify the field "<allow_any>no</allow_any>"  to "<allow_any>yes</allow_any>".
it is work.
Thanks.

Offline

#6 2012-01-19 19:23:03

lifeinthegrey
Member
From: Seattle
Registered: 2012-01-17
Posts: 52

Re: [Solved] please come in if you konw the debian testing + xfce4.8

Just a heads up, I have multiple machines with testing + XFCE, and this is a slim-specific issue. If you use a different login manager (like lightdm or gdm), it registers the user as "active" and then the active protocols in policykit take over. Slim, for some reason, does not do that, which is why you need to set power, udisk, etc policykits to allow_any yes. By setting them this way, it is potentially a large security risk. Also, slim isn't in development anymore.

Last edited by lifeinthegrey (2012-01-19 19:23:27)


oh, you want eXtremely Fast Computing? thats Easy ...

Offline

Board footer

Powered by FluxBB