Xfce Forum

Sub domains
 

You are not logged in.

#1 2012-01-25 23:53:42

jesuisbenjamin
Member
Registered: 2012-01-25
Posts: 17

Problems installing pyxfce

Hello,

I am trying to install pyxfce on Xubuntu 11.10 (XFCE 4.8)

While running ./configure the error returns:

checking for libxfcegui4-1.0 >= 4.3.90... not found
*** The required package libxfcegui4-1.0 was not found on your system.
*** Please install libxfcegui4-1.0 (atleast version 4.3.90) or adjust
*** the PKG_CONFIG_PATH environment variable if you
*** installed the package in a nonstandard prefix so that
*** pkg-config is able to find it.

I first made sure the package was installed with:

sudo apt-get install libxfcegui*

Then I found out where all the pkgconfig paths are:

find /usr -name "pkgconfig"

Then I passed the output to the path variable and exported it:

PKG_CONFIG_PATH=/usr/share/pkgconfig/:/usr/lib/i386-linux-gnu/pkgconfig/:/usr/lib/pkgconfig/
export PKG_CONFIG_PATH

Running ./configure again however, didn't go any better.

What am I missing here?

Thanks

Last edited by jesuisbenjamin (2012-01-27 01:10:31)

Offline

#2 2012-01-26 07:53:14

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: Problems installing pyxfce

Do you have /usr/lib/pkgconfig/libxfcegui4-1.0.pc?

Offline

#3 2012-01-26 11:56:00

jesuisbenjamin
Member
Registered: 2012-01-25
Posts: 17

Re: Problems installing pyxfce

Nope sad

I merely have:

benjamin@xubuntu:~$ find /usr -name "*.pc" | grep libxfce
/usr/lib/pkgconfig/libxfce4util-1.0.pc

Edit:
OK, somehow the following did not install the libxfcegui4 series:

sudo apt-get install libxfce*

Now I installed it and ./configuration is asking for libxfce4menu-0.1, which apt-cache search does not return neutral

After some research it appears libxfce4menu-0.1 is deprecated and replaced by libxfce4utils and garcon. Will the installation of pyxfce work at all then?

Last edited by jesuisbenjamin (2012-01-26 17:20:29)

Offline

#4 2012-05-11 11:09:59

FrancescoA
Member
Registered: 2009-04-27
Posts: 38

Re: Problems installing pyxfce

Hello, I also tried and have the same problems.

Offline

Board footer

Powered by FluxBB