Xfce Forum

Sub domains
 

You are not logged in.

#1 2012-02-19 13:09:16

brabster
Member
Registered: 2012-02-19
Posts: 5

Xfce Display Settings Popup won't go away

Hi everyone, first post so apologies if I break etiquette!

I'm trying out Xfce, really like it so far but I can't stop the 'Display Settings' dialog from popping up every few seconds. I have an external monitor plugged in to my laptop and I select to display on that monitor only, but it pops up again maybe 30 seconds later to ask me again. And again. And again. Leaving it open doesn't help - just keeps popping up. the only way I've found to kill it is to kill the xfce-settings-helper in 'Session and Startup', which would be fine but that also kills my keyboard shortcuts, which I kinda depend on.

So - how do I kill this dialogue (I have lxrandr popup on startup once and I choose how I want my displays to work) without killing my keyboard shortcuts? (Mint 11 Katya with Xfce 4.8 distributed by Xubuntu)

Thanks a lot for the help, and apologies if it's a stupid newbie question!

Offline

#2 2012-02-19 14:43:21

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,063

Re: Xfce Display Settings Popup won't go away

Is it the xfce4 Display Settings dialog that keeps popping up or the lxrandr one? (The xfce4 Display Settings dialog carries the title "Display" whereas the lxrandr one, based on screenshots I've seen, carries the title "Display Settings"). If its the lxrandr one, then:

- what is the command that you are using to autostart it?
- where are you putting this autostart command?

And, is there any reason why you're not using the xfce4 Display Settings manager (Alt-F2 then run xfce4-display-settings, or find it in the Settings Manager) when using xfce?

Offline

#3 2012-02-20 18:01:44

brabster
Member
Registered: 2012-02-19
Posts: 5

Re: Xfce Display Settings Popup won't go away

Hi ToZ

The dialog is titled 'Display settings'  and starts with 'Several displays are available. Use:' before defaulting to the Laptop panel and offering the external display and both displays cloned. It's not the diaply

To help clarify, I have removed the 'Session and Startup' option I was using to auto start lxrandr (which is also in my Main Menu options as 'Monitor Settings' which is where I found it) and restarted my session. Same problem, the dialog I describe above prompts me to choose every maybe 30 seconds or so. As soon as I 'Quit program' on the xfce4-settings-helper in the 'Session and Startup' dialog, the popup stops. I have LXDE installed on the same system and lxrandr is part of that, which is where I know it from.

I hope that answers the questions and provides enough additional information

Offline

#4 2012-02-20 18:26:38

secipolla
Member
Registered: 2012-01-15
Posts: 393

Re: Xfce Display Settings Popup won't go away

Then you could uninstall lxrandr and use only xfce4-display-settings.

Offline

#5 2012-02-20 19:14:59

brabster
Member
Registered: 2012-02-19
Posts: 5

Re: Xfce Display Settings Popup won't go away

@secipolla no good, following uninstall of lxrandr (and lxde as it's required) still got the same problem.

Offline

#6 2012-02-21 03:03:23

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,063

Re: Xfce Display Settings Popup won't go away

Then what program is it that is running? Open a terminal window and type in:

xprop

...the cursor will change to a +. Click on the "Display Settings" window and all of the window properties will display in the terminal window. Post back the last bit of text. It should help us identify the program that is running.

You can also try cleaning out your sessions cache (this will reset your saved sessions). You can do this via:

rm -rf ~/.cache/sessions

It's quite possible that the program is starting automatically this way.

Offline

#7 2012-02-21 18:16:31

brabster
Member
Registered: 2012-02-19
Posts: 5

Re: Xfce Display Settings Popup won't go away

Hey ToZ

Here's that output - nice tip!

_NET_WM_SYNC_REQUEST_COUNTER(CARDINAL) = 73400325
_NET_WM_WINDOW_TYPE(ATOM) = _NET_WM_WINDOW_TYPE_NORMAL
_NET_WM_USER_TIME_WINDOW(WINDOW): window id # 0x4600004
WM_CLIENT_LEADER(WINDOW): window id # 0x4600001
_NET_WM_PID(CARDINAL) = 2532
WM_LOCALE_NAME(STRING) = "en_GB.UTF-8"
WM_CLIENT_MACHINE(STRING) = "paul-laptop"
WM_NORMAL_HINTS(WM_SIZE_HINTS):
        program specified location: 0, 0
        program specified minimum size: 258 by 159
        program specified maximum size: 258 by 159
        window gravity: NorthWest
WM_PROTOCOLS(ATOM): protocols  WM_DELETE_WINDOW, WM_TAKE_FOCUS, _NET_WM_PING, _NET_WM_SYNC_REQUEST
WM_CLASS(STRING) = "xfce4-display-settings", "Xfce4-display-settings"
WM_ICON_NAME(STRING) = "Display settings"
_NET_WM_ICON_NAME(UTF8_STRING) = "Display settings"
WM_NAME(STRING) = "Display settings"
_NET_WM_NAME(UTF8_STRING) = "Display settings"

Offline

#8 2012-02-21 19:48:36

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,063

Re: Xfce Display Settings Popup won't go away

Hmmm, it is the xfce4-display-settings dialog that is popping up every 30 seconds. This is odd.

Is there anything relevant in your ~/.xsession-errors log file about this dialog box?

Does it happen when you use only the laptop screen and not the external monitor? (Maybe something is triggering it)

Anything in your /var/log/Xorg.0.log file? How about dmesg?

Offline

#9 2012-02-22 19:16:46

brabster
Member
Registered: 2012-02-19
Posts: 5

Re: Xfce Display Settings Popup won't go away

Xorg.0.log prints:

[   432.542] (II) fglrx(0): EDID vendor "SAM", prod id 694
[   432.542] (II) fglrx(0): Using hsync ranges from config file
[   432.542] (II) fglrx(0): Using vrefresh ranges from config file
[   432.542] (II) fglrx(0): Printing DDC gathered Modelines:
[   432.542] (II) fglrx(0): Modeline "1920x1200"x0.0  154.00  1920 1968 2000 2080  1200 1203 1209 1235 +hsync -vsync (74.0 kHz)
[   432.542] (II) fglrx(0): Modeline "800x600"x0.0   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz)
[   432.542] (II) fglrx(0): Modeline "800x600"x0.0   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz)
[   432.542] (II) fglrx(0): Modeline "640x480"x0.0   31.50  640 656 720 840  480 481 484 500 -hsync -vsync (37.5 kHz)
[   432.542] (II) fglrx(0): Modeline "640x480"x0.0   31.50  640 664 704 832  480 489 492 520 -hsync -vsync (37.9 kHz)
[   432.542] (II) fglrx(0): Modeline "640x480"x0.0   30.24  640 704 768 864  480 483 486 525 -hsync -vsync (35.0 kHz)
[   432.542] (II) fglrx(0): Modeline "640x480"x0.0   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz)
[   432.542] (II) fglrx(0): Modeline "720x400"x0.0   28.32  720 738 846 900  400 412 414 449 -hsync +vsync (31.5 kHz)
[   432.542] (II) fglrx(0): Modeline "1280x1024"x0.0  135.00  1280 1296 1440 1688  1024 1025 1028 1066 +hsync +vsync (80.0 kHz)
[   432.542] (II) fglrx(0): Modeline "1024x768"x0.0   78.75  1024 1040 1136 1312  768 769 772 800 +hsync +vsync (60.0 kHz)
[   432.542] (II) fglrx(0): Modeline "1024x768"x0.0   75.00  1024 1048 1184 1328  768 771 777 806 -hsync -vsync (56.5 kHz)
[   432.542] (II) fglrx(0): Modeline "1024x768"x0.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz)
[   432.542] (II) fglrx(0): Modeline "832x624"x0.0   57.28  832 864 928 1152  624 625 628 667 -hsync -vsync (49.7 kHz)
[   432.542] (II) fglrx(0): Modeline "800x600"x0.0   49.50  800 816 896 1056  600 601 604 625 +hsync +vsync (46.9 kHz)
[   432.542] (II) fglrx(0): Modeline "800x600"x0.0   50.00  800 856 976 1040  600 637 643 666 +hsync +vsync (48.1 kHz)
[   432.542] (II) fglrx(0): Modeline "1152x864"x0.0  108.00  1152 1216 1344 1600  864 865 868 900 +hsync +vsync (67.5 kHz)
[   432.543] (II) fglrx(0): Modeline "1600x1200"x0.0  162.00  1600 1664 1856 2160  1200 1201 1204 1250 +hsync +vsync (75.0 kHz)
[   432.543] (II) fglrx(0): Modeline "1280x1024"x0.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz)
[   432.543] (II) fglrx(0): Modeline "1280x960"x0.0  108.00  1280 1376 1488 1800  960 961 964 1000 +hsync +vsync (60.0 kHz)

each time the dialog pops up.

Stuff mentioning X in ~/.xsession-errors:


pb@paul-laptop ~ $ tail -100f ~/.xsession-errors|grep -i x
/etc/gdm/Xsession: Beginning session setup...
Start IM through /etc/X11/xinit/xinput.d/all_ALL linked to /etc/X11/xinit/xinput.d/default.
/usr/bin/startxfce4: X server already running on display :0
xfdesktop[1848]: starting up
** Message: Initializing gksu extension...
xfdesktop: Fatal IO error 2 (No such file or directory) on X server :0.0.
xfdesktop[2155]: starting up
xfdesktop: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
xfdesktop[2291]: starting up
(xfce4-display-settings:2389): xfconf-WARNING **: No bindings were found on the channel
(xfce4-display-settings:2392): xfconf-WARNING **: No bindings were found on the channel
(xfce4-display-settings:2395): xfconf-WARNING **: No bindings were found on the channel
xfdesktop: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
xfdesktop[2558]: starting up
xfdesktop: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
xfdesktop[2562]: starting up
xfdesktop: Fatal IO error 2 (No such file or directory) on X server :0.0.
xfdesktop[2564]: starting up
xfdesktop: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.

Nothing suspicious looking in dmesg...

Offline

#10 2012-02-22 20:24:13

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,063

Re: Xfce Display Settings Popup won't go away

Does this happen when you don't use the external monitor?

xfdesktop keeps on crashing - this is not good. Are you manually restarting it? (Not sure if its related).

Have you tried clearing your sessions cache?

Offline

#11 2012-03-30 14:37:37

ThunderFox
Member
Registered: 2012-03-30
Posts: 1

Re: Xfce Display Settings Popup won't go away

Hello!

Sorry for hacking into this topic, but I'm having this exact same problem. I think I might be able to give out some more details about it, even though I'm yet to find a solution for this.

First of all, I'm also using a laptop, particularly an HP Pavilion DV6 with ATI graphics and using the 'radeon' driver. The problem has happened before with the official ATI driver as well. I'm running openSUSE 12.1 and I have XFCE as well as GNOME installed. This has been happening both on openSUSE and Ubuntu Oneiric, except that on Oneiric, the XFCE display popup did not appear.

What has been common is that, this problem only happened (on both distributions) with an external monitor plugged in.

On both, the login manager reverted to default resolution right on boot. Then, on GNOME, with both distributions also, the resolution kept reverting to default and both displays automatically cloned. This could happen anywhere from 30 seconds to a few minutes after you set the resolution properly. GNOME does not have a prompt telling you which monitor to use.

On XFCE, I've had to set the monitors to manually extend through xrandr on session start (not lxrandr) also on both distributions. On Ubuntu, the computer didn't seem to mind this, and always set the resolution properly after the login screen. On openSUSE though, I keep getting this pop-up. It happens with the same frequency that the monitors used to reset when using GNOME. I think this might be directly related.

I've narrowed it down to three things, from observation. One, this is not distribution-specific. Two, this has something to do with the graphics driver or this computer in particular, and three, the monitors are behaving as if they keep detecting a new monitor being plugged in.

I've researched onto the hypothesis of disabling monitor plug n' play and see if this solved the problem. So far I have not yet found a way to do so. On another note, this is a rather recent problem, which did not happen with older versions of Linux. Back when X.org still used the /etc/X11/xorg.conf file instead of that new model, these problems didn't exist. So many new things have been implemented since then (Kernel 3.0, new xorg, upstart, etc) I don't even know where to trace this back to.


Anyway, I just wanted to share with you that this is likely not a XFCE related problem, and if you can find a solution, I'd be grateful. If you need any help to find the problem I'm up for it. I'm sick of this nagging problem. This computer has been riddled with graphics driver problems ever since I bought it.

Offline

#12 2013-05-02 12:16:22

AngelG
Member
From: Sofia
Registered: 2013-05-02
Posts: 2

Re: Xfce Display Settings Popup won't go away

Well since I have the same problem, here's how I hacked it (nasty) to get myself served until a better solution is found:
1) Move the original file (in case you decide to revert the changes;  yes, it is the xfce4-display-settings):
sudo mv /usr/bin/xfce4-display-settings /usr/bin/xfce4-display-settings.original
2) Create a fake file:

sudo cp /bin/true  /usr/bin/xfce4-display-settings

This fake xfce4-display-settings (native code) just returns "true" to keep the calling application happy. (I don't know which daemon keeps calling it).
5) Logoff/logon;Enjoy XFCE4. Of course your "Display" in xfce settings won't work now, so you'll want to install lxrandr via Software Center to get the functionality. It's icon will be the same but called "Monitor Settings"
You may have to repeat this after distribution upgrade.

Last edited by AngelG (2013-05-02 12:35:25)

Offline

#13 2013-10-19 21:58:09

netglitch
Member
Registered: 2013-10-19
Posts: 1

Re: Xfce Display Settings Popup won't go away

I've run into this issue as well. Thunderfox's observations gave me an idea. My laptop has a hybrid graphics configuration, AMD/Intel. After turning off the discrete graphics chipset with vgaswitcheroo, the issue stopped. I haven't been able to determine what the root cause of the issue is, but I'm going to go out on a limb and say, at least in my situation, it has something to do with having more then one graphics chipset. There are no errors in Xorg.0.log, dmesg or xsession-errors. I'm currently running XFCE 4.10 on Xubuntu 13.10 with Linux 3.11. Fortunately for me I don't need the discrete graphics so for now I can leave it off.

Offline

Board footer

Powered by FluxBB