Xfce Forum

Sub domains
 

You are not logged in.

#1 2012-04-06 01:47:09

tbk2000
Member
Registered: 2010-08-05
Posts: 10

Error on make of libxfcegui4 in xfce4.10pre1

I can not install libxfcegui4(mousepad depend on it),have installed xfce4.10pre1.

this is the error message I get while making libxfce4gui4:

Making all in libxfcegui4
make[2]: Entering directory `/home/damp/libxfcegui4-4.8.1/libxfcegui4'
make  all-am
make[3]: Entering directory `/home/damp/libxfcegui4-4.8.1/libxfcegui4'
  CC     libxfcegui4_la-netk-enum-types.lo
In file included from ../libxfcegui4/libxfcegui4.h:46:0,
                 from netk-enum-types.c:4:
../libxfcegui4/xfce-appmenuitem.h:73:56: error: unknown type name 'XfceDesktopEntry'
make[3]: *** [libxfcegui4_la-netk-enum-types.lo] 错误 1
make[3]: Leaving directory `/home/damp/libxfcegui4-4.8.1/libxfcegui4'
make[2]: *** [all] 错误 2
make[2]: Leaving directory `/home/damp/libxfcegui4-4.8.1/libxfcegui4'
make[1]: *** [all-recursive] 错误 1
make[1]: Leaving directory `/home/damp/libxfcegui4-4.8.1'
make: *** [all] 错误 2

Offline

#2 2012-04-06 06:12:41

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: Error on make of libxfcegui4 in xfce4.10pre1

Apply this patch. I'll make a new release for 4.10, but because we don't support gui4 it is not in the main package list.

Offline

#3 2012-04-06 08:20:38

tbk2000
Member
Registered: 2010-08-05
Posts: 10

Re: Error on make of libxfcegui4 in xfce4.10pre1

Think you ,I will try it.

Offline

#4 2012-04-06 10:44:07

Keith Hedger
Member
From: Torrington,Devon,UK
Registered: 2012-04-01
Posts: 46
Website

Re: Error on make of libxfcegui4 in xfce4.10pre1

Nick wrote:

Apply this patch. I'll make a new release for 4.10, but because we don't support gui4 it is not in the main package list.

I have just applied this patch and now the gui lib compiles fine as do other apps like screenshooter

Offline

#5 2012-04-23 19:07:26

mrk3004
Member
Registered: 2012-01-16
Posts: 5

Re: Error on make of libxfcegui4 in xfce4.10pre1

Nick wrote:

Apply this patch. I'll make a new release for 4.10, but because we don't support gui4 it is not in the main package list.

I have the same problem in libxfcegui4 4.6.4 (#GIT d9429abb0b), your patch solved it for me.

:S

strange...

Last edited by mrk3004 (2012-04-23 19:07:59)

Offline

#6 2012-04-23 21:13:31

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: Error on make of libxfcegui4 in xfce4.10pre1

Already released libxfcegui4-4.9.0 which includes the patch.

http://archive.xfce.org/src/xfce/libxfcegui4/4.9

Offline

Board footer

Powered by FluxBB