Xfce Forum

Sub domains
 

You are not logged in.

#1 2012-04-13 20:55:53

secipolla
Member
Registered: 2012-01-15
Posts: 393

Little issues with Xfce 4.10.

I've installed 4.10 pre-release in Fedora 17. Here are some minor issues that I thought I might write here instead of opening bug reports.

1) This I would like to know if it's a xfce-session bug or not. If a desktop file of those that can be auto-started has a '&' on the 'Comment' line, then that line will be messed up (it will show other unrelated stuff) in the 'session and startup' settings, 'autostarted apps.' tab.
In ~/.xsession-errors we see:

(xfce4-session-settings:1455): Gtk-WARNING **: Failed to set text from markup due to error parsing markup: Error on line 1: Entity did not end with a semicolon; most likely you used an ampersand character without intending to start an entity - escape ampersand as &

So it looks like it isn't an xfce-session bug and instead it's from the app which should use '&' or just 'and'.
Just mentioning, anyway.

2) The 'Action Buttons' panel plugin doesn't show any icon for the 'Suspend' action. This using the GNOME icon theme. It seems the plugin wants a 'system-suspend' icon but maybe it should just use 'xfsm-suspend' that xfce-session installs (also an icon theme that HAS system-suspend, Faenza, also has it with the name xfsm-suspend).

3) The new MIME type editor's desktop file points to application-default-icon but I don't know of an icon theme that has that one. Maybe just use 'applications-other'?
* BTW, some very good icon themes originally made for GNOME (like blank-on, gartoon, yasis etc.) are simply being abandoned. Like they don't work any more with GNOME 3 because they changed the icon theme template, so to speak, so just mentioning, maybe someone with a lot of time on his/hers hands would adapt to Xfce ;-)

4) The xfce-aplications.menu file still has the entries for 'help' and 'about' but those desktop files don't exist any more, right?
And as a very minor issue, xfce-session-logout.desktop is 'Log Out' (the one that shows in the menu) and maybe it should change to 'Log Out...' to be like the same action in the 'Action buttons' plugin.

--

On a plus side, well done, IMO, by listing 'non-Xfce' options (in italics) for the auto-start apps. With this I can work around, by using gnome-fallback-mount from gnome-settings-daemon, the fact that no matter how much I try I can't get thunar-volman to automount (and this breaks all the other actions it could perform). I was having this with 4.8 and it stays with 4.10. But this, when I build up a bit more patience, I will discuss first in the Xfce mailing-list in Fedora as it could be something like some udev rule interfering, from what I read in other posts.
But nonetheless the GNOME service works very well and it does it in a simple way, user interface wise, as it has just the options to enable/disable auto-mount or auto-run*. Then it asks what to do depending on the media inserted and possibly just uses the MIME stuff to act accordingly. (how it does behind the scenes I have no idea).

* these are set-up in dconf-editor (at least I have no GUI installed here like, maybe, gnome-control-center).

Last edited by secipolla (2012-04-13 21:00:05)

Offline

#2 2012-04-18 19:45:50

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,144
Website

Re: Little issues with Xfce 4.10.

Fixed 1 3 and 4.

Offline

#3 2012-04-18 23:40:24

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,059

Re: Little issues with Xfce 4.10.

If you don't mind, can I add one further issue to this list?

If you create a launcher using exo-open as the command and specify a url that contains the percentage sign (%), the % sign is removed and the link doesn't open properly. e.g.

exo-open "www.somesite.com/page%2F.html"

If you launch the command from a terminal window, it works fine - so something in the launcher code is removing the %.
Thanks

Offline

#4 2012-04-19 00:09:09

secipolla
Member
Registered: 2012-01-15
Posts: 393

Re: Little issues with Xfce 4.10.

Nick wrote:

Fixed 1 3 and 4.

I'd noticed it, thank you.

Offline

#5 2012-04-19 06:24:04

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,144
Website

Re: Little issues with Xfce 4.10.

If you want a % in the launcher, you have to add %%, because the command is executed following the desktop file spec.

Offline

#6 2012-04-19 10:48:05

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,059

Re: Little issues with Xfce 4.10.

Nick wrote:

If you want a % in the launcher, you have to add %%, because the command is executed following the desktop file spec.

Thanks Nick.

Offline

#7 2012-04-19 23:22:37

secipolla
Member
Registered: 2012-01-15
Posts: 393

Re: Little issues with Xfce 4.10.

As far as I could understand, "Automatically tile windows when moving towards the screen edge" in xfwm4-tweaks-settings (Accessibility tab) only works if "Wrap workspaces when dragging a window off the screen" in xfwm4-settings (Advanced tab) is disabled.
So maybe there should be an explanation text/tooltip for that option.

Offline

Board footer

Powered by FluxBB