Xfce Forum

Sub domains
 

You are not logged in.

#1 2012-05-23 16:43:01

Grzesiek
Member
Registered: 2012-05-23
Posts: 3

[Solved] Unable to mount removable devices

Hi there.

I (more/less) successfully installed xfce-4.8 on my PLD linux machine (www.pld-linux.org) but I'm no t able to mount removable devices such as USB pen-drives or CDs. More precisely, when I insert pen-drive its icon is displayed on the desktop. I right-click on it and select "Mount Volume". Then I get the message: "Failed to mount, Not authorizes to perform the operation". Mounting works fine when logged in as root.

Note that I log in using text console and then I use startxfce4 commad to start X server.

Thanks in advance for any help.

Greg

Offline

#2 2012-05-24 01:55:12

lifeinthegrey
Member
From: Seattle
Registered: 2012-01-17
Posts: 52

Re: [Solved] Unable to mount removable devices

I had this problem when I was using SLiM as a login manager. Basically, you need to edit policy kit to allow the user to mount devices. In the case of most login managers, it automatically allows the active user to perform actions, but SLiM does not get recognized as an active user (for some reason) and therefore has issues.

But even if you aren't using SLiM, policy kit modification would be the way to go. I'm a debian user, so my path to it is /usr/share/polkit-1/actions, but yours may be different. Once you are in the polkit actions folder, though, you want to edit the udisks policy. If setting <allow_active>yes</allow_active> doesn't work (for SLiM it won't), then you need to create / edit <allow_any>yes</allow_any>. For ANY user to mount the device. (I don't recommend this because of security reasons, but it is the only way sometimes).

Or, if you ARE using SLiM, you could just install lightdm. Solves all problems.


oh, you want eXtremely Fast Computing? thats Easy ...

Offline

#3 2012-05-25 15:17:00

Grzesiek
Member
Registered: 2012-05-23
Posts: 3

Re: [Solved] Unable to mount removable devices

Thanks for your answer.

In my disto I found the file /usr/share/polkit-1/actions/org.freedesktop.udisks2.policy (PLD is equipped with Udisk2). Inside I found plenty of different settings and I don know which one to change. It would be nice if you could take a look at http://hermes.sojka.co/pld/org.freedesk … .policy.gz and help me to fix it.

Regards

Offline

#4 2012-05-25 22:06:59

Grzesiek
Member
Registered: 2012-05-23
Posts: 3

Re: [Solved] Unable to mount removable devices

I managed to find the appropriate setting to change:

<action id="org.freedesktop.udisks2.filesystem-mount-other-seat">
.....
<allow_any>yes</allow_any>

(was auth_admin).
The most surprising thing is that it is filesystem-mount-other-seat instead of filesystem-mount. I'm plunging USB drive directly to my own computer not some remote machine.

Regards and thanks for help.

Offline

#5 2012-05-26 02:44:37

lifeinthegrey
Member
From: Seattle
Registered: 2012-01-17
Posts: 52

Re: [Solved] Unable to mount removable devices

No worries, although it shouldn't be too surprising. filesystem-mount refers to local filesystems, such as your internal partitions dedicated to windows. filesystem-mount-other-seat refers to filesystems that are seated differently than the standard, always-connected internal drives, such as USB connections.

Either way, realize that the allow_any situation is a huge security risk. Better to have a manager that actually notifies the system of being an active user (lightdm, gdm, mdm, kdm, the list goes on).


oh, you want eXtremely Fast Computing? thats Easy ...

Offline

Board footer

Powered by FluxBB