Xfce Forum

Sub domains
 

You are not logged in.

#1 2012-06-24 10:10:48

Vito49
Member
From: Aarschot/Belgium
Registered: 2012-03-04
Posts: 4

GIMP stays on all workspaces

Hello, first of all: I'm not sure this is a GIMP problem or an XFCE problem. But i think it happened after GIMP froze and I had to use ctrl/alt/BS ... I'm not English but I will try to explain what happens.

I'm using Xfce 4.8.
And only Xfce, no other OS on my system.

I use 4 workspaces. When I open GIMP in a workspace everything seems to be normal, I have the main GIMP window, the toolbox and the layers-window. I can use GIMP the way it is intended, no problems.
But when I switch to another workspace, the toolbox and the layer-window are there too, NOT the main-window, and they are in all workspaces.
In fact these windows seem to be made "sticky", but there is no way to switch them to "un-sticky", I even can't move them to another workspace (there's no option to do that), this I can only do with the main-window which is only in the workspace I started GIMP in.
Another thing: when I move the main-window to another workspace all Gimp-windows disappear from the other workspaces, everything seems to be completely normal as it was before, GIMP is only in 1 workspace, but from the moment I open the workspace containing GIMP the toolbox and the layer-window are back on all workspaces ....

Confused? Me too :-)
Believe me, I did almost everything possible to fix this, but nothing helps.
I would appreciate if somebody could help me to fix this problem. Feel free to ask if you need additional information.

Thanks.
Vito

PS: sorry if this topic is not valid for this forum.


Vito
Xfce user from Aarschot/Belgium/Europe

Offline

#2 2012-06-24 12:40:43

secipolla
Member
Registered: 2012-01-15
Posts: 393

Re: GIMP stays on all workspaces

This bugged me too. GIMP behaves like that for me too.
I don't use it much but when I want those windows out of the way I minimize them.

Offline

#3 2012-06-24 21:32:33

Sideburns
Member
From: Camarillo, CA
Registered: 2011-03-30
Posts: 296
Website

Re: GIMP stays on all workspaces

Try this: with the GIMP open, right-click on its button on the task bar.  Make sure that Only on This Workspace is checked and Always on Visible Workspace is unchecked.


Registered Linux user #470359
Permanently recovered BOFH
Any advice in this post is worth exactly what you paid for it.

Offline

#4 2012-06-25 12:03:14

Vito49
Member
From: Aarschot/Belgium
Registered: 2012-03-04
Posts: 4

Re: GIMP stays on all workspaces

Sideburns wrote:

Try this: with the GIMP open, right-click on its button on the task bar.  Make sure that Only on This Workspace is checked and Always on Visible Workspace is unchecked.

I already tried this before, it doesn't help.
Keep in mind that ONLY the toolbox and the layer-window are on all workspaces, NOT the Gimp main-window, this one resides only in the workspace I started GIMP in.

I can't minimize the unwanted windows, I can only set them to top, but then the same window (toolbox and so on) in all workspaces are set to top, also in the workspace the main-window resides ..
At the moment I do this before switching from GIMP to another workspace, but it all worked normal before ...

Vito


Vito
Xfce user from Aarschot/Belgium/Europe

Offline

#5 2012-06-25 12:30:04

Vito49
Member
From: Aarschot/Belgium
Registered: 2012-03-04
Posts: 4

Re: GIMP stays on all workspaces

Sideburns wrote:

Try this: with the GIMP open, right-click on its button on the task bar.  Make sure that Only on This Workspace is checked and Always on Visible Workspace is unchecked.

Additional information:

I have another user-account for testing purpose on my computer and GIMP behaves exactly the same in that account. So I can be sure it has nothing to do with set-up files in my personal home folder.

There are several set-up files (rc files) in /etc/gimp/2.0 ... I checked them too but as far as I understand them there is no setting to make the toolbox and other windows sticky.

I'm a bit ashamed to say, but I also reinstalled GIMP (only the main package) and it made no difference. I agree, this is the Microsoft Windows way ... I seldom do that.

That's why I'm afraid this error with GIMP is Xfce related.

Vito


Vito
Xfce user from Aarschot/Belgium/Europe

Offline

#6 2012-07-05 16:12:32

Ahau
Member
Registered: 2011-12-22
Posts: 27

Re: GIMP stays on all workspaces

Hi Vito49,

I had a report of this issue as well, you can see my response here: http://porteus.org/forum/viewtopic.php? … t=10#p8233

Here's the solution I found:
Open GIMP -> edit -> preferences -> window management -> change dropdowns for "Hint for the toolbox:" and "Hint for other docs:" to "Normal window" or "keep above". Then restart GIMP. They should now stay in the same workspace as the main window.

Hope that helps...

Offline

Board footer

Powered by FluxBB