Xfce Forum

Sub domains
 

You are not logged in.

#1 2012-09-10 18:08:54

Alp
Member
Registered: 2012-09-10
Posts: 7

Middle Mouse Button does not work at all

First of all, this is my first experience with XFCE. I was using Gnome for a long time, but due to Gnome3/Unity i decided to switch to something else. First, i tried E17, but that did not satisfy me. But XFCE feeled great from the the very first second!

Ok, here is my problem: I cannot middle-click with my mouse. That means:

* No Middle-Click-Paste
* No Middle-Click Tab-Close in my browser
* No Middle-Click Open-in-new-Tab in my browser

I could imagine that this is related to my xorg config, so here is the relevant stuff:

$ cat /etc/X11/xorg.conf.d/10-evdev.conf 
#
# Catch-all evdev loader for udev-based systems
# We don't simply match on any device since that also adds accelerometers
# and other devices that we don't really want to use. The list below
# matches everything but joysticks.

Section "InputClass"
        Identifier "evdev pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
	Option "XkbLayout" "de"
	Option "XkbVariant" "deadgraveacute"
EndSection

Section "InputClass"
        Identifier "evdev touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev tablet catchall"
        MatchIsTablet "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev touchscreen catchall"
        MatchIsTouchscreen "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Last edited by Alp (2012-09-10 18:09:22)

Offline

#2 2012-09-10 22:49:30

secipolla
Member
Registered: 2012-01-15
Posts: 393

Re: Middle Mouse Button does not work at all

Did you create that file yourself?
evdev is a basic input driver, I don't think it needs anything like that.
Unless you're using some DIY distro that needs this...
Try renaming that file and restarting X.

Offline

#3 2012-09-11 13:48:38

Alp
Member
Registered: 2012-09-10
Posts: 7

Re: Middle Mouse Button does not work at all

I am using Arch Linux, and the file was there already. I tried it without the file but then i have no mouse nor keyboard input at all. I had to reboot in Runlevel 1 to put the file in its initial folder.

Any other ideas?

Offline

#4 2012-09-11 15:05:13

secipolla
Member
Registered: 2012-01-15
Posts: 393

Re: Middle Mouse Button does not work at all

man evdev might give you some idea.

Offline

#5 2012-09-11 22:55:27

Alp
Member
Registered: 2012-09-10
Posts: 7

Re: Middle Mouse Button does not work at all

Didn't help, I am stuck here.

Offline

Board footer

Powered by FluxBB