Xfce Forum

Sub domains
 

You are not logged in.

#1 2012-09-18 11:00:12

v_andal
Member
Registered: 2012-09-18
Posts: 3

[Solved] earlier display of background image for desktop

I was trying to setup the system so that there's no flickering during transition from Login manager to XFCE. I'm using Slim as Login manager. So, I've set the same background for Slim and for XFCE. This worked very good with XFCE 4.6. But after I've upgraded to 4.8 I get this gray background during session initiation. Is there any way to avoid it?

Offline

#2 2012-09-18 11:27:41

secipolla
Member
Registered: 2012-01-15
Posts: 393

Re: [Solved] earlier display of background image for desktop

Maybe it's a slim issue (not saying it's a bug)?
Like for instance with lightdm whatever background you set it to use it sticks with Xfce and the one set by xfdesktop goes on top of it. But for LXDM I think it works like you said.

So if the gray colour is just the default that X sets maybe you could find out how to change it to something else. I think it can be done with xsetroot (in the session startup) but I think it can't use an image.

Offline

#3 2012-09-18 14:19:47

v_andal
Member
Registered: 2012-09-18
Posts: 3

Re: [Solved] earlier display of background image for desktop

Well, the grey I see is not the default that X sets. But you might be right about Slim. I've also installed newer version of Slim and it now supports ConsoleKit. I wonder if newer Slim clears the desktop background to grey color before starting XFCE. On the other hand, I'm starting XFCE from .xinitrc and there I was setting background using feh before executing startxfce4. Even this didn't help.

Maybe there's some way to at least force xfdesktop to run earlier?

Offline

#4 2012-09-19 00:29:13

secipolla
Member
Registered: 2012-01-15
Posts: 393

Re: [Solved] earlier display of background image for desktop

I don't know if it's wise to mess with xfdesktop. Like it may depend on xfsettingsd etc. and may start in the proper sequence. And as you said, not even messing with feh solved it so maybe it's just the way slim is working.
Maybe you have just to live with it or if you don't mind something a little bit heavier than slim, use lightdm (I don't even know if it's really heavier).

Offline

#5 2012-09-19 06:24:36

v_andal
Member
Registered: 2012-09-18
Posts: 3

Re: [Solved] earlier display of background image for desktop

Ok, I'll check it out.

Offline

#6 2012-09-19 11:24:10

SantaFe
Member
From: Freightyard.
Registered: 2010-09-06
Posts: 69

Re: [Solved] earlier display of background image for desktop

I might be wrong, but I don't think it's slim doing it.  I'm using Xfce 4.8.3 & lightDM & I get the grey screen also, & I don't have slim installed.


I use Xfce.  Don't you wish Everyone did? big_smile

Offline

#7 2012-09-19 12:30:29

secipolla
Member
Registered: 2012-01-15
Posts: 393

Re: [Solved] earlier display of background image for desktop

Just to try.
What if you remove xfdesktop or any other app that sets a background from auto-start?
Here in Fedora, in /etc/lightdm/lightdm-gtk-greeter.conf there's the background option which can be like

background=/usr/share/backgrounds/default.png

or

background=#314259

and it carries on to the desktop.

Offline

Board footer

Powered by FluxBB