Xfce Forum

Sub domains
 

You are not logged in.

#1 2012-09-28 08:54:13

oversky
Member
Registered: 2011-11-03
Posts: 2

[Solved] right-click menu responses slowly in Xubuntu, LinuxMint 13, LMDE

Recently I downloaded Fedora-17-i686-Live-XFCE, xubuntu-12.04-desktop-i386, linuxmint-13-xfce-dvd-32bit, and linuxmint-201204-xfce-dvd-32bit(LMDE).
In Fedora, the right-click menu shows up immediately.
However, in Xubuntun and Linumint, the menu delay for about half a second.
LMDE is the slowest. The delay is about one second.

I like apt-get more than rpm system.
Is there anything that I can turn to speed up XFCE in Xubuntun, Linumint, and LMDE?

Offline

#2 2012-09-28 09:21:05

angstrom
Member
Registered: 2011-08-13
Posts: 265

Re: [Solved] right-click menu responses slowly in Xubuntu, LinuxMint 13, LMDE

I have the same behavior (~ 1s delay) on OpenSuse 12.2.
I wonder if this delay is simply proportional to the number of .desktop file that are parsed when showing the whole Application menu tree ...

Last edited by angstrom (2012-09-28 09:26:10)


Xfce is NOT Xubuntu. Bugs in Xubuntu don't mean that Xfce is buggy ...

Offline

#3 2012-09-28 17:11:25

secipolla
Member
Registered: 2012-01-15
Posts: 393

Re: [Solved] right-click menu responses slowly in Xubuntu, LinuxMint 13, LMDE

I think the parameter that most affect the delay is icon loading. So if you have some misconfigured desktop file that's set to use a big icon (like it has a full path to a big image in its Icon key instead of just the icon name) that can delay menu loading a lot.
Otherwise, just more apps or an icon theme with heavier icons would influence.

As for rpm etc., in Fedora yum, yum-utils, rpm etc. are more flexible than apt, although aptitude can do wonders. But then all Fedora is more flexible and integrated than Debian and derived distros but one uses what fits one best.

Offline

#4 2012-09-29 02:13:06

andrzejr
Member
Registered: 2012-04-06
Posts: 47

Re: [Solved] right-click menu responses slowly in Xubuntu, LinuxMint 13, LMDE

I presume you mean right-click on the desktop.

If so, do the right-click on it, select "Desktop Settings" and "Menus" tab, and either:
- disable "Show applications menu..." completely, or
- disable "Show applications icons...".

Offline

#5 2012-09-29 13:43:13

oversky
Member
Registered: 2011-11-03
Posts: 2

Re: [Solved] right-click menu responses slowly in Xubuntu, LinuxMint 13, LMDE

andrzejr wrote:

I presume you mean right-click on the desktop.

If so, do the right-click on it, select "Desktop Settings" and "Menus" tab, and either:
- disable "Show applications menu..." completely, or
- disable "Show applications icons...".

This does work for me. Thanks, andrzejr.

Last edited by oversky (2012-09-29 13:43:58)

Offline

Board footer

Powered by FluxBB