Xfce Forum

Sub domains
 

You are not logged in.

#1 2012-11-09 15:44:09

apm
Member
Registered: 2012-11-09
Posts: 3

[solved] Calibre-Fonts and Text Huge (After .cache deleted)

hi,

First off, thanks to the XFCE devs for producing a great product.

XFCE version 4.8.3 (revision 360ccf2)
Fedora release 17 (Beefy Miracle), up to date
3.6.5-1.fc17.x86_64 #1 SMP Wed Oct 31 19:37:18 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Yesterday I deleted my .cache/sessions/* dirs (ran into the no borders issue and couldn't restart xfwm). Now when I start calibre (v. 0.9.1) all the text and icons are too large by a factor of 2 or more. I've gone into the calibre settings and they all look normal; 10 pt. font, medium icons etc. I've changed some of them, the font sizes and icon sizes, and restarted but everything is still huge. Does anyone have any suggestions as to how to fix or better diagnose the problem?

Last edited by apm (2012-11-09 16:39:36)

Offline

#2 2012-11-09 16:02:15

secipolla
Member
Registered: 2012-01-15
Posts: 393

Re: [solved] Calibre-Fonts and Text Huge (After .cache deleted)

It's a Qt app, isn't it.

If you don't mind it not looking exactly like your GTK apps then install qt-config and set the fonts there.

Offline

#3 2012-11-09 16:17:33

apm
Member
Registered: 2012-11-09
Posts: 3

Re: [solved] Calibre-Fonts and Text Huge (After .cache deleted)

Thanks for the help.

It is a qt app. I installed qt-config and tried setting fonts and GUI style, but it's not quite working right-in order to get approx. 10 pt fonts I have to set the font size to 6, the lowest. The qtconfig-qt4 app has the same issue as calibre; fonts and icons way too large. I'll try mucking around with the config files and see what happens.

Offline

#4 2012-11-09 16:45:40

apm
Member
Registered: 2012-11-09
Posts: 3

Re: [solved] Calibre-Fonts and Text Huge (After .cache deleted)

Thanks, secipolla, for the help.

I noticed I was getting the same error message when starting calibre and qtconfig-qt4:
QGtkStyle was unable to detect the current GTK+ theme
(Previously I was starting calibre from the panel so missed the warning.)

Searching on that led me to https://bbs.archlinux.org/viewtopic.php?id=99175
Some of the earlier comments on that thread didn't seem to apply; I don't have a $HOME/.gtkrc-2.0 for instance. I followed the suggestion from hurleyef and installed libgnomeui (via yum), logged out and back in, started calibre from the command line, no error, and everything looks normal again.

Offline

#5 2012-11-09 18:55:30

secipolla
Member
Registered: 2012-01-15
Posts: 393

Re: [solved] Calibre-Fonts and Text Huge (After .cache deleted)

If you don't mind all the things libgnomeui brings then fine.
Another way that maybe would work would be to remove it ('yum history undo last'), install Gconf2 and run

gconftool-2 --set --type string /desktop/gnome/interface/gtk_theme <theme name>

Replace with the name of your GTK theme.

Last edited by secipolla (2012-11-09 18:56:30)

Offline

Board footer

Powered by FluxBB