Xfce Forum

Sub domains
 

You are not logged in.

#1 2012-12-14 11:04:01

shadowen
Member
Registered: 2012-12-14
Posts: 2

[Solved] Disable that pop-to-front = pop to front on THIS desktop.

I'm having an annoying problem, that I've not been able to find a solution for on google or this forum (I conceed I might be using the wrong search terms).

I have an annoyance that often I have 4-5 browsers open on different desktops - I use a lot of desktops. - however when ever a website issues the pop-to-front command, or any program uses pop to front, the program moves from the desktop where I started it (which is tied with other programs running on that desktop), to the current desktop..

This is a huge annoyance for me, as I have desktops set up for running different things, such as managing different servers on different desktops, and so forth.

Thus this feature of programs relocating based on pop-to-front, is a huge pain, as I can't keep my environment clean.

(Note that I often have round 60-70 programs running, and having them randomly relocate is a huge problem).

I don't have this problem in gnome, nor when I used to use kde, programs stayed put on the desktop where I placed them.

Is there any way to make applications to stay put on the desktop where they were started ?

I'm running
xfce4-doc-4.8.3-1.el6.noarch
xfce4-icon-theme-4.4.3-5.el6.noarch
xfce4-settings-4.8.3-1.el6.x86_64
xfce4-session-4.8.1-4.el6.x86_64
libxfce4util-4.8.1-2.el6.x86_64
xfce4-power-manager-1.0.10-1.el6.x86_64
xfce4-panel-4.8.3-2.el6.x86_64
xfce4-session-engines-4.8.1-4.el6.x86_64
xfce-utils-4.8.3-1.el6.x86_64
libxfce4ui-4.8.0-4.el6.x86_64
xfce4-mixer-4.8.0-1.el6.x86_64
xfce4-appfinder-4.8.0-2.el6.x86_64

on Scientific Linux  6.3

Offline

#2 2012-12-14 11:28:16

ToZ
Member
From: Toronto, Canada
Registered: 2011-06-02
Posts: 933

Re: [Solved] Disable that pop-to-front = pop to front on THIS desktop.

Does changing the settings at "Settings Manager -> Window Manager Tweaks -> Focus -> When a window raises itself" help?

Offline

#3 2012-12-14 11:34:29

shadowen
Member
Registered: 2012-12-14
Posts: 2

Re: [Solved] Disable that pop-to-front = pop to front on THIS desktop.

Ah that's where it was hidden... 

I will test if that solves it - the description looks right.

Offline

Board footer

Powered by FluxBB