Xfce Forum

Sub domains
 

You are not logged in.

#1 2013-01-01 14:46:22

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,266

[Solved] xfwm4-settings dialog not being displayed

Just built from git to include new keyboard shortcuts changes (http://jeromeg.blog.free.fr/index.php?p … ork-landed). Compilation seems to go fine but xfwm4 settings dialog no longer opens.

toz@xubu:~$ xfwm4-settings
xfwm4-settings: symbol lookup error: xfwm4-settings: undefined symbol: xfce_shortcuts_xfwm4_get_feature_list

toz@xubu:~$ xfwm4 --version
    This is xfwm4 version 4.10.0git.9a81de5 (revision 9a81de5) for Xfce 4.10
    Released under the terms of the GNU General Public License.
    Compiled against GTK+-2.24.13, using GTK+-2.24.13.

    Build configuration and supported features:
    - Startup notification support:                 Yes
    - XSync support:                                Yes
    - Render support:                               Yes
    - Xrandr support:                               Yes
    - Embedded compositor:                          Yes
    - KDE systray proxy (deprecated):               No

Not sure if its a bug or an issue with my compilation, but have created a bug report 9707 (https://bugzilla.xfce.org/show_bug.cgi?id=9707).

Thanks in advance.

Last edited by ToZ (2013-01-02 00:10:55)

Offline

#2 2013-01-01 15:54:21

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,144
Website

Re: [Solved] xfwm4-settings dialog not being displayed

Looks like an old 4ui xfwm4 linked to.

Offline

#3 2013-01-01 21:16:41

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,266

Re: [Solved] xfwm4-settings dialog not being displayed

Thanks Nick.
Looks like its related to Ubuntu's multiarch. The library files are not being copied to /usr/lib/x86_64-linux-gnu (where old versions of the libraries exist) and which takes precedence. Need to do some script-fu'ing to fix that.

Last edited by ToZ (2013-01-02 00:11:18)

Offline

Board footer

Powered by FluxBB