Xfce Forum

Sub domains
 

You are not logged in.

#1 2013-01-02 05:55:51

dtd
Member
Registered: 2011-12-08
Posts: 17

Can not use Restart or Shutdown on the start menu.

This is essentially the same problem as "Unable to reboot/shutdown from Xfce (Debian Testing) by Pirlouis on 2011-10-11"

It is the same in that these buttons are greyed out. xfce is 4.10 on FreeBSD 9.1RC3.

My issue is only with out to activate the menu. I have configured the system as to have full access to the shutdown command as a non privileged user. The scripts ck-system-restart and ck-system-stop in /usr/local/lib/ConsoleKit/scripts work.

I do not see this as a FreeBSD issue. My issue is how to make the shutdown/restart buttons invoke the appropriate process. I had done what the install notes say should be added. This has no effect.

To be able to shutdown or reboot your system, you'll have to add a .pkla file
in /usr/local/etc/polkit-1/localauthority/50-local.d directory. Which looks
like this (replace PUTYOURGROUPHERE by your group):

[Restart]
Identity=unix-group:PUTYOURGROUPHERE
Action=org.freedesktop.consolekit.system.restart
ResultAny=yes
ResultInactive=yes
ResultActive=yes

[Shutdown]
Identity=unix-group:PUTYOURGROUPHERE
Action=org.freedesktop.consolekit.system.stop
ResultAny=yes
ResultInactive=yes
ResultActive=yes

For those who have working suspend/resume:

[Suspend]
Identity=unix-group:PUTYOURGROUPHERE
Action=org.freedesktop.upower.suspend
ResultAny=yes
ResultInactive=yes
ResultActive=yes

Offline

#2 2013-01-02 17:39:03

olivierd
Member
Registered: 2011-02-03
Posts: 12

Re: Can not use Restart or Shutdown on the start menu.

dtd wrote:

This is essentially the same problem as "Unable to reboot/shutdown from Xfce (Debian Testing) by Pirlouis on 2011-10-11"

It is the same in that these buttons are greyed out. xfce is 4.10 on FreeBSD 9.1RC3.

My issue is only with out to activate the menu. I have configured the system as to have full access to the shutdown command as a non privileged user. The scripts ck-system-restart and ck-system-stop in /usr/local/lib/ConsoleKit/scripts work.

You don't touch theses scripts, later, if you uninstall sysutils/consolekit, you'll get lots of warnings.

To be able to shutdown/reboot, you must create .pkla file in /usr/local/etc/polkit-1/localauthority/50-local.d/ (like below).

dtd wrote:

To be able to shutdown or reboot your system, you'll have to add a .pkla file
in /usr/local/etc/polkit-1/localauthority/50-local.d directory. Which looks
like this (replace PUTYOURGROUPHERE by your main group):

[Restart]
Identity=unix-group:PUTYOURGROUPHERE
Action=org.freedesktop.consolekit.system.restart
ResultAny=yes
ResultInactive=yes
ResultActive=yes

[Shutdown]
Identity=unix-group:PUTYOURGROUPHERE
Action=org.freedesktop.consolekit.system.stop
ResultAny=yes
ResultInactive=yes
ResultActive=yes

For those who have working suspend/resume:

[Suspend]
Identity=unix-group:PUTYOURGROUPHERE
Action=org.freedesktop.upower.suspend
ResultAny=yes
ResultInactive=yes
ResultActive=yes

Offline

#3 2013-01-03 08:20:26

dtd
Member
Registered: 2011-12-08
Posts: 17

Re: Can not use Restart or Shutdown on the start menu.

?? The first thing I did was make a .pkla file. As stated, that had no effect. The rest of the post was to indicate that as the X11 user I have access to shutdown. I assumed that the ConsoleKit scripts would be invoked by the menu. If that is the case, those scripts work, i.e., I can invoke them directly to shutdown or reboot.

Those options are however not available on the Start==>Log Out menu

Offline

#4 2013-01-03 14:25:59

Clio
Member
Registered: 2011-01-25
Posts: 35

Re: Can not use Restart or Shutdown on the start menu.

Perhaps is this helpful:
exec ck-launch-session startx
in your ~/.profile or .xinitrc

I use Debian not FreeBSD, but I think, the files are the same.

Offline

Board footer

Powered by FluxBB