Xfce Forum

Sub domains
 

You are not logged in.

#1 2012-04-07 04:00:19

rng
Member
Registered: 2012-04-07
Posts: 1

nautilus-open-terminal problem

I installed nautilus on xfce4 and then nautilus-open-terminal. I was not very happy with xterm that it opened and wanted to change it to xfterm4. I gave following commands:

$ gsettings set org.gnome.desktop.default-applications.terminal exec xfterm4
$ gsettings set org.gnome.desktop.default-applications.terminal exec-arg "' -e'"

However, now xfterm4 opens but it does so in home folder rather than in the folder being viewed in nautilus. This defeats the very purpose of installing nautilus-open-folder. How can I change this setting? I think it has something to do with /usr/bin/xfterm4 script.  Alternatively, I want all settings to be restored back to default.

Thanks for your help.

Last edited by rng (2012-04-08 01:01:48)

Offline

#2 2012-04-07 10:27:56

paolo321
Member
Registered: 2011-06-26
Posts: 120

Re: nautilus-open-terminal problem

You could try to use directly

xfce4-terminal

, or maybe gnome terminal...
(just my 2 cents, I'm absolutely not sure about it...)

Offline

#3 2013-01-16 19:19:03

naphelge
Member
Registered: 2012-03-19
Posts: 2

Re: nautilus-open-terminal problem

applied:
$ gsettings set org.gnome.desktop.default-applications.terminal exec xfce4-terminal

now opens xfce4-term when I right-clock open-term in nautilus, but will still open files in vim with gnome-term. any idea how to move this along one step further maybe so that when I right-click on a sh or html file to open in terminal vim (not gVim), as often is the case for me, the file will be opened by vim in xfce4-term rather than gnome.

Last edited by naphelge (2013-01-16 19:19:38)

Offline

Board footer

Powered by FluxBB