Xfce Forum

Sub domains
 

You are not logged in.

#1 2013-01-30 17:09:36

diolu
Member
Registered: 2013-01-24
Posts: 2

No sound events

I am using xfce 4.10 with the current version of archlinux. My problem is that I can't enable sound events. I have checked the box in the configuration but I have no sound. This is not a permission or hardware problem since apps are able to play sound just fine. I have installed libcanbera (and libcanberra-gstreamer) as suggested but still nothing. I am using plain alsa for the sound (so no pulseaudio); I can run /usr/bin/canberra-gtk-play from the command line (I have tried

/usr/bin/canberra-gtk-play -f /usr/share/sounds/freedesktop/stereo/trash-empty.oga).

But when I empty the Trash, I have no sound at all. I am out of idea now. Any help?

Last edited by diolu (2013-01-30 17:11:40)

Offline

#2 2013-01-30 19:39:16

SantaFe
Member
From: Freightyard.
Registered: 2010-09-06
Posts: 87

Re: No sound events

I hear you..... No pun intended wink    Music & video audio is fine, but I've got sound effects enabled, and the only sound effect I hear in Xfce 4.10 is when Thunderbird finishes loading e-mails, then I hear a beep.  Hmmm


bah weep grana weep ninny bon. big_smile

Offline

#3 2013-01-30 23:16:55

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 2,825

Re: No sound events

A per this thread: http://ubuntuforums.org/showthread.php?t=1869787, I've been able to get Xfce sounds to work in the past couple of versions of Xubuntu. YMMV with other distros, but it might point in the right direction.


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#4 2013-02-01 14:55:37

narmod
Member
From: Trujillo - Perú
Registered: 2012-12-29
Posts: 5
Website

Re: No sound events

Besides enabling event sounds on the "Appearance" settings and installing canberra, you need to set the sound theme name. To do this, go to "Settings »  Settings Editor". Once there go to "xsettings" and on the right side scroll all the way down to "Net » SoundThemeName" and change it's value to freedesktop. If that doesn't work, try changing the theme, install or download and extract (in ~/.local/share/sounds/) a different theme. For me the theme called "Fresh and Clean" works well.

Also, just in case, go to "System » dconf", once there go to "org » gnome » desktop » sound" and check everything there and set the theme name as well.

Offline

Board footer

Powered by FluxBB