Xfce Forum

Sub domains
 

You are not logged in.

#1 2013-03-13 12:50:35

fdelente
Member
Registered: 2012-12-30
Posts: 7

Maximizing a window overlaps gkrellm and xfce4-panel

Hello.

I use gkrellm as a system status monitor; when I used sawfish, it was configured so that when maximizing windows gkrellm wouldn't disappear under them, by reserving a blank column on the right side of the desktop, of about 48 pixels, when windows didn't go when maximized.

However I can't replicate this behavior with xfwm4: maximized windows take up all the screen, even the space where xfce4-panel is.

I tried creating rules with devilspie2 to declare gkrellm as a dock, so that it would be avoided when maximizing, but it doesn't work.

Is there a way to get the behavior I want?

Thanks.

--
F. Delente

Offline

#2 2013-03-13 15:18:40

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,063

Re: Maximizing a window overlaps gkrellm and xfce4-panel

Try Settings Manager -> Workspaces -> Margins tab.

Offline

#3 2013-03-13 15:33:30

fdelente
Member
Registered: 2012-12-30
Posts: 7

Re: Maximizing a window overlaps gkrellm and xfce4-panel

Works, even though I find it disturbing to have to manually decide which space to leave around. Normally X roles are there for that, aren't they? Does xfwm4 respects them?

Offline

Board footer

Powered by FluxBB