Xfce Forum

Sub domains
 

You are not logged in.

#1 2013-03-15 15:31:56

xfce.trad
Member
Registered: 2013-03-07
Posts: 2

XFCE 4.10 - Multimedia keys doesn't works

XFCE 4.10
Xubuntu 12.10 x32
Acer Aspire One 722

I configured this shorcuts to multimedia keys:

amixer -D pulse sset Master playback 5%+
amixer -D pulse sset Master playback 5%-
amixer -D pulse sset Master playback toggle

When I starts the laptop, this shortcuts doesn't be used by system. If I run the amixer toggle command in Terminal, works. But, pressing Fn+F8, mutes the system but doesn't unmute. When I changes user and back to my user, the toggle shortcut works.

xubuntu@NETUBU:~$ amixer -D pulse sset Master playback toggle
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65536
  Mono:
  Front Left: Playback 22358 [34%] [off]
  Front Right: Playback 22358 [34%] [off]
xubuntu@NETUBU:~$ amixer -D pulse sset Master playback toggle
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65536
  Mono:
  Front Left: Playback 22358 [34%] [on]
  Front Right: Playback 22358 [34%] [on]

Last edited by xfce.trad (2013-03-15 19:17:50)

Offline

#2 2013-03-16 01:02:48

xfce.trad
Member
Registered: 2013-03-07
Posts: 2

Re: XFCE 4.10 - Multimedia keys doesn't works

When I run the script below in Terminal, the system sound mute and unmute. But, when I go to Settings>>Keyboard>>Shortcuts and set mute key (Fn+F8) to execute it, doesn't works.

#!/bin/bash
if amixer -c 1 get Master | grep -q off
then
    amixer -D pulse set Master playback unmute
else
    amixer -D pulse set Master playback mute
fi

Offline

#3 2013-03-17 19:33:02

paolo321
Member
Registered: 2011-06-26
Posts: 120

Re: XFCE 4.10 - Multimedia keys doesn't works

at least imho, xfce or something else inside xubuntu has some problems using multimedia keys for keyboard shortcuts... Maybe a conflict with xfce4 volumed ?
I have a similar script and similar issues: problem seems solved using xbindkeys instead of xfce keyboard shortcuts.

btw, my script uses pactl instead of amixer since, on oneiric, amixer toggle was not enough to solve the problem ...I'm not 100% sure if this is still needed.

Offline

Board footer

Powered by FluxBB