Xfce Forum

Sub domains
 

You are not logged in.

#1 2013-04-08 20:47:02

markfilipak
Member
Registered: 2013-03-11
Posts: 46

Thunar cooking file names - bogus - bad behavior - fix?

Thunar is cooking file names.
For example,
'/etc/xdg/autostart/AT-SPI D-Bus Bus'   <<--- Thunar shows
'/etc/xdg/autostart/at-spi-dbus-bus.desktop'   <<--- actually

I don't want file names cooked. What can I do?

Thanks - Mark.


VMware Player 5.0.2
Host: WinXP3, 32-bit
Guest: Linux Mint 14, 64-bit + Xfce 4.10

Offline

#2 2013-04-09 05:18:36

MountainDewManiac
Member
From: USA police-state welfare-state
Registered: 2013-03-24
Posts: 308

Re: Thunar cooking file names - bogus - bad behavior - fix?

That's odd. I just checked that file/directory, and it displays the correct name in Thunar for me. Are you using the current version of Thunar (1.6.2)?

Online

#3 2013-04-09 05:54:00

markfilipak
Member
Registered: 2013-03-11
Posts: 46

Re: Thunar cooking file names - bogus - bad behavior - fix?

Isn't it odd. I'm very new to Linux so I don't know what's normal and what's not. I have Thunar 1.4.0, but I just did an update so apparently the latest is not in the Mint distro. Even so...

It seems like it has to be a setting problem, something like "use friendly names" or some such nonsense, but I've checked what few preference settings there are.

I take it you've never seen this. What tipped me off was 2 files apparently with exactly the same 'Screensaver' name (but of course they don't actually have the same name).

'/etc/xdg/autostart/Screensaver'   <<--- Thunar shows
'/etc/xdg/autostart/gnome-screensaver.desktop'   <<--- actually

and

'/etc/xdg/autostart/Screensaver'   <<--- Thunar shows
'/etc/xdg/autostart/xscreensaver.desktop'   <<--- actually


VMware Player 5.0.2
Host: WinXP3, 32-bit
Guest: Linux Mint 14, 64-bit + Xfce 4.10

Offline

#4 2013-04-09 07:55:52

MountainDewManiac
Member
From: USA police-state welfare-state
Registered: 2013-03-24
Posts: 308

Re: Thunar cooking file names - bogus - bad behavior - fix?

markfilipak wrote:

I have Thunar 1.4.0, but I just did an update so apparently the latest is not in the Mint distro.

Sorry, about that. I forgot that I added the Xfce PPAs to my sources list. By current, I guess I meant the newest - or, alternatively, the current according to the Xfce team - as opposed to Mint's current.

There's a thread around here somewhere about adding those sources if you wish to update your Xfce desktop environment and Xfce components (Thunar, et cetara) to... the most recent versions, if you are interested. It looks like everyone (that returned to the thread to leave feedback) had success with no downside. However, the fact that these updates are not in the regular Mint channel (including backports, et cetara) indicates that the Mint team have not thoroughly tested them yet... But, as Dad used to say when I was a child, I can break an anvil with a rubber mallet, lol, and my Xfce components are still great.

But I just skimmed the release notes for Thunar versions 1.6 and 1.6.2 and, although a lot of bugs were squashed and features added, I did not see any reference to the issue you describe.

markfilipak wrote:

It seems like it has to be a setting problem, something like "use friendly names" or some such nonsense, but I've checked what few preference settings there are.

Hmm. I do not recall seeing any setting like that in any of the three versions of Thunar (1.4, 1.6, 1.6.2) that I have used with Mint 14.

The only option (that I can think of) like that in my setup is: When I right-click on the (standard) desktop Applications Menu and select Properties, there is an option to show generic application names. This doesn't seem (to me) to be related, but you might check to make sure that the option is unchecked.

screenshot-04092013-035114am.php

markfilipak wrote:

I take it you've never seen this.

No. If I didn't need to get up in 2½ hours (haven't been to bed yet), I'd try hitting a search engine to see if I could find something that might help, but I really do need to shut down and get horizontal for a bit. If I don't forget, I'll look tomorrow evening (if I do, feel free to bump this thread).

Good luck,
MDM

Online

#5 2013-04-09 16:37:30

markfilipak
Member
Registered: 2013-03-11
Posts: 46

Re: Thunar cooking file names - bogus - bad behavior - fix?

Thanks for taking the time, MDM. I hope you got some quality sleep!

I have all 4 of those check boxes cleared: No 'generic application names', no 'icons in menu', no 'tooltips', and no 'button title'. It doesn't seem logical that a setting there would affect how Thunar displays file names, but what do I know... I'm new to all this.

You know, I don't think this is worth it. The reason I write that is that I plan to eventually dump Thunar in favor of a 'Commander'-style file-system manager. I'll just accelerate my plans and install it now. I'll be right back...


VMware Player 5.0.2
Host: WinXP3, 32-bit
Guest: Linux Mint 14, 64-bit + Xfce 4.10

Offline

#6 2013-04-10 16:46:37

MountainDewManiac
Member
From: USA police-state welfare-state
Registered: 2013-03-24
Posts: 308

Re: Thunar cooking file names - bogus - bad behavior - fix?

That's one way to solve it, lol.

I would guess that a different file manager would not do this (but then, I'm surprised that Thunar does).

Best of luck,
MDM

Online

#7 2013-04-11 14:30:29

warrickguy
Member
Registered: 2013-02-08
Posts: 5

Re: Thunar cooking file names - bogus - bad behavior - fix?

debian testing/wheezy
xfce4 4.8.1
Thunar 1.2.3
I too have this or a related problem with Thunar. When using Thunar to browse the /usr/share/applications directory the .desktop files are displayed using the Name= specified from inside the file rather than the actual file name. Is there a way to turn off or toggle this behavior?  The Applications Menu properties settings mentioned in an above post didn't help me either.

Last edited by warrickguy (2013-04-11 14:31:32)

Offline

#8 2013-04-11 16:58:27

markfilipak
Member
Registered: 2013-03-11
Posts: 46

Re: Thunar cooking file names - bogus - bad behavior - fix?

Well, good luck Warrick. I'm out of here. I uninstalled Thunar and installed Krusader. Joy ensues.

I prefer a 'commander'-style interface over an 'explorer'-style interface anyway, and the Krusader Krew did an outstanding job. Joy continues.

And Thank You, MountainDewManiac, but you really aught to lay off of that stuff.

I have a Mountain Dew story for you. When I was in the U.S. Air Force (1966-1970) and stationed at Chanute AFB, Rantoul, Illinois, I entered a radio contest to win Willy the Hillbilly, a doll fashioned after the Mountain Dew man with the turned-up hat from the old Mountain Dew bottle. The contest went on all summer. It was on the radio constantly. The award ceremony was to be hosted by Miss Illinois. It seemed like a big deal.

I was notified that I'd won a week before the award ceremony. Given the obvious importance of the contest, I imagined that old Willy would be in a car and I'd have to take the car too, or something like that. On the Saturday of the award I dressed in uniform and arrived at the outdoor stage in downtown Rantoul. There were hundreds of people in chairs facing the stage. Miss Illinois invited me to the microphone. She gave me a kiss on the cheek and handed me the Willy doll. "That's it?" I asked incredulously. "Yeah," she said. "Isn't he cute!"

I thanked Miss Illinois and left the stage. I gave Willy to a kid in a front-row seat.

Last edited by markfilipak (2013-04-11 18:26:13)


VMware Player 5.0.2
Host: WinXP3, 32-bit
Guest: Linux Mint 14, 64-bit + Xfce 4.10

Offline

Board footer

Powered by FluxBB