Xfce Forum

Sub domains
 

You are not logged in.

#1 2013-02-13 22:45:44

RonJohn
Member
Registered: 2013-02-13
Posts: 4

Fonts look ragged after conversion from GNOME to Xfce

Hi,

Ubuntu 12.04
GNOME 3.4 (in Session Fallback mode)
Xfce 4.8 (upgraded to 4.10 ppa:xubuntu-dev/xfce-4.10)
Monitor DPI: 305

Hate to compare/contrast Xfce to GNOME, but...

Fonts looked great under GNOME, but now (as the Subject says) are just a bit (though disconcertingly) ragged.
Raggedness example: http://postimage.org/image/6rkljgu6v/

I think it has to do with the high DPI that my monitor reports.  GNOME automagically handled things behind the scene, but when I first logged using Xfce, the fonts were HUGE until I dropped the Settings->Appearance->Fonts->"Custom DPI setting" to 100.  Setting the custom DPI to various values from 96 thru 104 didn't fix the raggedness.

Any thoughts?

Ron

Offline

#2 2013-02-16 12:48:01

wkr
Member
Registered: 2011-01-01
Posts: 88

Re: Fonts look ragged after conversion from GNOME to Xfce

Hi Ronjogn
Have you tweaked other font settings (anti-aliasing and so on) ?

Offline

#3 2013-02-16 20:31:13

RonJohn
Member
Registered: 2013-02-13
Posts: 4

Re: Fonts look ragged after conversion from GNOME to Xfce

wkr wrote:

Hi Ronjogn
Have you tweaked other font settings (anti-aliasing and so on) ?

Yes, but with no success.  The default of Sans 10, Enabled anti-aliasing, and no hinting or sub-pixel ordering looks least bad.

Offline

#4 2013-04-11 16:14:11

herbie643
Member
Registered: 2013-04-05
Posts: 42

Re: Fonts look ragged after conversion from GNOME to Xfce

I found that if you have the following file in your home directory the fonts look fine

.fonts.conf
<?xml version='1.0'?>
<match target="font">
<edit mode="assign" name="embeddedbitmap">
  <bool>false</bool>
</edit>
<match target="font">
  <edit mode="assign" name="rgba">
   <const>rgb</const>
  </edit>
</match>
<match target="font">
  <edit mode="assign" name="hinting">
   <bool>false</bool>
  </edit>
</match>
<match target="font">
  <edit mode="assign" name="hintstyle">
   <const>hintnone</const>
  </edit>
</match>
<dir>~/.fonts</dir>
<match target="font">
  <edit mode="assign" name="antialias">
   <bool>true</bool>
  </edit>
</match>
</match>
 
and

fontfix
#!/bin/sh

WHOAMI=`whoami`
if [ x$WHOAMI != xroot ]; then
    echo Please run me as root.
    exit 1
fi

cd /etc/fonts/conf.d

ln -s ../conf.avail/10-antialias.conf 10-antialias.conf
ln -s ../conf.avail/10-hinting.conf 10-hinting.conf
ln -s ../conf.avail/10-hinting-slight.conf 10-hinting-slight.conf
ln -s ../conf.avail/11-lcdfilter-default.conf 11-lcdfilter-default.conf
ln -s ../conf.avail/53-monospace-lcd-filter.conf 53-monospace-lcd-filter.conf


Hope this works for you.

Offline

Board footer

Powered by FluxBB