Xfce Forum

Sub domains
 

You are not logged in.

#1 2013-04-20 10:15:22

king-ghidorah
Member
Registered: 2013-04-19
Posts: 16

Keyboard shortcuts in Keyboard -> Application Shortcuts do not work.

Hi,


XFCE 4.10 on my Ubuntu 12.10. I have the following shortcuts in the Keyboard -> Application Shortcuts gui tool:

gmrun <Alt>F2
xfce4-appfinder <Alt>F3
xfce4-popup-applicationsmenu <Alt>F1
...

and none of them work. But <Alt>F4 which is definded in Window Manager -> Keyboard does work and brings up the Log Out window.

Having said that they don't work is not entirely accurate. The aren't working now, after I have just logged in, nothing on the desktop. I hit the combinations right at the start, I waited a couple of minutes, I hit the combinations again, repeatedly. Nothing. But sometimes, I haven't managed to determine when yet, they will work. Sometimes I will hit <Alt>F3 and the xfce4-appfinder will pop up after something like 10 seconds.

Do you have an idea what's wrong? How to troubleshoot something like that?

Offline

#2 2013-04-20 21:14:39

king-ghidorah
Member
Registered: 2013-04-19
Posts: 16

Re: Keyboard shortcuts in Keyboard -> Application Shortcuts do not work.

When I run xfce4-appfinder from the command line it takes a while before it starts and I get the following message:

(xfce4-appfinder:2750): xfce4-appfinder-CRITICAL **: Failed to open window: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

and it turns out to be a bug. Workaround:

xfce4-appfinder --disable-server

Offline

#3 2013-04-20 21:45:36

king-ghidorah
Member
Registered: 2013-04-19
Posts: 16

Re: Keyboard shortcuts in Keyboard -> Application Shortcuts do not work.

Wow! XFCE under Ubuntu is full of surprises. I've just logged out, logged in and the screen resolution decreased. Then I logged out and logged in again and the screen resolution increased...

Back to the issue, though. After some searching I discovered that I had two files potentially used for configuring shortcuts:

~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml
/etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml

The latter didn't have my customised shortcuts so I moved it to a quarantine folder, in case it was somehow conflicting with the other one. That neither fixed nor broke things (I haven't noticed, anyway).

Then I patiently tried the shortcuts again. I kept hitting <Alt>F2 (which is bound to gmrun) every second right after having logged in and after ~20 seconds 20 windows popped up. Looks like the xfce4-keyboard-shortcuts.xml config file is read in very late during the process of loading XFCE. But 20 seconds for loading XFCE seems to me very excessive too.

Any thoughts?


Edit: Well, tried today, and my 'trick' didn't work. Looks like there is something more to it...

Last edited by king-ghidorah (2013-04-21 10:05:33)

Offline

#4 2013-04-27 01:49:17

gsenna
Member
Registered: 2013-04-27
Posts: 1

Re: Keyboard shortcuts in Keyboard -> Application Shortcuts do not work.

Same behaviour over here! I am running Ubuntu 13.04+xfce4+openbox.

Offline

#5 2013-06-01 21:53:09

king-ghidorah
Member
Registered: 2013-04-19
Posts: 16

Re: Keyboard shortcuts in Keyboard -> Application Shortcuts do not work.

Changing to Debian 7 with XFCE 4.8 fixed it ;-) Everything works and works fast.

Offline

#6 2013-06-02 02:15:45

sixsixfive
Member
From: behind you
Registered: 2012-04-08
Posts: 87
Website

Re: Keyboard shortcuts in Keyboard -> Application Shortcuts do not work.

gsenna wrote:

Same behaviour over here! I am running Ubuntu 13.04+xfce4+openbox.

openbox has it's own shortcuts ==> http://openbox.org/wiki/Help:Bindings


regards,
ssf

Offline

Board footer

Powered by FluxBB