Xfce Forum

Sub domains
 

You are not logged in.

#1 2013-01-02 20:54:00

benelux.j
Member
Registered: 2013-01-02
Posts: 2

[Solved] Disable Tooltips on XFCE desktop

Hi all,
On XFCE 4.10 is possible disabling Tooltip on xfdesktop?

Screenshot

Cheers,

Offline

#2 2013-01-03 03:01:37

ozjd
Member
From: Hawkesbury NSW Australia
Registered: 2012-02-05
Posts: 203
Website

Re: [Solved] Disable Tooltips on XFCE desktop

Add this line to ~/.gtkrc-2.0

gtk-enable-tooltips = 0

Offline

#3 2013-01-03 17:08:54

benelux.j
Member
Registered: 2013-01-02
Posts: 2

Re: [Solved] Disable Tooltips on XFCE desktop

Yesssssssss, work fine!

Thank smile

Offline

#4 2013-04-14 21:04:33

fest3er
Member
Registered: 2013-04-14
Posts: 1

Re: [Solved] Disable Tooltips on XFCE desktop

ozjd wrote:

Add this line to ~/.gtkrc-2.0

gtk-enable-tooltips = 0

This works in 4.8 (Debian Wheezy), but has weird side effects.

In phpBB and vBulletin, I can no longer drag-select text with the mouse in Chromium unless the mouse is moving quickly before I hold down the left button. Scrollbars no longer drag in Chromium. I can't drag-select desktop icons unless the mouse is moving quickly before I hold the left button down.

Oh, well. As annoying as the tool tips are, I'll have to re-enable them. These new problems affect usability.

Offline

#5 2013-04-14 22:27:00

ozjd
Member
From: Hawkesbury NSW Australia
Registered: 2012-02-05
Posts: 203
Website

Re: [Solved] Disable Tooltips on XFCE desktop

fest3er wrote:
ozjd wrote:

Add this line to ~/.gtkrc-2.0

gtk-enable-tooltips = 0

This works in 4.8 (Debian Wheezy), but has weird side effects.

In phpBB and vBulletin, I can no longer drag-select text with the mouse in Chromium unless the mouse is moving quickly before I hold down the left button. Scrollbars no longer drag in Chromium. I can't drag-select desktop icons unless the mouse is moving quickly before I hold the left button down.

Oh, well. As annoying as the tool tips are, I'll have to re-enable them. These new problems affect usability.

Sounds like a bug in Chromium, file a bug report.

Offline

#6 2013-04-17 02:42:47

Sideburns
Member
From: Camarillo, CA
Registered: 2011-03-30
Posts: 279
Website

Re: [Solved] Disable Tooltips on XFCE desktop

I'm running Xfce4.10 on Fedora 17.  there is not such directory as ~/.gtkrc-2.0.  In fact, there's no such file as ~/gt* on my machine.

OOPS!  That's a file, not a directory.  Never mind...

*************************************************************

Not only didn't it work, it messed up some of my other settings.  I've commented it out, and will log out and back in again to see if I can, at least, get back to where I started.

Last edited by Sideburns (2013-04-17 02:53:21)


Registered Linux user #470359
Permanently recovered BOFH
Any advice in this post is worth exactly what you paid for it.

Offline

#7 2013-04-20 20:09:38

Sideburns
Member
From: Camarillo, CA
Registered: 2011-03-30
Posts: 279
Website

Re: [Solved] Disable Tooltips on XFCE desktop

I just tried this on my laptop; same result.  Not only didn't it work as advertised, it changed the background on my icon labels, just as it did on my desktop.


Registered Linux user #470359
Permanently recovered BOFH
Any advice in this post is worth exactly what you paid for it.

Offline

#8 2013-04-21 01:04:54

ozjd
Member
From: Hawkesbury NSW Australia
Registered: 2012-02-05
Posts: 203
Website

Re: [Solved] Disable Tooltips on XFCE desktop

I tested again on my Fedora 17 system running Xfce 4.10 and it worked for me. I usually have the icon background set to transparent but changed it while testing.

I don't understand why it works for some people and not for others. I'm guessing there is some difference in set up that isn't obvious that causes this but don't know what it is. I'm guessing you didn't have a .gtkrc2.0 file before?

Offline

#9 2013-04-21 01:38:24

Sideburns
Member
From: Camarillo, CA
Registered: 2011-03-30
Posts: 279
Website

Re: [Solved] Disable Tooltips on XFCE desktop

As a matter of fact, I did, on both machines.  I created it to get a transparent background for icon labels.  (This goes away on either machine when I try to nuke tooltips.)  Is there a specific place in the file it belongs?  It occurs to me that I've been putting it inside the icon view section.  I'll try moving it up above that part and see what happens.


Registered Linux user #470359
Permanently recovered BOFH
Any advice in this post is worth exactly what you paid for it.

Offline

#10 2013-04-21 01:49:54

ozjd
Member
From: Hawkesbury NSW Australia
Registered: 2012-02-05
Posts: 203
Website

Re: [Solved] Disable Tooltips on XFCE desktop

Sideburns wrote:

As a matter of fact, I did, on both machines.  I created it to get a transparent background for icon labels.  (This goes away on either machine when I try to nuke tooltips.)  Is there a specific place in the file it belongs?  It occurs to me that I've been putting it inside the icon view section.  I'll try moving it up above that part and see what happens.

I've got it at the end of the file, not in any section.

Offline

#11 2013-04-21 01:53:45

Sideburns
Member
From: Camarillo, CA
Registered: 2011-03-30
Posts: 279
Website

Re: [Solved] Disable Tooltips on XFCE desktop

OK, I put it at the top, just before the icon section and it worked.


Registered Linux user #470359
Permanently recovered BOFH
Any advice in this post is worth exactly what you paid for it.

Offline

#12 2013-04-21 21:11:37

Sideburns
Member
From: Camarillo, CA
Registered: 2011-03-30
Posts: 279
Website

Re: [Solved] Disable Tooltips on XFCE desktop

I'm not sure if this is a side-effect, or what.  Now, the tooltips for the various applets on my panel (such as the weather) don't show up, and activating them via Desktop Settings doesn't help.  It's a shame that you can't get rid of the huge, annoying, redundant "tooltips" for desktop icons without getting rid of the useful ones as well.


Registered Linux user #470359
Permanently recovered BOFH
Any advice in this post is worth exactly what you paid for it.

Offline

#13 2013-04-21 22:37:34

ozjd
Member
From: Hawkesbury NSW Australia
Registered: 2012-02-05
Posts: 203
Website

Re: [Solved] Disable Tooltips on XFCE desktop

I suspect it is a single setting, all or none. That is the reason I don't disable them. I find the tooltips on external drives icons useful.

Offline

#14 2013-04-21 22:45:13

Sideburns
Member
From: Camarillo, CA
Registered: 2011-03-30
Posts: 279
Website

Re: [Solved] Disable Tooltips on XFCE desktop

The only ones I've ever found useful were the ones that let me see all of the weather data or just what my CPU usage is ATM.  The ones for the desktop icons I've always considered redundant, especially when you consider that they show the last time the launcher was modified, not the file it points to.


Registered Linux user #470359
Permanently recovered BOFH
Any advice in this post is worth exactly what you paid for it.

Offline

#15 2013-04-25 15:20:32

muellner
Member
Registered: 2013-04-25
Posts: 1
Website

Re: [Solved] Disable Tooltips on XFCE desktop

While not disabling the toooltips, the following lines in my ~/.gtkrc-2.0 brought the humongous tooltips down to a pleasant size:

style "xfdesktop-icon-view" {
    XfdesktopIconView::tooltip-size = 48
}
widget_class "*XfdesktopIconView*" style "xfdesktop-icon-view"

This doesn't seem to have the negative side effects of disabling the GTK tooltips in general.

Source: the README in the current xfdesktop source distribution (4.10.2).

Offline

#16 2013-07-30 12:44:13

Castania
Member
Registered: 2013-07-30
Posts: 6

Re: [Solved] Disable Tooltips on XFCE desktop

I have a fresh Fedora 19 Xfce spin (64bit) on a Dell laptop. 

The gtkrc-2.0 file was NOT present in the home directory.  I created it with Leafpad and put a single line:

gtk-enable-tooltips = 0

After a log-out/log-in, it seems to be working with no serious side effects (in fact, no side effects at all!).  No ridiculous popups.

On this, however . . . I can't figure out why in the world anyone would think it a good idea to have "signs" popup any time the mouse stands still.  It's like have a sign that says "Car" on your automobile.  When I hover over a pdf file, I don't need a sign telling me "this is a pdf file."  When I hover over the Chrome icon, I don't need a popup telling me that this is the Google Chrome icon and clicking it will allow me to surf the web.

If you're listening . . . and experience thus far seems to indicate you're not . . . please think before "adding" useless features that require immense amounts of time to undo/overcome.

My 2 cents . . .

Offline

#17 2013-07-30 17:56:34

MountainDewManiac
Member
From: USA police-state welfare-state
Registered: 2013-03-24
Posts: 248

Re: [Solved] Disable Tooltips on XFCE desktop

Castania wrote:

On this, however . . . I can't figure out why in the world anyone would think it a good idea to have "signs" popup any time the mouse stands still.

At a guess, it's not being done for the people who already know what everything is/does. And the behavior doesn't bother me - but since it does appear to bother you overmuch, I'll hope that future versions of Xfce allow you to disable it with less effort.

Castania wrote:

If you're listening

Try here:

https://mail.xfce.org/mailman/listinfo

Regards,
MDM

Offline

#18 2013-07-30 22:43:16

ozjd
Member
From: Hawkesbury NSW Australia
Registered: 2012-02-05
Posts: 203
Website

Re: [Solved] Disable Tooltips on XFCE desktop

Castania wrote:

On this, however . . . I can't figure out why in the world anyone would think it a good idea to have "signs" popup any time the mouse stands still. .

As I mentioned earlier in the thread I find them useful for external drives, tells if mounted and where etc. But for the rest I agree. If only you could choose where you get them it would be ideal.

Offline

#19 2013-09-28 09:09:30

puppycutletts
Member
Registered: 2013-06-24
Posts: 8

Re: [Solved] Disable Tooltips on XFCE desktop

Yeah plauges of the devil etc..

I am passably OK with tool tips... I don't really notice them much AND I do find them to be actually useful as there are so many mystical things to remember, that I like "dumb programs" working as reminders.

In effect I LIKE how it works.

Except when working on my browser (Firefox) - and HUGE - ABSOLUTELY HUGE areas of the screen appear, with BLACK RECTANGLES on them, that take up about 1/6 - 1-8 of the screen space with the normally sized white words in them.

I use the Youbumtoo OS with the XFCE interface

(It's OK I can't spell Ubuntu as I am iclexdys, and I can't I'm not fluid in Swaheli).

It was this bit that piqued my interest:

style "xfdesktop-icon-view" { XfdesktopIconView::tooltip-size = 48 } widget_class "*XfdesktopIconView*" style "xfdeskt

Now this is bad. Typical as so many non synchronous scripts, there is no connection between the text and where and how to use it.

I also hate guessing games, on account of others failing to explain their plans, to the degree that people can pick it up without having to guess their way through it.

This issue aside, I actually do like the helper tip -- just not the inflated ones that appear on the browser.

OK there is no "~/.gtkrc-2.0" in the filing system.

But in the SETTINGS EDITOR - Xsettings - XFT - Hinting init 1.

I think this "1" could be changed to "0" to get rid of hinting.

But I am still at a little bit of a loss - as to WHY the HINT screens blow up to  1/6 of the webpage.

Is it because of my using a netbook and the capacity to zoom into and out of webpages - and the zoom / hint sizing is going out of synch?

I'd rather FIX the problem, instead of patching what is essentially useful software.

AND true to form, some of my major issues about Linux developers, is the reasonabley and inexcusably frequent LACK of basic controls.

Like a function might be implemented and included, and yet - there is no "ON" or "OFF" switch included with it.

Such as this one.

And the only solution/s, or what appear to be solutions - or even best guesses etc., are scattered all over the internet like a jihad on your arse.

One other thing about the solutions issue, is that there is NO mention or direct link into the manual pages (man pag?) and the basic XFCE  help guide, is NOT actually on the system with the operating system - no it's on the internet;

To me this is as stupid as leaving the tools behind on a long trip.

It's even worse for OTHER people to assume that the people using the software actually have access to the interwebs - and or have to have and use the intergnettes to find out anything or do anything - on account of the developers being just plain lazy.

I will come back to this issue later.

I am beset by demons, and am in need of a herd of swine.

Last edited by puppycutletts (2013-09-28 09:16:47)

Offline

#20 2013-09-28 22:44:56

andrzejr
Member
Registered: 2012-04-06
Posts: 47

Re: [Solved] Disable Tooltips on XFCE desktop

I have extended the documentation of advanced Xfdesktop settings:

http://docs.xfce.org/xfce/xfdesktop/advanced

Note that these are options are for theme authors or advanced users. Non-technical users can access them via: Settings Manager->Appearange->Style.

Offline

#21 2013-10-01 22:50:26

MountainDewManiac
Member
From: USA police-state welfare-state
Registered: 2013-03-24
Posts: 248

Re: [Solved] Disable Tooltips on XFCE desktop

andrzejr wrote:

I have extended the documentation of advanced Xfdesktop settings

Thank you.

Regards,
MDM

Offline

#22 2013-10-06 03:01:00

Sideburns
Member
From: Camarillo, CA
Registered: 2011-03-30
Posts: 279
Website

Re: [Solved] Disable Tooltips on XFCE desktop

I just took a look at Settings Manager, and there's nothing I can find named Appearance.  (I presume that what you wrote was a typo, and in any event, it doesn't show either.)


Registered Linux user #470359
Permanently recovered BOFH
Any advice in this post is worth exactly what you paid for it.

Offline

#23 2013-10-06 03:16:42

ozjd
Member
From: Hawkesbury NSW Australia
Registered: 2012-02-05
Posts: 203
Website

Re: [Solved] Disable Tooltips on XFCE desktop

My Settings Manager in Fedora 19 has Appearance as the first option, strangely it doesn't have an icon but it still runs. You can also get to it from the menu under Settings - Appearance.

Offline

#24 2013-10-06 04:12:11

Sideburns
Member
From: Camarillo, CA
Registered: 2011-03-30
Posts: 279
Website

Re: [Solved] Disable Tooltips on XFCE desktop

I just took a look under Settings ->Appearance on my Fedora 19 Desktop, and there's nothing editable under Styles.


Registered Linux user #470359
Permanently recovered BOFH
Any advice in this post is worth exactly what you paid for it.

Offline

#25 2013-10-06 04:29:05

ozjd
Member
From: Hawkesbury NSW Australia
Registered: 2012-02-05
Posts: 203
Website

Re: [Solved] Disable Tooltips on XFCE desktop

Sideburns wrote:

I just took a look under Settings ->Appearance on my Fedora 19 Desktop, and there's nothing editable under Styles.

Yes you're right. I'm not sure what andrzejr means as the things in the wiki can only be done in the gtkrc file.

Offline

Board footer

Powered by FluxBB