Xfce Forum

Sub domains
 

You are not logged in.

#1 2013-04-26 20:33:09

Antis Lathoi
Member
Registered: 2013-04-26
Posts: 7

Bad interaction of xfce4 with emacs fullscreen mode

Hi,

I installed xfce (4.10) as my desktop environment on arch linux.

emacs (I'm using a fresh bzr checkout and compile myself) has a "toggle-frame-fullscreen" function built-in. When writing, I prefer emacs to be in fullscreen, with the text descending in the middle of the frame; for centering the text I use the emacs fringe feature.

I wrote two very basic functions to change to fullscreen+fringe ("focus") and to switch back to the frame size before full-screen ("relax").

(defun focus ()
  (interactive)
  (toggle-frame-fullscreen)
  (set-fringe-mode (quote (320 . 0))))

(defun relax ()
   (interactive)
   (set-fringe-mode nil)
   (toggle-frame-fullscreen))

The first function works as expected, but as soon as I call "relax" the frame returns from fullscreen to a "maximised" state (filling the whole screen, but with window decoration), -- and NOT to the frame geometry before changing to fullscreen. Whithout the fringe-related command, "relax" works well!, but as soon as I try to cancel the fringe automatically, the frame is maximized. In order to have it work correctly, I have to omit the fringe command and do a manual M-x fringe-mode RET "default".

I suspect that this is xfce4-related (the tiling feature perhaps??), as it does not occur with other desktop environments (such as lxde).

Can anyone give me a hint or try the functions and post his/her results?

Thanks

Antis

Offline

#2 2013-04-26 22:36:31

andrzejr
Member
Registered: 2012-04-06
Posts: 47

Re: Bad interaction of xfce4 with emacs fullscreen mode

Why not just map "Toggle fullscreen" to a key in settings->window manager->keyboard?

Offline

#3 2013-04-26 23:38:23

Antis Lathoi
Member
Registered: 2013-04-26
Posts: 7

Re: Bad interaction of xfce4 with emacs fullscreen mode

andrzejr wrote:

Why not just map "Toggle fullscreen" to a key in settings->window manager->keyboard?

Andrzejr: thanks for your response! actually I can't just do a toggle-frame-fullscreen because I want the fringe action (create / cancel fringe) to be hooked into its operation.

Antis.

Offline

#4 2013-04-27 00:13:33

MountainDewManiac
Member
From: USA police-state welfare-state
Registered: 2013-03-24
Posts: 300

Re: Bad interaction of xfce4 with emacs fullscreen mode

I don't have a solution and therefore was hesitant to post at all. And you might be right in your speculation that it's an issue with Xfce. However, I just checked the Wikipedia page and was surprised to learn that the application - after all, it's 36 or 37 years old, lol - is still being actively developed. (I find that to be an impressive thing.)

In fact, there was a stable release (version 24.3) just last month.

So you might be able to get help either by communicating with the current maintainer or by posting on the Emacs mailing list; perhaps you are not the first person that has experienced this behavior and someone else has found a solution, or it might be that someone has created an alternate method of doing what you wish to do that does not provoke the unintended behavior.

Here are some pages about Emacs. You might find information about its mailing list and how to access/subscribe on one of them:

The Wikipedia page:

http://en.wikipedia.org/wiki/Emacs

EmacsWiki page:

http://www.emacswiki.org/

Emacs' home page:

http://www.gnu.org/software/emacs/

I hope you find a solution to your issue. If/when you do, please return to this thread and post it for the future help of others and mark your thread as [Solved] (and thanks!).

Regards,
MDM

Offline

Board footer

Powered by FluxBB