Xfce Forum

Sub domains
 

You are not logged in.

#1 2013-02-18 22:03:19

Mumbo-Jumbo
Member
Registered: 2013-02-18
Posts: 2

Problems with wine+wc3 fullscreen.

I'm not quite sure if this is a xfce4 (what would make me right to post it here), a x-server, or a pure wine issue, however i hope somebody here might have an idea how to fix it:

Background:
i wanted to bind my additional mousekeys to work as numkeys to be able to use stuff from my wc3 inventory quicker. After trying arround a bit, i noticed that the xkeybind works when i set wc3 to run in -window mode.
Here is the thread on the winehq that i created on the topic:
http://forum.winehq.org/viewtopic.php?f=8&t=18294

Well, and here the next problem starts. When i start it in windowed mode and do ALT+SPACE->Fullscreen a small part of the screen (bottom 6 pixels) aren't covered with wc3 - setting the mainbar to autohide doesn't help. This causes the mouse to disfunction when i try to scroll down too fast.
Are there any workarrounds so i can get wc3 into a "real" fullscreen while having it minimized? Virtual Desktop isn't a real workarround since i have the very same problem with the windows-titlebar in this case wink

So - is there any way i can use my mousekeys as numpad-keys and play fullscreen?
Ways i could imagine atm:
-Start Wc3 with wine in windowed mode and make it fullscreen afterwards (thing i tried, see the problem description above). Any ideas how to fix it?
-Start Wc3 with wine without the windowed mode in a way the xbindkeys work for it - i guess atm that the problem is that Warcraft III isn't affected by my xbindkeys in this mode, any way to force it to accept my config? x)

High speculative:
-Start a new x-server, call the xbindkeys, start wc3 in the new x-server? - I have no idea how to perform this, could it work and how could i test it? (i'm still kind of a noob)

Also, i'm highly interessted in knowing why this thing happens-
as allrdy written above, i assume that wine starts wc3 somehow "outside" of the normal x-config boarders when it is not windowed (command atm is "wine "Frozen Throne.exe" -opengl (-windowed)" < last parameter only for testing atm, i can't allow to miss the scrolling when i play).

Thanks in advance
Mumbo-Jumbo

Offline

#2 2013-05-12 12:09:37

mrd
Member
Registered: 2013-05-12
Posts: 3

Re: Problems with wine+wc3 fullscreen.

Any luck getting it to work? I'm having the exactly same problems as you.

Offline

#3 2013-05-15 06:37:48

Korrode
Member
From: Melbourne, Australia
Registered: 2012-12-19
Posts: 26
Website

Re: Problems with wine+wc3 fullscreen.

Run winecfg, in the Graphics tab there is an option called "Allow the window manager to control the windows".
Does toggling that affect the situation?

Last edited by Korrode (2013-05-15 06:38:06)


Rob McCathie - Manjaro Linux Team
http://manjaro.org/get-manjaro/

Xfce is the flagship environment for Manjaro. We strive to offer the most leading edge Xfce desktop experience.

Offline

#4 2013-05-15 21:08:44

mrd
Member
Registered: 2013-05-12
Posts: 3

Re: Problems with wine+wc3 fullscreen.

Korrode:
Thank you for the tip. It sadly doesn't work. I had the option set, but unticking it didn't help. When allowing the WM control the window, the problem was with the bottom 5-6 pixels of the screen not getting covered and thus moving down in-game with the cursor was difficult. Unsetting the option caused the same problem now appear on all other sides of the window.
If it's of any use... I'm using Xfce 4.10, Wine 1.5.30 and Xorg 1.14. If any logs are needed, please ask them of me.
Thanks again!

Offline

#5 2013-05-16 08:47:42

Korrode
Member
From: Melbourne, Australia
Registered: 2012-12-19
Posts: 26
Website

Re: Problems with wine+wc3 fullscreen.

What exactly do you mean by "aren't covered"?
Nothing is rendered in the bottom 5-6 horizontal rows of pixels?

EDIT:
And clarifying: xbindkeys does work in Windowed mode but doesn't work in full screen even when "Allow the window manager to control the windows" is on?

Last edited by Korrode (2013-05-16 08:50:30)


Rob McCathie - Manjaro Linux Team
http://manjaro.org/get-manjaro/

Xfce is the flagship environment for Manjaro. We strive to offer the most leading edge Xfce desktop experience.

Offline

#6 2013-05-17 18:16:27

mrd
Member
Registered: 2013-05-12
Posts: 3

Re: Problems with wine+wc3 fullscreen.

Here's a screenshot of the bottom of the screen not getting covered http://imgur.com/ub61QWO when running in window mode, but fullscreen by the WM. About the xbindkeys, they work only when a dialog box is opened (after I press enter to write something to the other players), but not during normal play.
[EDIT] I'm actually not sure if xbindkeys isn't working. I'm using xbindkeys to call xvkbd -no-jump-pointer -keypad -text 4 when pressing the middle mouse button. Testing now to see which one isn't working.
[Edit2] Yep, xvkbd isn't working outside the dialog. xbindkeys does its job though. Also tested this without the -window parameter, and there xbindkeys doesn't work at all.

Last edited by mrd (2013-05-17 18:30:39)

Offline

Board footer

Powered by FluxBB