Xfce Forum

Sub domains
 

You are not logged in.

#1 2013-06-14 17:27:47

Reporter
Member
From: Eugene, Oregon
Registered: 2010-10-19
Posts: 5
Website

[Solved] After moving from 4.8 to 4.10 my panels remain in the foreground

Running Debian Sid (Unstable).  After upgrading from Xfce 4.8 to 4.10 my Panels now remain in the foreground when I run a program, such as the FireFox browser, for instance.  This is not desirable.

Offline

#2 2013-06-14 23:32:50

Darktux
Member
From: Portugal
Registered: 2013-01-17
Posts: 57

Re: [Solved] After moving from 4.8 to 4.10 my panels remain in the foreground

Hi Reporter,
Please check in Panel Preferences if you have the Don't Reserve Space on Borders selected ?
If yes unselect it.

Offline

#3 2013-06-15 10:15:46

Reporter
Member
From: Eugene, Oregon
Registered: 2010-10-19
Posts: 5
Website

Re: [Solved] After moving from 4.8 to 4.10 my panels remain in the foreground

I don't have that Panel Preference selected.  This Panel Preference can allow or disallow the placement of desktop icons under Panels but has no effect on allowing panels to remain visible on top of my browser and all applications, such as Open Office, terminals, Skype, etc..  Someone whom I mentioned this to says that it has to do with a change by Xfce from GTK2 to QT, if I recall correctly.  I provide a vertical market solution which makes extensive use of very large custom icons in several Panels when the desktop is showing, which is nice, but when programs are launched they use the entire HD display area and the persistence of these Panels after programs are launched is a disaster for the vertical market interface.

Offline

#4 2013-06-16 10:15:50

puw
Member
Registered: 2013-04-30
Posts: 2

Re: [Solved] After moving from 4.8 to 4.10 my panels remain in the foreground

The panels are placed above all regular windows. No idea if that was changed after 4.8 but it sounds like that is your problem. This behaviour can be changed using the wmctrl command, I use the following script on startup which works for my needs (one panel only, it won't work well with many panels unless run after all have started)

#!/bin/bash

while true; do
        ID=$(wmctrl -l | grep xfce4-panel$ | awk '{ print $1 }')
        if [ -n "$ID" ]; then
                break;
        fi
        sleep 5
done

for n in $ID; do
        wmctrl -i -r $n -b add,below
done

But you could also run this command and then click on the panel
wmctrl -r :SELECT: -b toggle,below

Panels always on top is by design as I have understood it.

Offline

#5 2013-06-16 16:30:03

MountainDewManiac
Member
From: USA police-state welfare-state
Registered: 2013-03-24
Posts: 385

Re: [Solved] After moving from 4.8 to 4.10 my panels remain in the foreground

Reporter wrote:

Someone whom I mentioned this to says that it has to do with a change by Xfce from GTK2 to QT, if I recall correctly.

Xfce still uses GTK+ version 2 (not Qt).

I wonder if your issue is related to the (fixed) auto-hide panel bug? If so, I fixed it by adding ppa:xubuntu-dev/xfce-4.10 and ppa:xubuntu-dev/xfce-4.12 to my sources list and doing an update. The description on the Xfce 4.12 PPA web page specifies that we MUST add the Xfce 4.10 PPA to our sources first, BtW. And it also states that the versions (in the 4.12 PPA) are pre-release versions, not "stable" ones; however, they have been solid as granite for me.

Regards,
MDM


Mountain Dew Maniac

How to Ask for Help <=== Click on this link

Offline

#6 2013-06-16 18:40:01

Reporter
Member
From: Eugene, Oregon
Registered: 2010-10-19
Posts: 5
Website

Re: [Solved] After moving from 4.8 to 4.10 my panels remain in the foreground

Using FireFox or LibreOffice in full screen mode places the browser on top of all five of my panels but when not in full screen mode the browser window slides under them.

Offline

#7 2013-06-16 18:48:11

Korrode
Member
From: Melbourne, Australia
Registered: 2012-12-19
Posts: 26
Website

Re: [Solved] After moving from 4.8 to 4.10 my panels remain in the foreground

Probably related to this:
https://bugzilla.xfce.org/show_bug.cgi?id=8563

I know my problem will be.


Rob McCathie - Manjaro Linux Team
http://manjaro.org/get-manjaro/

Xfce is the flagship environment for Manjaro. We strive to offer the most leading edge Xfce desktop experience.

Offline

#8 2013-06-27 11:27:00

Reporter
Member
From: Eugene, Oregon
Registered: 2010-10-19
Posts: 5
Website

Re: [Solved] After moving from 4.8 to 4.10 my panels remain in the foreground

I found information about this here >> https://fedoraproject.org/wiki/Xfce  under Tips and Tricks and it enabled me to solve this 'problem'.

Last edited by Reporter (2013-06-27 11:55:05)

Offline

Board footer

Powered by FluxBB