Xfce Forum

Sub domains
 

You are not logged in.

#1 2011-08-16 20:39:43

forest
Member
Registered: 2009-05-16
Posts: 3

dragging firefox url icon fails to create desktop/shortcut file

As described here, I'm trying to create a web shortcut (desktop file) by dragging the icon from the Firefox address bar to a Thunar folder or desktop.  This worked with older versions of Thunar and Firefox, but now that I'm running Xubuntu Natty (Firefox 5 and Thunar 1.2.1) it fails.  Depending on the web site I try, it either creates a file containing the page's html instead of a .desktop shortcut file, or fails to create any file at all.  Can anyone explain this and/or help me fix it?

Offline

#2 2011-11-05 14:27:20

Kernelpanic
Member
Registered: 2011-11-05
Posts: 1

Re: dragging firefox url icon fails to create desktop/shortcut file

Did you ever find a solution? I am having the same problem.

Offline

#3 2011-11-05 15:52:36

forest
Member
Registered: 2009-05-16
Posts: 3

Re: dragging firefox url icon fails to create desktop/shortcut file

I did not.  Here's a bug report:

https://bugzilla.mozilla.org/show_bug.cgi?id=568960

There are browser extensions that allow a .desktop file to be created through a series of menus, but that's just an awkward workaround.  Everything I've read on Firefox confirms that we're supposed to be able to drag the favicon to a folder to create a .desktop file.  It seems to have broken on xfce (and maybe on other free desktops as well) some time ago.

Offline

#4 2013-07-04 16:52:26

ThePowerTool
Member
Registered: 2013-07-04
Posts: 1

Re: dragging firefox url icon fails to create desktop/shortcut file

I just installed Fedora 18 w Gnome.  Under Gnome I didn't see this problem.

I then switched from Gnome to XFCE.  Dragging the site icon from Firefox to files creates the .html rather than the .desktop.

Switching back to Gnome the problem goes away.

I updated the bug referenced in the previous post.

If anyone else knows anything about this your assistance would be appreciated.

If anyone else is experiencing this please update the bug so it gets attention.

If you are using a work-around, great.  I've seen one or two work-arounds that appear complex.  I'd prefer the site icon work as designed and create a link in a .desktop file.

Offline

Board footer

Powered by FluxBB