Xfce Forum

Sub domains
 

You are not logged in.

#1 2013-07-07 12:18:33

sguazt
Member
Registered: 2013-07-07
Posts: 4

How to make the XF86AudioPlay button an omni-play button?

Hello,

I'm using XFCE 4.10.1 on Fedora 19 x86_64.
I'd like to create a keyboard shortcut so that when I press the XF86AudioPlay button the audio player that is currently running starts (or stops) to play.

This is the default behavior I can find in GNOME, without the need to create any specific keyboard shortcut.
Under GNOME, I tried with different players, for instance:
- radiotray
- audacious
- rhythmbox
and in all cases it works like a charm.

In XFCE, the XF86AudioPlay is mapped by default to the "pragha" application (which is not installed on my system).

I know I can map this button to a specific player, but is it possible to mimic the GNOME's behavior?


Thank you for your help,

-- Marco

Offline

#2 2013-07-09 16:57:23

stqn
Member
Registered: 2010-10-11
Posts: 168

Re: How to make the XF86AudioPlay button an omni-play button?

Are you saying that when you run radiotray, audacious or rhythmbox under Xfce instead of Gnome (same computer, same distribution, same user), the play/pause key doesn’t work?

AFAIK it’s up to each audio application to react (or not) to the press of this key, so it should work the same under Xfce and Gnome.

Offline

#3 2013-07-09 20:10:46

sguazt
Member
Registered: 2013-07-07
Posts: 4

Re: How to make the XF86AudioPlay button an omni-play button?

No, I'm just saying that currently in XFCE (at least the one shipped with Fedora 19) the XF86AudioPlay is bound to the pragha player
Command: pragha --pause
Shortcut: XF86AudioPlay

I can rebind it to one of my favourite players (one among radiotray, audacious and rhythmbox), but to all of them.

Instead, in GNOME, without making and keyboard binding, I am able to start any of the above players and to have the XF86AudioPlay automa(t|g)ically working.

I admit I don't know how can be obtained, but it's very cool! wink

-- Marco

Offline

#4 2013-07-09 22:12:15

stqn
Member
Registered: 2010-10-11
Posts: 168

Re: How to make the XF86AudioPlay button an omni-play button?

Just delete the annoying shortcut then. (And no this is not caused by Xfce itself; this is the first time I hear about this pragha thing.)

Offline

#5 2013-07-10 07:15:22

sguazt
Member
Registered: 2013-07-07
Posts: 4

Re: How to make the XF86AudioPlay button an omni-play button?

Hi

I've just removed the binding, then I rebooted my system.
Now, if I start either radiotray or audacious and I press XF86AudioPlay the player does not start to play.
Instead, with rhythmbox it seems to work

What is your experience?

Thanks!

-- Marco

Offline

#6 2013-07-10 13:53:18

stqn
Member
Registered: 2010-10-11
Posts: 168

Re: How to make the XF86AudioPlay button an omni-play button?

I don’t use radiotray, audacious or rhythmbox, but Clementine reacts to XF86AudioPlay out of the box, and deadbeef can be configured to do so (I just tried it.)

Offline

#7 2013-07-10 14:04:00

sguazt
Member
Registered: 2013-07-07
Posts: 4

Re: How to make the XF86AudioPlay button an omni-play button?

Indeed, audacious can be configured as well by enabling the Global Hotkey plugin. I didn't know about that, just found now.

For what concerns radiotray, I have enabled two plugins "Mate Media Keys" and "GNOME Media Keys" but does not work.
I'll investigate about it...

Thank you for the hint.

-- Marco

Offline

Board footer

Powered by FluxBB