Xfce Forum

Sub domains
 

You are not logged in.

#26 2013-09-13 00:42:57

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,271

Re: Serious bug in xfdesktop-settings module

Looks like you now have another window manager running. If its nautilus, try killing the process then runing xfdesktop.

Online

#27 2013-09-13 00:44:56

shakebake
Member
Registered: 2012-05-14
Posts: 51

Re: Serious bug in xfdesktop-settings module

ps -ef | grep nautilus

shows I have 2 (3?) processes of nautilus

cody     2016     1  0 19:25 ?        00:00:02 nautilus
cody     2468  2412  0 19:43 pts/0    00:00:00 grep --color=auto nautilus


strange, nautilus is not running right now

Offline

#28 2013-09-13 00:48:31

shakebake
Member
Registered: 2012-05-14
Posts: 51

Re: Serious bug in xfdesktop-settings module

Klling the nautilus process and then typing xfdesktop in the terminal did it!
At least I got my desktop back now.
Mayby nautilus was somehow taking over from the xfdesktop?

Offline

#29 2013-09-13 00:54:01

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,271

Re: Serious bug in xfdesktop-settings module

shakebake wrote:

Mayby nautilus was somehow taking over from the xfdesktop?

Yes. You need to run nautilus with the --no-desktop parameter so it doesn't take over. As you can see, it causes a bit of a mess. I also think you're going to find that when you log out and in again, nautilus will be running again. Might be a good time to clear out your sessions cache. Here's how:

1. Log out
2. Go to the first tty (Ctrl+Alt+F1)
3. Log in to the text console
4. Run the following commands:

cd .cache
rm -rf sessions

5. Go back to the gui tty (Ctrl+Alt+F7)
6. Log in again and check to see that xfdesktop is running.

Back to your original problem: I think one or more of the images in your group of 80+ is somehow corrupt. I would suggest adding the images one at a time to the list to see which one(s) hang the system. You'll need to remove those. When it does hang, you're going to run into the same problem as earlier. To get around it, delete (or move the image file in question from the directory), delete the backdrop.list file, restart xfdesktop and try again.

Online

#30 2013-09-13 00:59:46

shakebake
Member
Registered: 2012-05-14
Posts: 51

Re: Serious bug in xfdesktop-settings module

I had just added about 5 or 6 more images to that list and I think that could have been the problem, maybe one of them
was corrupt ( I am assuming that when the image-list manager loads the image-list that one selects, then the images themselves
are loaded also, so a corrupted one would foul things up? )
I will now clear the sessons cache and will try to see how to set nautilus with --no-desktop option, I will
restart and see what happens.

Offline

#31 2013-09-14 02:36:46

shakebake
Member
Registered: 2012-05-14
Posts: 51

Re: Serious bug in xfdesktop-settings module

Thank you Toz for your help.

I know now I can reload the .xml file, log out and clear the .cache/sessions
to get my desktop back.

I think the problem may have been the image file with the 80+ files
listed in it. I had previously added to this list using gedit instead of
using the desktop-settings utility to add and also I think I may have
changed the timestamp date on some of the images, so that might
have been the problem. ...will see

Offline

Board footer

Powered by FluxBB