Xfce Forum

Sub domains
 

You are not logged in.

#1 2013-09-13 09:53:49

dooffas
Member
Registered: 2013-09-02
Posts: 7

Disable Screensaver / Screen Blank / Screen Lock

I am attempting to disable screensaver, screen blank and screen lock via the command line. This is because the settings will be applied in an unattended install.

From my own research this appears to be possible through xorg.conf.

I have tried setting:

Section "ServerFlags"
    Option          "BlankTime" "0"
    Option          "StandbyTime" "0"
    Option          "OffTime" "0"
    Option          "SuspendTime" "0"
EndSection

Also:
        Option "DPMS" "false"
in the Monitor section.

But even with these settings, when the machine is inactive for a period of time, the screen blanks and shortly after locks (password is required to disable screen blank).

Can someone please point me in the right direction?

Thanks

----------EDIT----------
Running XFCE 4.1 under Fedora 19

Last edited by dooffas (2013-09-13 09:54:43)

Offline

#2 2013-09-13 20:57:39

azim
Member
Registered: 2013-06-16
Posts: 15

Re: Disable Screensaver / Screen Blank / Screen Lock

maybe take a look into .xscreensaver for possible settings, also new config for screesaver is in /etc/skel that should be empty with blank only afaik ...

Offline

#3 2013-09-13 21:05:46

dooffas
Member
Registered: 2013-09-02
Posts: 7

Re: Disable Screensaver / Screen Blank / Screen Lock

In a last ditch effort to get this sorted, I removed the xscreensaver package. Alas, this did not solve the issue. The screen still blanks after a length of time. I have however managed to disable the 'screenblanking' with the xset utility. However cannot get it to persist after reboot.

Offline

#4 2013-09-13 22:00:32

daggoth
Member
From: New Zealand
Registered: 2009-03-05
Posts: 42

Re: Disable Screensaver / Screen Blank / Screen Lock

dooffas wrote:

I have however managed to disable the 'screenblanking' with the xset utility. However cannot get it to persist after reboot.

Add your xset commands to a startup script - a script can be scheduled to run during startup from Session_and_Startup-->Application_Autostart. But beyond that, check and disable the monitor settings in the preferences for xfce4-power-manager too.

Offline

#5 2015-04-19 01:32:30

georgeeipi
Member
Registered: 2015-04-19
Posts: 4

Re: Disable Screensaver / Screen Blank / Screen Lock

Has this problem been resolved? I did all of what daggoth suggested above, but still no joy, the Screen Saver options are not being changed after restarting Xfce4.

I have created an Autostart script with xset commands for disabling screen blanking and gone into the Settings-->Session_Startup-->Application_Autostart  menu and added an option to execute my Autostart script. On exiting and restarting Xfce4 and running xset -q I see the Screen Saver prefer blanking is back at 'yes'. If I go into the terminal emulator and type in 'xset s noblank' (or execute my Autostart script) and check the settings with xset -q again the prefer blanking is 'no'. So my commands are correct, but either my Autostart script is not being executed, or the order of scripts is such that there is some other script overriding my Autostart.

Can anyone give me a pointer as to how to make sure my script is the last one being executed? Or some other tip so as to stop the screen from blanking??

Offline

#6 2015-04-20 03:08:57

georgeeipi
Member
Registered: 2015-04-19
Posts: 4

Re: Disable Screensaver / Screen Blank / Screen Lock

Ok, solved it. Create a shell in a folder of your choosing, say /home/Desktop/Autostart.sh.  The file has something like:

#!/bin/bash
sleep 1; xset s off
sleep 1; xset s noblank

In Settings-->Session-->Startup--Application_Autostart  create a new application (click on the + and the system generates a new line). Fill in the fields, but the important bit is in the 'Command' field, enter

zsh /home/Desktop/Autostart 

Make sure you include the zsh (or sh depending on which version of Linux you are using).  The other critical bit is to go to the Power Manager and enable it (not disable). Set the option for Timeout and Screen blank to 'never'. And that should do it.

I was led down the wrong path in my journey to finding the solution by reports on the internet that there was some sort of bug in Debian, Raspbian. In fact the actual problem is the apparent dearth of documentation that makes it clear just how Debain (Bananian) and Xfce work together. I hope this is of some use to others that have the same problem.

Last edited by georgeeipi (2015-04-20 03:09:28)

Offline

Board footer

Powered by FluxBB