Xfce Forum

Sub domains
 

You are not logged in.

#1 2013-10-19 16:36:41

jejuba
Member
Registered: 2013-10-07
Posts: 10

[Solved] QGtkStyle was unable to detect the current GTK+ theme

Dear all,

i was just about to finish instaling Debian Whezzy on my new laptop and I just had migrated my home from the old computer to that new one when things started to fall apart. or sort of.

The last thing I did was to set the wifi. And then various programs stopped working: okular, kyle, kate.
mousepad and iceweasel work fine.

When I start one of the non working prgs this is what I get (for okular for instance):

QGtkStyle was unable to detect the current GTK+ theme.
okular(3816)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:

The last significant thing I did to set up the wifi connection was:

# adduser nom_utilisateur netdev
# /etc/init.d/dbus reload

I mention this because I feel there is a connection betwenn dbus and QGtk.

Any idea what, why, and how to solve that? Could this be associated with xfce4?

Thanks,

Offline

#2 2013-10-20 00:02:00

ozjd
Member
From: Hawkesbury NSW Australia
Registered: 2012-02-05
Posts: 221
Website

Re: [Solved] QGtkStyle was unable to detect the current GTK+ theme

The fact you migrated the home raises a red flag. Try it with a new user, if it works there is something in your setup that causes the issue.

Offline

#3 2013-10-20 09:53:42

jejuba
Member
Registered: 2013-10-07
Posts: 10

Re: [Solved] QGtkStyle was unable to detect the current GTK+ theme

Dear ozjd,

thank you for your answer. I actually only moved 2 directories from my old computer to this new one. These directories have no configuration files. I created another user but I get the same problem.

Now I deleted the .kde file, restarted the computer, and managed to get the application working (only i lost all my settings)... but only for once; then the I get the same error message and the applications stop working!

Any idea? I don't know how to wipe clean all .kde config and make sure nothing comes back. Or maybe something else.

Best,

Offline

#4 2013-10-21 00:41:55

ozjd
Member
From: Hawkesbury NSW Australia
Registered: 2012-02-05
Posts: 221
Website

Re: [Solved] QGtkStyle was unable to detect the current GTK+ theme

If you have kde installed you could try setting the gtk theme, it is somewhere in the settings with colours and similar settings.
BTW deleting the .kde directory will delete settings but also may delete data. You only need to delete .kde/share/config, seems a bit weird giving kde advice in Xfce forum smile.

As this isn't really an Xfce issue you may find you get better answers from the Debian forum. I'm not familiar with Debian, not sure if the set up is like Fedora or not.

Offline

#5 2013-10-21 18:51:06

jejuba
Member
Registered: 2013-10-07
Posts: 10

Re: [Solved] QGtkStyle was unable to detect the current GTK+ theme

OK thanks,

i've looking around and did not find any post useful or applicable enough for me. I think I am going to reinstall and see what happens. Weak way to go forward but sometimes...

cheers,

Offline

#6 2013-11-03 08:41:31

jejuba
Member
Registered: 2013-10-07
Posts: 10

Re: [Solved] QGtkStyle was unable to detect the current GTK+ theme

Dear all,

i eventually re-installed the whole system, set the wifi first and then installed KDE apps. I haven't had any issues since then. Not a good way to solve a problem for sure but it is all I could find.

Best,

Offline

Board footer

Powered by FluxBB