Xfce Forum

Sub domains
 

You are not logged in.

#1 2013-11-21 01:54:41

robert3242
Member
Registered: 2013-11-21
Posts: 9

Minor problem with xscreensaver on 64-bit Debian 7.2 with Xfce 4.8

This is my first real experience with using Xfce as my Linux desktop, and I'm extremely impressed with it; but I am having one minor issue. I use xscreensaver, which Debian includes via dependencies with their default Xfce DE, which is mostly fine. That would be my first choice anyway, and for the most part it does exactly what it's supposed to do. Until, that is, I run some videos in the VLC media player. I always disable the player's ability to turn off any screensaver or blank the screen while showing videos, since I've never found that built-in ability terribly reliable. So, when I'm going to run videos, I run the xscreensaver-demo program and simply disable it from there. That works too. But when I'm done with videos and re-run xscreensaver-demo to turn the screensaver back on, the drop-down "Mode" box just doesn't work--not for several minutes, anyway. I've never run into that phenomenon with Gnome or KDE, both of which I've run prior to now. And if I wait a few minutes, it works fine again in Xfce too, so I'm thinking maybe there's something about the Xfce window manager that it doesn't like. For what it's worth, I do use the Nvidia proprietary video driver, and I do have compositing turned on in the window manager.

I've searched these forums for something similar, also been all through the Xscreensaver and Debian sites including their forums, but I haven't found anything like this anywhere else. Googling hasn't provided an answer either.

As I said at first, to me this is a minor issue. If there is no answer, I'll live with it. After all, having to wait a few minutes before I can do what I need to do isn't a big deal to me. But if there is a simple fix or workaround, I'd love to hear about it.

Thanks in advance.


Debian 7.5 i386/Xfce 4.8

Offline

#2 2013-11-21 02:37:46

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,171

Re: Minor problem with xscreensaver on 64-bit Debian 7.2 with Xfce 4.8

If you run "xscreensaver-demo" in a terminal window after viewing the videos, when you want to re-enable a screensaver, do any error messages appear in the terminal window? Sounds like something is timing out before returning control to the program.

Offline

#3 2013-11-21 03:22:06

robert3242
Member
Registered: 2013-11-21
Posts: 9

Re: Minor problem with xscreensaver on 64-bit Debian 7.2 with Xfce 4.8

ToZ wrote:

If you run "xscreensaver-demo" in a terminal window after viewing the videos, when you want to re-enable a screensaver, do any error messages appear in the terminal window? Sounds like something is timing out before returning control to the program.

I haven't tried that but it's a very good idea and it should've occurred to me. I'll give it a try, and if I see any error messages I'll post back here.


Debian 7.5 i386/Xfce 4.8

Offline

#4 2013-11-22 02:57:20

MountainDewManiac
Member
From: USA police-state welfare-state
Registered: 2013-03-24
Posts: 284

Re: Minor problem with xscreensaver on 64-bit Debian 7.2 with Xfce 4.8

Just wanted to mention that, IIRC, the current version of VLC seems to deal with xscreensaver fine. That's with the current version of XFCE (et al), though; I don't know if the same holds true for old versions, such as 4.8 - if you're experiencing issues, you may wish to consider updating things.

Regards,
MDM

EDIT: Here are the versions that I have installed (and working). IDK if comparable versions are available to you (in your distro) or not; I have included changelog text if I have it in case that it makes it easier to check:

xscreensaver 5.15-2ubuntu1 precise; urgency=low
  * Merge with Debian testing, remaining Ubuntu changes:
    - debian/control:
      + Add Vcs-Bzr link
      + Add/Update replaces with Ubuntu versions
      + Update package descriptions to list Ubuntu screensavers
    - debian/rules:
      + Use /usr/share/backgrounds as image directory
      + Add translation domain to .desktop files
    - debian/source_xscreensaver.py:
      + Add apport hook
    - debian/split-hacks.config:
      + Use different set of default hacks than Debian
    - debian/xscreensaver.dirs
      + Install /usr/share/backgrounds. By default, settings search in
        /usr/share/backgrounds and without it, it displays an error
    - debian/patches/53_XScreenSaver.ad.in.patch:
      + Use Ubuntu branding
    - debian/patches/60_sequential_glslideshow.patch:
      + Allow going through images sequentially rather than just at random in
        the GLSlideshow hack.
  * debian/changelog: really clean up changelog, some entries were still out of
    place.
-- Mathieu Trudel-Lapierre <mathieu-tl@ubuntu.com>  Wed, 21 Dec 2011 11:27:37 -0500

xfwm4_4.11.0-0ubuntu1~ppa0.12.10.2

xfdesktop4_4.11.0-0ubuntu1~ppa0.12.10.1

vlc 2.0.8-0ubuntu0.12.10.1 quantal-security; urgency=low
  * New bug-fixing upstream release (LP: #1186780).
  * SECURITY UPDATE: Denial of service (crash) and possibly execute arbitrary
    code via a crafted MKV file (disputed).
    - Improve resistance and checking against malformed MKV files.
    - CVE-2013-3245
  * SECURITY UPDATE: Two xss vulnerabilities.
    - CVE-2013-3565
  * SECURITY UPDATE: Buffer Overflow in ASF Demuxer.
    - CVE-2013-1954
    - VideoLAN-SA-1302
-- Benjamin Drung <bdrung@ubuntu.com>  Thu, 01 Aug 2013 14:41:36 +0200

(These might not actually be the newest versions (IDK) but I have no issues with xscreensaver activating whilst VLC is playing a video with the above files installed.)

Last edited by MountainDewManiac (2013-11-22 03:31:07)

Offline

#5 2013-11-22 14:29:00

robert3242
Member
Registered: 2013-11-21
Posts: 9

Re: Minor problem with xscreensaver on 64-bit Debian 7.2 with Xfce 4.8

MountainDewManiac wrote:

Just wanted to mention that, IIRC, the current version of VLC seems to deal with xscreensaver fine. That's with the current version of XFCE (et al), though; I don't know if the same holds true for old versions, such as 4.8 - if you're experiencing issues, you may wish to consider updating things.

Regards,
MDM

Debian's stable branch, which I run, does use xscreensaver 5.15, but it uses Xfce 4.8 and the VLC version I'm using, which came through Debian's Backports is at version 2.06. The only way to obtain newer packages would be to switch to their Testing or Unstable branches, which I don't care to do since I'd rather not deal with the inevitable if unexpected breakages which would occur. That's why I cling, somewhat like a barnacle, to Debian and to their Stable branch in particular.

As I pointed out in my original post, while this is an issue for me, it's a minor one, really no more than an inconvenience. But I do appreciate the info which you took the time to provide. Cheers.


Debian 7.5 i386/Xfce 4.8

Offline

#6 2013-11-22 20:11:22

robert3242
Member
Registered: 2013-11-21
Posts: 9

Re: Minor problem with xscreensaver on 64-bit Debian 7.2 with Xfce 4.8

ToZ wrote:

If you run "xscreensaver-demo" in a terminal window after viewing the videos, when you want to re-enable a screensaver, do any error messages appear in the terminal window? Sounds like something is timing out before returning control to the program.

Okay, it's happened again and I tried the above suggestion. After viewing videos full-screen using VLC, clicking on the xscreensaver menu shortcut brings up xscreensaver-demo, but the mode selection box didn't work, as I posted earlier. That selection box could be highlighted by clicking my mouse, but I couldn't actually change the mode from disabled to anything else. Weirdly, however, when I ran the program from a terminal immediately thereafter using the xscreensaver-demo command, the same interface came up, and the mode selection box worked just fine. Also, I saw no error messages.

Thinking therefore that something might be wrong with the .desktop file (which, in Debian at least, Xfce and other DEs use to create their menu shortcuts, I thought that something might be wrong there. In Debian, such .desktop files are found at /usr/share/applications. Pulling up (in Nano) that particular .desktop file, I got the following:

  GNU nano 2.2.6       File: xscreensaver-properties.desktop                   

[Desktop Entry]
Exec=xscreensaver-demo
Icon=xscreensaver
Terminal=false
Name=Screensaver
Name[da]=Pauseskærm
Name[de]=Bildschirmschoner
Name[es]=Salvapantallas
Name[et]=Ekraanisäästja
Name[fi]=Näytönsäästäjä
Name[fr]=Économiseur d'écran
Name[hu]=Képernyővédő
Name[ja]=スクリーンセーバー
Name[ko]=화면 보호기
Name[nb]=Skjermsparer
Name[nl]=Schermbeveiliging
Name[pl]=Wygaszacz ekranu
Name[pt]=Protecção Ecrã
Name[pt_BR]=Protetor de tela
Name[ru]=Хранитель экрана
Name[sk]=Šetrič obrazovky
Name[sv]=Skärmsläckare
Name[vi]=Trình bảo vệ màn hình
Name[wa]=Spårgneu di waitroûle
Name[zh_CN]=屏幕保护程序
Name[zh_TW]=螢幕保護程式
Comment=Change screensaver properties
Comment[da]=Ændr egenskaber for pauseskærm
Comment[de]=Einstellungen des Bildschirmschoners ändern
Comment[fi]=Muuta näytönsäästäjän ominaisuuksia
Comment[fr]=Modifier les propriétés de l'économiseur d'écran
Comment[hu]=Képernyővédő tulajdonságainak megváltoztatása
Comment[ja]=スクリーンセーバーの設定を変更する
Comment[nl]=Eigenschappen van schermbeveiliging aanpassen
Comment[pt_BR]=Modificar as propriedades do protetor de tela
Type=Application
Categories=Settings;DesktopSettings;Security;X-XFCE;

I see nothing wrong or even suspicious-looking with any of the above. I can add that after I ran the program via a terminal command and it had worked fine, running it via the menu shortcut also revealed that it was working fine when run in that way as well.


Debian 7.5 i386/Xfce 4.8

Offline

#7 2013-11-22 20:53:06

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,171

Re: Minor problem with xscreensaver on 64-bit Debian 7.2 with Xfce 4.8

robert3242 wrote:

Okay, it's happened again and I tried the above suggestion. After viewing videos full-screen using VLC, clicking on the xscreensaver menu shortcut brings up xscreensaver-demo, but the mode selection box didn't work, as I posted earlier. That selection box could be highlighted by clicking my mouse, but I couldn't actually change the mode from disabled to anything else. Weirdly, however, when I ran the program from a terminal immediately thereafter using the xscreensaver-demo command, the same interface came up, and the mode selection box worked just fine. Also, I saw no error messages.

Next time, run it first from the terminal to see if there are any error messages.

Offline

#8 2013-11-24 21:25:15

robert3242
Member
Registered: 2013-11-21
Posts: 9

Re: Minor problem with xscreensaver on 64-bit Debian 7.2 with Xfce 4.8

ToZ wrote:
robert3242 wrote:

Okay, it's happened again and I tried the above suggestion. After viewing videos full-screen using VLC, clicking on the xscreensaver menu shortcut brings up xscreensaver-demo, but the mode selection box didn't work, as I posted earlier. That selection box could be highlighted by clicking my mouse, but I couldn't actually change the mode from disabled to anything else. Weirdly, however, when I ran the program from a terminal immediately thereafter using the xscreensaver-demo command, the same interface came up, and the mode selection box worked just fine. Also, I saw no error messages.

Next time, run it first from the terminal to see if there are any error messages.

No errors, and it works the way it's supposed to on first run, too.


Debian 7.5 i386/Xfce 4.8

Offline

Board footer

Powered by FluxBB