Xfce Forum

Sub domains
 

You are not logged in.

#1 2013-04-12 16:44:48

reset042
Member
Registered: 2012-04-26
Posts: 23

How to stop window buttons blinking?

When I'm trying to work and concentrate (which is hard for me at the best of times!) it's very distracting when one or two window buttons in the panel (I hope I have the terminology correct there) are blinking continuously. Often I do not have time to respond immediately to their constant nagging, as I'm on the phone with someone and trying to sort something else out. This is really spoiling my XFCE experience.

I've searched Google and this forum but I can't find the answer. I've thought about removing the panel completely but that's far from ideal. Please could anyone tell me how to stop window buttons flashing in the panel? Or maybe even make it so they flash only twice and then politely wait?

Offline

#2 2013-04-13 01:51:07

ozjd
Member
From: Hawkesbury NSW Australia
Registered: 2012-02-05
Posts: 219
Website

Re: How to stop window buttons blinking?

There is an option in Window Manager Tweaks - Accessibility to "Notify urgency by making window's decoration blink". Is that the issue?

I'm on Fedora 17 Xfce 4.10 but you don't say which distro you are using so what you see may be different.

Offline

#3 2013-04-15 05:47:46

reset042
Member
Registered: 2012-04-26
Posts: 23

Re: How to stop window buttons blinking?

Thanks but I had looked at that. That option is already unchecked, so I assume it must be the default. Also, when I read that option I assumed it applied to the window's decoration itself, and not the problem area: the rectangular buttons in the panel that one clicks on to raise and lower windows.

Sorry, I forgot post the distro I'm using: Debian. And in case it has any bearing, I'm using Compiz as my window manager.

Offline

#4 2013-04-15 06:00:15

ozjd
Member
From: Hawkesbury NSW Australia
Registered: 2012-02-05
Posts: 219
Website

Re: How to stop window buttons blinking?

I thought it was the decoration too but wondered if it also affected the panel buttons. Don't know any other option in Xfce. Not familiar with Compiz so can't help there but maybe it is a Compiz option.

BTW you don't need to remove the whole panel as the Windows buttons is an item on the panel and can be removed separately.

Offline

#5 2013-04-15 06:44:17

reset042
Member
Registered: 2012-04-26
Posts: 23

Re: How to stop window buttons blinking?

ozjd wrote:

BTW you don't need to remove the whole panel as the Windows buttons is an item on the panel and can be removed separately.

Thanks for the tip! I hadn't thought of that.

If it's a Compiz option I haven't been able to find it. Can anyone confirm that this is XFCE's default behaviour? That is: Window Buttons flash repeatedly and incessantly when a window such as a 'Downloads complete' alert in Iceweasel has been spawned.

Last edited by reset042 (2013-04-15 06:47:38)

Offline

#6 2013-04-19 20:03:29

raztus
Member
Registered: 2013-04-19
Posts: 1

Re: How to stop window buttons blinking?

I can confirm that it's driving me nuts!  I've tried toggling various options [Window Manager > Focus > New window focus / Raise on focus], [Window Manager Tweaks > Focus > Honor standard ICCCM focus hint], [Accessibility > Notify of urgency by making window's decoration blink], and none seem to change this.  Google Chrome has started blinking repeatedly when I leave it to go to my terminal emulator (Guake).  I wouldn't mind the blinking so much if it would stop after a few seconds...

Also, just for clarification, I do not have compiz installed.

Last edited by raztus (2013-04-19 20:11:13)

Offline

#7 2013-04-19 22:44:48

ozjd
Member
From: Hawkesbury NSW Australia
Registered: 2012-02-05
Posts: 219
Website

Re: How to stop window buttons blinking?

What version of Xfce are you using?
I believe it was (partially?) removed for 4.10.
If you are on 4.10 try disabling the 'Show windows from all workspaces or viewports' in panel - Items - WIndows buttons.

Offline

#8 2013-04-22 05:09:55

reset042
Member
Registered: 2012-04-26
Posts: 23

Re: How to stop window buttons blinking?

I'm using XFCE 4.8 (BTW, it's just taken me ages to realize that you're referring to a newer version of XFCE. I read it as version four-point-one and I assumed that my version four-point-eight was newer! Is it just me?)

Last edited by reset042 (2013-04-22 06:09:26)

Offline

#9 2013-04-24 09:31:27

reset042
Member
Registered: 2012-04-26
Posts: 23

Re: How to stop window buttons blinking?

4:10 is not in my Debian repos. Is there another workaround? Or should I just wait until it's packaged for Debian?

Offline

#10 2013-04-24 22:22:01

ozjd
Member
From: Hawkesbury NSW Australia
Registered: 2012-02-05
Posts: 219
Website

Re: How to stop window buttons blinking?

Sorry don't know much about Debian. I'd be surprised if it wasn't available though. Probably best to ask on their forum.

Offline

#11 2013-06-09 18:59:17

haarp
Member
Registered: 2010-01-17
Posts: 10

Re: How to stop window buttons blinking?

I'm using 4.10, still the same behavior. 'Show windows from all workspaces or viewports' makes no difference.

Offline

#12 2013-06-09 20:00:02

stqn
Member
Registered: 2010-10-11
Posts: 168

Re: How to stop window buttons blinking?

Haven’t seen a window button blink in the panel for ages (Xfce 4.10). But can’t find any option to enable or disable that. It might be an option in your particular software (Iceweasel…)

Offline

#13 2013-12-12 00:19:17

roranicus
Member
Registered: 2013-12-12
Posts: 4

Re: How to stop window buttons blinking?

I'm having a similar issue using Linux Mint 15 XFCE edition. Tried everything, I can't seem to stop the buttons from blinking. I've had the problem with Firefox, Skype and Xchat.

edit: using XFCE 4.10

Last edited by roranicus (2013-12-12 00:27:13)

Offline

#14 2013-12-12 11:07:45

stqn
Member
Registered: 2010-10-11
Posts: 168

Re: How to stop window buttons blinking?

I see I wrote a few months ago that I didn’t have this problem, but now I can say I have been seeing this behaviour for the Firefox download window for a while, when a download is finished. It won’t stop blinking until I select that window. (Arch Linux so with a recent Xfce.)

Offline

#15 2013-12-12 15:09:38

haarp
Member
Registered: 2010-01-17
Posts: 10

Re: How to stop window buttons blinking?

I have posted a patch on the associated bug report that limits how often it will blink.

https://bugzilla.xfce.org/show_bug.cgi?id=9571

Offline

#16 2013-12-12 16:05:36

MountainDewManiac
Member
From: USA police-state welfare-state
Registered: 2013-03-24
Posts: 307

Re: How to stop window buttons blinking?

Can't swear to it, but I'm pretty sure the behavior you described is off by default in XFCE 4.10. I had to enable it to get it to happen. (After a few minutes, I disabled it; you're right, it's highly annoying - and I have my panels set to auto-hide when I'm not accessing them (not a clock-watcher, lol).

I'm running XFCE 4.10, with all the updates from the 4.10 & 4.12 PPAs, but it was also off by default before I added them. Using XFCE's own window manager, with composting (?) enabled.

Regarding the question about when XFCE will be in Debian's repos, it has been in their unstable or testing (I forget, whichever is farthest from oldStable) for a while, you can get it from there now. If you want to wait until that one becomes the new stable: I read a question from someone who was wondering when that one would become "Stable" (would be more technically correct to name it "Static," IMO, because as my distro updated many of the things that I've read about people having issues with, I've personally experienced more stability, not less... But Debian Stable holds onto older versions - and I keep reading about issues. But it probably saves work for them when they can just throw newer versions of everything into the unstable repo and let their users deal with it and do the testing; meanwhile, they look good to businesses - at first glance - because "We don't allow untested things into our Stable repos.")

Anyway, I did some checking, and going by the previous cycle's "time to stable," and deducting for the time that has passed since this one started, I'd guess that you're looking at between 17 to 20 months before that branch becomes the new Stable and XFCE 4.10 is available in it. Unless it is held back from the new stable, of course (I have no idea whether or not that is likely.)

(In order to help the developers and users,) should we start a list of who sees this issue - and who doesn't - and what version of XFCE (et cetera), whether they're using the default window manager or Compiz, which distro/version, and so forth? It might help determine if if this is actually an XFCE bug, an incompatibility with a third-party WM or one of its settings), or something that is being caused by the developers of one or more distros due to the way they're creating them.

Regards,
MDM

Offline

#17 2013-12-12 18:53:51

roranicus
Member
Registered: 2013-12-12
Posts: 4

Re: How to stop window buttons blinking?

haarp wrote:

I have posted a patch on the associated bug report that limits how often it will blink.

https://bugzilla.xfce.org/show_bug.cgi?id=9571


Sorry, bit of a noob. What do I do with this exactly?

I'll need step by step info as I'm still new to linux.

Thanks

Offline

#18 2013-12-17 02:45:07

roranicus
Member
Registered: 2013-12-12
Posts: 4

Re: How to stop window buttons blinking?

Sorry for the bump, but anyone had an answer to my question? I'd really like to try the fix Haarp posted but have no idea how.

Offline

#19 2013-12-18 00:33:22

Spect73
Member
Registered: 2013-10-31
Posts: 17

Re: How to stop window buttons blinking?

He posted a patch to the source code to fix the problem.  You would need to follow the link, download the patch, apply it to the source code and rebuild the package.  Do you have experience in building software packages from source?

Coordially,
Spect73


Coordially,
Spect73

Offline

#20 2013-12-18 03:47:41

roranicus
Member
Registered: 2013-12-12
Posts: 4

Re: How to stop window buttons blinking?

Not at all, sounds like too much to fix a glitch like that. Thanks for the answer though. I guess I'll have to wait for an update.

Offline

#21 2013-12-22 21:35:34

jlct021
Member
Registered: 2013-12-20
Posts: 5

Re: How to stop window buttons blinking?

@haarp: Thanks!

@roranicus: Here's what worked for me:  (Debian Jessie)

su
mkdir /tmp/panel
cd /tmp/panel
apt-get source xfce4-panel
cd xfce4-panel-4.10.1
wget http://bug-attachment.xfce.org/attachment.cgi?id=5152
patch -p1 < attachment.cgi?id=5152
libxfce4panel/xfce-arrow-button.c
vi debian/source/format 
#change (quilt) to (native)
:wq!                                                         
apt-get build-dep xfce4-panel
apt-get install devscripts build-essential fakeroot
exit                                                                 
debuild -us -uc
cd ..
dpkg --install xfce4-panel_4.10.1-1_amd64.deb
su
shutdown -r now

#note:
#not changing (quilt) to (native) in: 'debian/source/format' resulted in:
# 'dpkg-source: error: aborting due to unexpected upstream changes' after:
#debuild -us -uc
#references:
#Rebuilding Debian packages:

  http://www.debian-administration.org/articles/20

Last edited by jlct021 (2013-12-22 21:41:11)

Offline

#22 2014-01-08 17:53:55

jeanphil
Member
Registered: 2011-10-21
Posts: 3

Re: How to stop window buttons blinking?

On Xubunu 13.10 (xfce 4.10), if I set Focus/When a window raises itself to "Do nothing" in the Window Manager Tweaks application, the problem goes away.

Offline

Board footer

Powered by FluxBB